Update to 4.19.20

This commit is contained in:
Marcin Juszkiewicz 2019-02-06 19:10:57 +00:00
parent 954102fe6b
commit 8f73ffdafe
3 changed files with 78 additions and 40 deletions

79
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.19.19-1) UNRELEASED; urgency=medium
linux (4.19.20-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.17
@ -300,6 +300,83 @@ linux (4.19.19-1) UNRELEASED; urgency=medium
- usb: dwc3: gadget: Clear req->needs_extra_trb flag on cleanup
- ide: fix a typo in the settings proc file name
- Input: input_event - fix the CONFIG_SPARC64 mixup
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.20
- Fix "net: ipv4: do not handle duplicate fragments as overlapping"
- drm/msm/gpu: fix building without debugfs
- ipv6: Consider sk_bound_dev_if when binding a socket to an address
- ipv6: sr: clear IP6CB(skb) on SRH ip4ip6 encapsulation
- ipvlan, l3mdev: fix broken l3s mode wrt local routes
- l2tp: copy 4 more bytes to linear part if necessary
- l2tp: fix reading optional fields of L2TPv3
- net: ip_gre: always reports o_key to userspace
- net: ip_gre: use erspan key field for tunnel lookup
- net/mlx4_core: Add masking for a few queries on HCA caps
- netrom: switch to sock timer API
- net/rose: fix NULL ax25_cb kernel panic
- net: set default network namespace in init_dummy_netdev()
- ravb: expand rx descriptor data to accommodate hw checksum
- sctp: improve the events for sctp stream reset
- tun: move the call to tun_set_real_num_queues
- ucc_geth: Reset BQL queue when stopping device
- vhost: fix OOB in get_rx_bufs()
- net: ip6_gre: always reports o_key to userspace
- sctp: improve the events for sctp stream adding
- net/mlx5e: Allow MAC invalidation while spoofchk is ON
- ip6mr: Fix notifiers call on mroute_clean_tables()
- Revert "net/mlx5e: E-Switch, Initialize eswitch only if eswitch manager"
- sctp: set chunk transport correctly when it's a new asoc
- sctp: set flow sport from saddr only when it's 0
- virtio_net: Don't enable NAPI when interface is down
- virtio_net: Don't call free_old_xmit_skbs for xdp_frames
- virtio_net: Fix not restoring real_num_rx_queues
- virtio_net: Fix out of bounds access of sq
- virtio_net: Don't process redirected XDP frames when XDP is disabled
- virtio_net: Use xdp_return_frame to free xdp_frames on destroying vqs
- virtio_net: Differentiate sk_buff and xdp_frame on freeing
- CIFS: Do not count -ENODATA as failure for query directory
- CIFS: Fix trace command logging for SMB2 reads and writes
- CIFS: Do not consider -ENODATA as stat failure for reads
- fs/dcache: Fix incorrect nr_dentry_unused accounting in
shrink_dcache_sb()
- iommu/vt-d: Fix memory leak in intel_iommu_put_resv_regions()
- selftests/seccomp: Enhance per-arch ptrace syscall skip tests
- NFS: Fix up return value on fatal errors in nfs_page_async_flush()
- ARM: cns3xxx: Fix writing to wrong PCI config registers after alignment
- arm64: kaslr: ensure randomized quantities are clean also when kaslr is
off
- arm64: Do not issue IPIs for user executable ptes
- arm64: hyp-stub: Forbid kprobing of the hyp-stub
- arm64: hibernate: Clean the __hyp_text to PoC after resume
- gpio: altera-a10sr: Set proper output level for direction_output
- gpiolib: fix line event timestamps for nested irqs
- gpio: pcf857x: Fix interrupts on multiple instances
- gpio: sprd: Fix the incorrect data register
- gpio: sprd: Fix incorrect irq type setting for the async EIC
- gfs2: Revert "Fix loop in gfs2_rbm_find"
- mmc: bcm2835: Fix DMA channel leak on probe error
- mmc: mediatek: fix incorrect register setting of hs400_cmd_int_delay
- ALSA: usb-audio: Add Opus #3 to quirks for native DSD support
- ALSA: hda/realtek - Fixed hp_pin no value
- IB/hfi1: Remove overly conservative VM_EXEC flag check
- platform/x86: asus-nb-wmi: Map 0x35 to KEY_SCREENLOCK
- platform/x86: asus-nb-wmi: Drop mapping of 0x33 and 0x34 scan codes
- mmc: sdhci-iproc: handle mmc_of_parse() errors during probe
- Btrfs: fix deadlock when allocating tree block during leaf/node split
- btrfs: On error always free subvol_name in btrfs_mount
- kernel/exit.c: release ptraced tasks before zap_pid_ns_processes
- mm/hugetlb.c: teach follow_hugetlb_page() to handle FOLL_NOWAIT
- oom, oom_reaper: do not enqueue same task twice
- mm,memory_hotplug: fix scan_movable_pages() for gigantic hugepages
- mm, oom: fix use-after-free in oom_kill_process
- mm: hwpoison: use do_send_sig_info() instead of force_sig()
- mm: migrate: don't rely on __PageMovable() of newpage after unlocking it
- of: Convert to using %pOFn instead of device_node.name
- of: overlay: add tests to validate kfrees from overlay removal
- of: overlay: add missing of_node_get() in __of_attach_node_sysfs
- of: overlay: use prop add changeset entry for property in new nodes
- of: overlay: do not duplicate properties from overlay for new nodes
- md/raid5: fix 'out of memory' during raid cache recovery
- cifs: Always resolve hostname before reconnecting
[ Luca Boccassi ]
* Do not generate linux-source-$ver stanza in debian/control if

View File

@ -1,38 +0,0 @@
From: David Ahern <dsahern@gmail.com>
Date: Wed, 2 Jan 2019 18:57:09 -0800
Subject: ipv6: Consider sk_bound_dev_if when binding a socket to an address
Origin: https://git.kernel.org/linus/c5ee066333ebc322a24a00a743ed941a0c68617e
Bug-Debian: https://bugs.debian.org/918103
IPv6 does not consider if the socket is bound to a device when binding
to an address. The result is that a socket can be bound to eth0 and then
bound to the address of eth1. If the device is a VRF, the result is that
a socket can only be bound to an address in the default VRF.
Resolve by considering the device if sk_bound_dev_if is set.
This problem exists from the beginning of git history.
Signed-off-by: David Ahern <dsahern@gmail.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
net/ipv6/af_inet6.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/net/ipv6/af_inet6.c b/net/ipv6/af_inet6.c
index f0cd291034f0..0bfb6cc0a30a 100644
--- a/net/ipv6/af_inet6.c
+++ b/net/ipv6/af_inet6.c
@@ -350,6 +350,9 @@ static int __inet6_bind(struct sock *sk, struct sockaddr *uaddr, int addr_len,
err = -EINVAL;
goto out_unlock;
}
+ }
+
+ if (sk->sk_bound_dev_if) {
dev = dev_get_by_index_rcu(net, sk->sk_bound_dev_if);
if (!dev) {
err = -ENODEV;
--
2.20.1

View File

@ -99,7 +99,6 @@ bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
debian/revert-objtool-fix-config_stack_validation-y-warning.patch
bugfix/all/ipv6-Consider-sk_bound_dev_if-when-binding-a-socket-.patch
# Miscellaneous features