[armel] dts: marvell: fix number of sata port for linkstation ls-gl

Closes: #845611
This commit is contained in:
Roger Shimizu 2016-12-06 08:38:19 +09:00
parent 086dccbdfe
commit 8f06e2bdc6
3 changed files with 43 additions and 0 deletions

5
debian/changelog vendored
View File

@ -1,7 +1,12 @@
linux (4.8.11-2) UNRELEASED; urgency=medium
[ Uwe Kleine-König ]
* [armhf] dts: armada-385: add support for Turris Omnia
[ Roger Shimizu ]
* [armel] dts: marvell: fix number of sata port for linkstation ls-gl
(Closes: #845611)
-- Uwe Kleine-König <ukleinek@debian.org> Sun, 04 Dec 2016 21:16:06 +0100
linux (4.8.11-1) unstable; urgency=medium

View File

@ -0,0 +1,37 @@
From: Roger Shimizu <rogershimizu@gmail.com>
Date: Fri, 2 Dec 2016 00:11:12 +0900
Subject: [PATCH] ARM: dts: orion5x: fix number of sata port for linkstation
ls-gl
Origin: http://git.infradead.org/linux-mvebu.git/commit/b150e59f1d217473b3eab354a9e5e9fe907868ff
Bug report from Debian [0] shows there's minor changed model of
Linkstation LS-GL that uses the 2nd SATA port of the SoC.
So it's necessary to enable two SATA ports, though for that specific
model only the 2nd one is used.
[0] https://bugs.debian.org/845611
Fixes: b1742ffa9ddb ("ARM: dts: orion5x: add device tree for buffalo linkstation ls-gl")
Reported-by: Ryan Tandy <ryan@nardis.ca>
Tested-by: Ryan Tandy <ryan@nardis.ca>
Signed-off-by: Roger Shimizu <rogershimizu@gmail.com>
Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
---
arch/arm/boot/dts/orion5x-linkstation-lsgl.dts | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/arch/arm/boot/dts/orion5x-linkstation-lsgl.dts b/arch/arm/boot/dts/orion5x-linkstation-lsgl.dts
index 1cf644b..51dc734 100644
--- a/arch/arm/boot/dts/orion5x-linkstation-lsgl.dts
+++ b/arch/arm/boot/dts/orion5x-linkstation-lsgl.dts
@@ -82,6 +82,10 @@
gpios = <&gpio0 9 GPIO_ACTIVE_HIGH>;
};
+&sata {
+ nr-ports = <2>;
+};
+
&ehci1 {
status = "okay";
};

View File

@ -56,6 +56,7 @@ features/x86/x86-memtest-WARN-if-bad-RAM-found.patch
features/x86/x86-make-x32-syscall-support-conditional.patch
features/arm/arm-dts-imx53-add-support-for-usb-armory-board.patch
features/arm/arm-dts-add-support-for-turris-omnia.patch
features/arm/arm-dts-orion5x-fix-number-of-sata-port-for-linkstation-ls-gl.patch
# Miscellaneous bug fixes
bugfix/all/kbuild-use-nostdinc-in-compile-tests.patch