update to 4.19.26

This commit is contained in:
Marcin Juszkiewicz 2019-02-27 19:39:23 +01:00
parent 1b33d3e00b
commit 8e3ab60ac6
2 changed files with 138 additions and 2 deletions

138
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.19.25-1) UNRELEASED; urgency=medium
linux (4.19.26-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.21
@ -465,6 +465,142 @@ linux (4.19.25-1) UNRELEASED; urgency=medium
(CVE-2019-9162)
- net/x25: do not hold the cpu too long in x25_new_lci()
- ax25: fix possible use-after-free
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.26
- [armel armhf] 8834/1: Fix: kprobes: optimized kprobes illegal instruction
- tracing: Fix number of entries in trace header
- [mips*] eBPF: Always return sign extended 32b values
- [armel] gpio: pxa: avoid attempting to set pin direction via pinctrl on
MMP2
- mac80211: Restore vif beacon interval if start ap fails
- mac80211: Use linked list instead of rhashtable walk for mesh tables
- mac80211: Free mpath object when rhashtable insertion fails
- libceph: handle an empty authorize reply
- ceph: avoid repeatedly adding inode to mdsc->snap_flush_list
- numa: change get_mempolicy() to use nr_node_ids instead of MAX_NUMNODES
- proc, oom: do not report alien mms when setting oom_score_adj
- [x86] ALSA: hda/realtek - Headset microphone and internal speaker
support for System76 oryp5
- [x86] ALSA: hda/realtek: Disable PC beep in passthrough on alc285
- KEYS: allow reaching the keys quotas exactly
- backlight: pwm_bl: Fix devicetree parsing with auto-generated brightness
tables
- [armhf] mfd: ti_am335x_tscadc: Use PLATFORM_DEVID_AUTO while registering
mfd cells
- pvcalls-front: read all data before closing the connection
- pvcalls-front: don't try to free unallocated rings
- pvcalls-front: properly allocate sk
- pvcalls-back: set -ENOTCONN in pvcalls_conn_back_read
- mfd: twl-core: Fix section annotations on {,un}protect_pm_master
- mfd: db8500-prcmu: Fix some section annotations
- mfd: ab8500-core: Return zero in get_register_interruptible()
- mfd: qcom_rpm: write fw_version to CTRL_REG
- mfd: wm5110: Add missing ASRC rate register
- mfd: axp20x: Add AC power supply cell for AXP813
- mfd: axp20x: Re-align MFD cell entries
- mfd: axp20x: Add supported cells for AXP803
- mfd: cros_ec_dev: Add missing mfd_remove_devices() call in remove
- mfd: tps65218: Use devm_regmap_add_irq_chip and clean up error path in
probe()
- mfd: mc13xxx: Fix a missing check of a register-read failure
- qed: Fix qed_chain_set_prod() for PBL chains with non power of 2 page
count
- qed: Fix qed_ll2_post_rx_buffer_notify_fw() by adding a write memory
barrier
- net: hns: Fix use after free identified by SLUB debug
- bpf: Fix [::] -> [::1] rewrite in sys_sendmsg
- selftests/bpf: Test [::] -> [::1] rewrite in sys_sendmsg in
test_sock_addr
- watchdog: mt7621_wdt/rt2880_wdt: Fix compilation problem
- net/mlx4: Get rid of page operation after dma_alloc_coherent
- xprtrdma: Double free in rpcrdma_sendctxs_create()
- mlxsw: spectrum_acl: Add cleanup after C-TCAM update error condition
- selftests: forwarding: Add a test for VLAN deletion
- netfilter: nf_tables: fix leaking object reference count
- scsi: qla4xxx: check return code of qla4xxx_copy_from_fwddb_param
- scsi: isci: initialize shost fully before calling scsi_add_host()
- include/linux/compiler*.h: fix OPTIMIZER_HIDE_VAR
- netfilter: nft_flow_offload: Fix reverse route lookup
- bpf: correctly set initial window on active Fast Open sender
- bpf: fix panic in stack_map_get_build_id() on i386 and arm32
- netfilter: nft_flow_offload: fix interaction with vrf slave device
- RDMA/mthca: Clear QP objects during their allocation
- powerpc/8xx: fix setting of pagetable for Abatron BDI debug tool.
- acpi/nfit: Fix race accessing memdev in nfit_get_smbios_id()
- net: stmmac: Fix PCI module removal leak
- net: stmmac: dwxgmac2: Only clear interrupts that are active
- net: stmmac: Check if CBS is supported before configuring
- net: stmmac: Fix the logic of checking if RX Watchdog must be enabled
- net: stmmac: Prevent RX starvation in stmmac_napi_poll()
- isdn: i4l: isdn_tty: Fix some concurrency double-free bugs
- scsi: tcmu: avoid cmd/qfull timers updated whenever a new cmd comes
- scsi: ufs: Fix system suspend status
- scsi: qedi: Add ep_state for login completion on un-reachable targets
- scsi: ufs: Fix geometry descriptor size
- scsi: cxgb4i: add wait_for_completion()
- netfilter: nft_flow_offload: fix checking method of conntrack helper
- always clear the X2APIC_ENABLE bit for PV guest
- [armhf, arm64] drm/meson: add missing of_node_put
- drm/amdkfd: Don't assign dGPUs to APU topology devices
- drm/amd/display: fix PME notification not working in RV desktop
- vhost: return EINVAL if iovecs size does not match the message size
- [armhf, arm64] drm/sun4i: backend: add missing of_node_puts
- bpf: don't assume build-id length is always 20 bytes
- bpf: zero out build_id for BPF_STACK_BUILD_ID_IP
- atm: he: fix sign-extension overflow on large shift
- hwmon: (tmp421) Correct the misspelling of the tmp442 compatible
attribute in OF device ID table
- [armhf] leds: lp5523: fix a missing check of return value of lp55xx_read
- bpf: bpf_setsockopt: reset sock dst on SO_MARK changes
- dpaa_eth: NETIF_F_LLTX requires to do our own update of trans_start
- mlxsw: pci: Return error on PCI reset timeout
- net: bridge: Mark FDB entries that were added by user as such
- mlxsw: spectrum_switchdev: Do not treat static FDB entries as sticky
- net/mlx5e: Fix wrong (zero) TX drop counter indication for representor
- isdn: avm: Fix string plus integer warning from Clang
- batman-adv: fix uninit-value in batadv_interface_tx()
- inet_diag: fix reporting cgroup classid and fallback to priority
- ipv6: propagate genlmsg_reply return code
- net: ena: fix race between link up and device initalization
- net/mlx4_en: Force CHECKSUM_NONE for short ethernet frames
- net/mlx5e: Don't overwrite pedit action when multiple pedit used
- net/packet: fix 4gb buffer limit due to overflow check
- net: sfp: do not probe SFP module before we're attached
- sctp: call gso_reset_checksum when computing checksum in sctp_gso_segment
- sctp: set stream ext to NULL after freeing it in sctp_stream_outq_migrate
- team: avoid complex list operations in team_nl_cmd_options_set()
- Revert "socket: fix struct ifreq size in compat ioctl"
- Revert "kill dev_ifsioc()"
- net: socket: fix SIOCGIFNAME in compat
- net: socket: make bond ioctls go through compat_ifreq_ioctl()
- geneve: should not call rt6_lookup() when ipv6 was disabled
- sit: check if IPv6 enabled before calling ip6_err_gen_icmpv6_unreach()
- net_sched: fix a race condition in tcindex_destroy()
- net_sched: fix a memory leak in cls_tcindex
- net_sched: fix two more memory leaks in cls_tcindex
- net/mlx5e: XDP, fix redirect resources availability check
- RDMA/srp: Rework SCSI device reset handling
- KEYS: user: Align the payload buffer
- KEYS: always initialize keyring_index_key::desc_len
- drm/amdgpu: Set DPM_FLAG_NEVER_SKIP when enabling PM-runtime
- gpu: drm: radeon: Set DPM_FLAG_NEVER_SKIP when enabling PM-runtime
- [x86] drm/i915/fbdev: Actually configure untiled displays
- drm/amd/display: Fix MST reboot/poweroff sequence
- mac80211: allocate tailroom for forwarded mesh packets
- [x86] kvm: Return LA57 feature based on hardware capability
- net: validate untrusted gso packets without csum offload
- net: avoid false positives in untrusted gso validation
- Revert "bridge: do not add port to router list when receives query with
source 0.0.0.0"
- netfilter: nf_tables: fix flush after rule deletion in the same batch
- netfilter: nft_compat: use-after-free when deleting targets
- netfilter: ipv6: Don't preserve original oif for loopback address
- netfilter: nfnetlink_osf: add missing fmatch check
- netfilter: ipt_CLUSTERIP: fix sleep-in-atomic bug in
clusterip_config_entry_put()
- udlfb: handle unplug properly
- [armhf arm64] pinctrl: max77620: Use define directive for
max77620_pinconf_param values
- net: phylink: avoid resolving link state too early
[ Ben Hutchings ]
* [sparc64] udeb: Use standard module list in nic-modules; add i2c-modules

View File

@ -473,8 +473,8 @@ index e732bd2ddd32..fcdfaf0ab8a7 100644
return NETDEV_TX_OK;
}
@@ -2621,7 +2670,9 @@ static int ena_restore_device(struct ena_adapter *adapter)
netif_carrier_on(adapter->netdev);
set_bit(ENA_FLAG_DEVICE_RUNNING, &adapter->flags);
mod_timer(&adapter->timer_service, round_jiffies(jiffies + HZ));
- dev_err(&pdev->dev, "Device reset completed successfully\n");
+ dev_err(&pdev->dev,