Update to 3.2-rc3

svn path=/dists/trunk/linux-2.6/; revision=18319
This commit is contained in:
Ben Hutchings 2011-11-26 03:33:20 +00:00
parent fb649e9731
commit 8de56753df
4 changed files with 3 additions and 91 deletions

5
debian/changelog vendored
View File

@ -1,7 +1,8 @@
linux-2.6 (3.2~rc2-1~experimental.1) UNRELEASED; urgency=low
linux-2.6 (3.2~rc3-1~experimental.1) UNRELEASED; urgency=low
* New upstream release candidate
[ Ben Hutchings ]
* New upstream release candidate
* aufs: Update to aufs3.x-rcN-20111114
* ieee802154: Enable IEEE802154_6LOWPAN as module
* can: Enable CAN_GW, CAN_EMS_PCMCIA, CAN_PEAK_PCI as modules

View File

@ -1,53 +0,0 @@
Date: Wed, 26 Oct 2011 13:29:42 +0200
From: Bart Hartgers <bart.hartgers@gmail.com>
Subject: [PATCH] ark3116 initialisation fix
Hi,
This patch for the usb serial ark3116 driver fixes an initialisation
ordering bug that gets triggered on hotplug when using at least recent
debian/ubuntu userspace. Without it, ark3116 serial cables don't work.
Patch is against 3.1.
Groeten,
Bart
Signed-off-by: Bart Hartgers <bart.hartgers@gmail.com>
Tested-by: law_ence.dev@ntlworld.com
---
diff -ur linux-3.1.orig//drivers/usb/serial/ark3116.c linux-3.1/drivers/usb/serial/ark3116.c
--- linux-3.1.orig//drivers/usb/serial/ark3116.c 2011-10-24 09:10:05.000000000 +0200
+++ linux-3.1/drivers/usb/serial/ark3116.c 2011-10-26 09:16:41.776874595 +0200
@@ -42,7 +42,7 @@
* Version information
*/
-#define DRIVER_VERSION "v0.6"
+#define DRIVER_VERSION "v0.7"
#define DRIVER_AUTHOR "Bart Hartgers <bart.hartgers+ark3116@gmail.com>"
#define DRIVER_DESC "USB ARK3116 serial/IrDA driver"
#define DRIVER_DEV_DESC "ARK3116 RS232/IrDA"
@@ -380,10 +380,6 @@
goto err_out;
}
- /* setup termios */
- if (tty)
- ark3116_set_termios(tty, port, NULL);
-
/* remove any data still left: also clears error state */
ark3116_read_reg(serial, UART_RX, buf);
@@ -406,6 +402,10 @@
/* enable DMA */
ark3116_write_reg(port->serial, UART_FCR, UART_FCR_DMA_SELECT);
+ /* setup termios */
+ if (tty)
+ ark3116_set_termios(tty, port, NULL);
+
err_out:
kfree(buf);
return result;

View File

@ -1,34 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 13 Nov 2011 18:42:46 +0000
Subject: [PATCH] block: Always check length of all iov entries in
blk_rq_map_user_iov()
Even after commit 5478755616ae2ef1ce144dded589b62b2a50d575
("block: check for proper length of iov entries earlier ...")
we still won't check for zero-length entries after an unaligned
entry. Remove the break-statement, so all entries are checked.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
block/blk-map.c | 4 +---
1 files changed, 1 insertions(+), 3 deletions(-)
diff --git a/block/blk-map.c b/block/blk-map.c
index e663ac2..2e852a4 100644
--- a/block/blk-map.c
+++ b/block/blk-map.c
@@ -204,10 +204,8 @@ int blk_rq_map_user_iov(struct request_queue *q, struct request *rq,
if (!iov[i].iov_len)
return -EINVAL;
- if (uaddr & queue_dma_alignment(q)) {
+ if (uaddr & queue_dma_alignment(q))
unaligned = 1;
- break;
- }
}
if (unaligned || (q->dma_pad_mask & len) || map_data)
--
1.7.7.2

View File

@ -39,9 +39,7 @@
+ features/all/cgroups-Allow-memory-cgroup-support-to-be-included-b.patch
+ debian/cgroups-Document-the-Debian-memory-resource-controll.patch
+ bugfix/ia64/nouveau-ACPI-support-is-dependent-on-X86.patch
+ bugfix/all/ark3116-initialisation-fix.patch
+ bugfix/all/oom-fix-integer-overflow-of-points-in-oom_badness.patch
+ bugfix/all/block-Always-check-length-of-all-iov-entries-in-blk_.patch
+ features/x86/x86-Add-amilo-rfkill-driver-for-some-Fujitsu-Siemens.patch
# Defer until we're sure about the system call number