[armhf] Enable cpufreq on some sunxi platforms (Closes: #793185)

svn path=/dists/sid/linux/; revision=22926
This commit is contained in:
Ian Campbell 2015-08-04 21:10:12 +00:00
parent f2378f0aa3
commit 8db2f2efff
4 changed files with 73 additions and 0 deletions

9
debian/changelog vendored
View File

@ -1,3 +1,12 @@
linux (4.1.3-2) UNRELEASED; urgency=medium
[ Ian Campbell ]
* [armhf] Enable cpufreq on some sunxi platforms (Closes: #793185)
- Enable autoloading of the cpufreq-dt driver.
- Enable autoloading of AXP20x regulator driver.
-- Ian Campbell <ijc@debian.org> Tue, 04 Aug 2015 19:31:45 +0100
linux (4.1.3-1) unstable; urgency=medium
* New upstream stable update:

View File

@ -0,0 +1,32 @@
From 07949bf9c63c9a80027fe8452d5fe8b9ba9b3c23 Mon Sep 17 00:00:00 2001
From: Felipe Balbi <balbi@ti.com>
Date: Fri, 8 May 2015 14:57:30 -0500
Subject: [PATCH] cpufreq: dt: allow driver to boot automatically
Origin: http://git.kernel.org/linus/07949bf9c63c9a80027fe8452d5fe8b9ba9b3c23
by adding the missing MODULE_ALIAS(), cpufreq-dt
can be autoloaded by udev/systemd.
Signed-off-by: Felipe Balbi <balbi@ti.com>
Acked-by: Nishanth Menon <nm@ti.com>
Acked-by: Viresh Kumar <viresh.kumar@linaro.org>
Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
---
drivers/cpufreq/cpufreq-dt.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/cpufreq/cpufreq-dt.c b/drivers/cpufreq/cpufreq-dt.c
index bab67db..528a82bf 100644
--- a/drivers/cpufreq/cpufreq-dt.c
+++ b/drivers/cpufreq/cpufreq-dt.c
@@ -416,6 +416,7 @@ static struct platform_driver dt_cpufreq_platdrv = {
};
module_platform_driver(dt_cpufreq_platdrv);
+MODULE_ALIAS("platform:cpufreq-dt");
MODULE_AUTHOR("Viresh Kumar <viresh.kumar@linaro.org>");
MODULE_AUTHOR("Shawn Guo <shawn.guo@linaro.org>");
MODULE_DESCRIPTION("Generic cpufreq driver");
--
2.1.4

View File

@ -0,0 +1,30 @@
From d4ea7d86457a8d0ea40ce77bdeda1fc966cc35ec Mon Sep 17 00:00:00 2001
From: Ian Campbell <ijc@hellion.org.uk>
Date: Sat, 1 Aug 2015 18:13:25 +0100
Subject: [PATCH] regulator: axp20x: Add module alias
Origin: https://git.kernel.org/broonie/regulator/c/d4ea7d86457a8d0ea40ce77bdeda1fc966cc35ec
This allows the module to be autoloaded.
Together with 07949bf9c63c ("cpufreq: dt: allow driver to boot
automatically") this is sufficient to allow a modular kernel (such
as Debian's) to enable cpufreq on a Cubietruck.
Signed-off-by: Ian Campbell <ijc@hellion.org.uk>
Signed-off-by: Mark Brown <broonie@kernel.org>
---
drivers/regulator/axp20x-regulator.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/regulator/axp20x-regulator.c b/drivers/regulator/axp20x-regulator.c
index 6468291..01bf347 100644
--- a/drivers/regulator/axp20x-regulator.c
+++ b/drivers/regulator/axp20x-regulator.c
@@ -405,3 +405,4 @@ module_platform_driver(axp20x_regulator_driver);
MODULE_LICENSE("GPL v2");
MODULE_AUTHOR("Carlo Caione <carlo@caione.org>");
MODULE_DESCRIPTION("Regulator Driver for AXP20X PMIC");
+MODULE_ALIAS("platform:axp20x-regulator");
--
2.1.4

View File

@ -78,6 +78,8 @@ bugfix/all/kernel-doc-set-man-page-date.patch
# Miscellaneous features
features/all/efi-autoload-efi-pstore.patch
features/all/cpufreq-dt-allow-driver-to-boot-automatically.patch
features/all/regulator-axp20x-Add-module-alias.patch
bugfix/x86/kvm-x86-fix-kvm_apic_has_events-to-check-for-null-po.patch
bugfix/x86/0003-x86-asm-entry-64-Remove-pointless-jump-to-irq_return.patch