liblockdep: Define pr_cont()

This commit is contained in:
Ben Hutchings 2017-10-01 15:44:25 +01:00
parent 60879f2bae
commit 884aedc0b4
3 changed files with 27 additions and 0 deletions

1
debian/changelog vendored
View File

@ -33,6 +33,7 @@ linux (4.13.4-1~exp1) UNRELEASED; urgency=medium
* [armhf] dts: exynos: Add dwc3 SUSPHY quirk (Closes: #843448)
* liblockdep: Make missing function declarations fatal errors, to catch use
of missing kernel APIs
* liblockdep: Define pr_cont()
[ Uwe Kleine-König ]
* [arm64] really enable NET_DSA_MV88E6XXX for Espressobin

View File

@ -0,0 +1,25 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 01 Oct 2017 15:39:34 +0100
Subject: tools/lib/lockdep: Define pr_cont()
lockdep.c now also uses pr_cont(), so we need to implement it in
liblockdep.
It is currently always used to continue warning lines, so define
pr_cont() the same as pr_warn(). If this changes, we might need to
record the last log level in a TLS variable and have pr_cont() check
that.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/include/linux/lockdep.h
+++ b/tools/include/linux/lockdep.h
@@ -47,6 +47,8 @@ static inline int debug_locks_off(void)
#define printk(...) dprintf(STDOUT_FILENO, __VA_ARGS__)
#define pr_err(format, ...) fprintf (stderr, format, ## __VA_ARGS__)
#define pr_warn pr_err
+/* XXX we assume pr_cont() is only used for warnings */
+#define pr_cont pr_warn
#define list_del_rcu list_del

View File

@ -136,3 +136,4 @@ bugfix/x86/revert-perf-build-fix-libunwind-feature-detection-on.patch
bugfix/all/tools-build-remove-bpf-run-time-check-at-build-time.patch
bugfix/all/cpupower-bump-soname-version.patch
bugfix/all/cpupower-fix-checks-for-cpu-existence.patch
bugfix/all/tools-lib-lockdep-define-pr_cont.patch