Update to 3.2.35

svn path=/dists/sid/linux/; revision=19586
This commit is contained in:
Jonathan Nieder 2012-12-09 04:36:22 +00:00
parent e9488bea16
commit 87fbfef5e8
4 changed files with 19 additions and 111 deletions

9
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (3.2.34-1) UNRELEASED; urgency=low
linux (3.2.35-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.33
@ -54,6 +54,11 @@ linux (3.2.34-1) UNRELEASED; urgency=low
- af-packet: fix oops when socket is not present
- r8169: Fix WoL on RTL8168d/8111d. (Closes: #674154)
- sky2: Fix for interrupt handler (Closes: #681280)
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.35
- Input: i8042 - also perform controller reset when suspending
(Closes: #693934)
- [x86] mce, therm_throt: Don't report power limit and package level
thermal throttle events in mcelog (Closes: #695209)
[ Ben Hutchings ]
* [x86] udeb: Re-add isci to scsi-extra-modules (Closes: #690886;
@ -82,8 +87,6 @@ linux (3.2.34-1) UNRELEASED; urgency=low
* usb: Disable UAS; it is known to be broken, and the supported devices
can also work with usb-storage
* ipv6: Treat ND option 31 as userland (DNSSL support) (Closes: #694522)
* Input: i8042 - also perform controller reset when suspending
(Closes: #693934)
* rt2x00: Add device IDs 5362, 5392, 539b (Closes: #694312)
* udeb: Add pata_piccolo to pata-modules (Closes: #695437)

View File

@ -1,105 +0,0 @@
From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Date: Sat, 29 Oct 2011 12:37:06 -0700
Subject: Input: i8042 - also perform controller reset when suspending
commit 1729ad1f4f9e167ade84ca8b5269695c42351160 upstream.
In addition to some laptops needing i8042 reset after resuming from S2R to
get their touchpads working there is another class of laptops - ones that
need i8042 reset before going to S2R, otherwise they will simply reboot
instead of resuming.
See https://bugzilla.kernel.org/show_bug.cgi?id=15612
This change forces reset of i8042 before doing S2R.
Reported-by: Stefan Koch <stefan_koch@gmx.net>
Tested-by: Alexander van Loon <a.vanloon@alexandervanloon.nl>
Signed-off-by: Dmitry Torokhov <dtor@mail.ru>
---
drivers/input/serio/i8042.c | 23 +++++++++++++++--------
1 file changed, 15 insertions(+), 8 deletions(-)
diff --git a/drivers/input/serio/i8042.c b/drivers/input/serio/i8042.c
index d37a48e..8656441 100644
--- a/drivers/input/serio/i8042.c
+++ b/drivers/input/serio/i8042.c
@@ -991,7 +991,7 @@ static int i8042_controller_init(void)
* Reset the controller and reset CRT to the original value set by BIOS.
*/
-static void i8042_controller_reset(void)
+static void i8042_controller_reset(bool force_reset)
{
i8042_flush();
@@ -1016,7 +1016,7 @@ static void i8042_controller_reset(void)
* Reset the controller if requested.
*/
- if (i8042_reset)
+ if (i8042_reset || force_reset)
i8042_controller_selftest();
/*
@@ -1139,9 +1139,9 @@ static int i8042_controller_resume(bool force_reset)
* upsetting it.
*/
-static int i8042_pm_reset(struct device *dev)
+static int i8042_pm_suspend(struct device *dev)
{
- i8042_controller_reset();
+ i8042_controller_reset(true);
return 0;
}
@@ -1163,13 +1163,20 @@ static int i8042_pm_thaw(struct device *dev)
return 0;
}
+static int i8042_pm_reset(struct device *dev)
+{
+ i8042_controller_reset(false);
+
+ return 0;
+}
+
static int i8042_pm_restore(struct device *dev)
{
return i8042_controller_resume(false);
}
static const struct dev_pm_ops i8042_pm_ops = {
- .suspend = i8042_pm_reset,
+ .suspend = i8042_pm_suspend,
.resume = i8042_pm_resume,
.thaw = i8042_pm_thaw,
.poweroff = i8042_pm_reset,
@@ -1185,7 +1192,7 @@ static const struct dev_pm_ops i8042_pm_ops = {
static void i8042_shutdown(struct platform_device *dev)
{
- i8042_controller_reset();
+ i8042_controller_reset(false);
}
static int __init i8042_create_kbd_port(void)
@@ -1424,7 +1431,7 @@ static int __init i8042_probe(struct platform_device *dev)
out_fail:
i8042_free_aux_ports(); /* in case KBD failed but AUX not */
i8042_free_irqs();
- i8042_controller_reset();
+ i8042_controller_reset(false);
i8042_platform_device = NULL;
return error;
@@ -1434,7 +1441,7 @@ static int __devexit i8042_remove(struct platform_device *dev)
{
i8042_unregister_ports();
i8042_free_irqs();
- i8042_controller_reset();
+ i8042_controller_reset(false);
i8042_platform_device = NULL;
return 0;

View File

@ -61,7 +61,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Set this flag for states where the HW flushes the TLB for us
* and so we don't need cross-calls to keep it consistent.
* If this flag is set, SW flushes the TLB, so even if the
@@ -320,27 +326,72 @@
@@ -320,27 +326,78 @@
unsigned long long msr_bits;
rdmsrl(MSR_NHM_SNB_PKG_CST_CFG_CTL, msr_bits);
@ -92,6 +92,10 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
+ .state_table = snb_cstates,
+};
+
+static const struct idle_cpu idle_cpu_ivb = {
+ .state_table = ivb_cstates,
+};
+
+#define ICPU(model, cpu) \
+ { X86_VENDOR_INTEL, 6, model, X86_FEATURE_MWAIT, (unsigned long)&cpu }
+
@ -107,6 +111,8 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
+ ICPU(0x2f, idle_cpu_westmere),
+ ICPU(0x2a, idle_cpu_snb),
+ ICPU(0x2d, idle_cpu_snb),
+ ICPU(0x3a, idle_cpu_ivb),
+ ICPU(0x3e, idle_cpu_ivb),
+ {}
+};
+MODULE_DEVICE_TABLE(x86cpu, intel_idle_ids);
@ -139,7 +145,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
if (boot_cpu_data.cpuid_level < CPUID_MWAIT_LEAF)
return -ENODEV;
@@ -354,43 +405,8 @@
@@ -354,48 +405,8 @@
pr_debug(PREFIX "MWAIT substates: 0x%x\n", mwait_substates);
@ -175,6 +181,11 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
- cpuidle_state_table = snb_cstates;
- break;
-
- case 0x3A: /* IVB */
- case 0x3E: /* IVB Xeon */
- cpuidle_state_table = ivb_cstates;
- break;
-
- default:
- pr_debug(PREFIX "does not run on family %d model %d\n",
- boot_cpu_data.x86, boot_cpu_data.x86_model);

View File

@ -413,7 +413,6 @@ debian/ALSA-avoid-ABI-change-in-3.2.34.patch
debian/rtnetlink-avoid-ABI-change-in-3.2.34.patch
debian/mm-avoid-ABI-change-in-3.2.33.patch
features/all/ipv6-Treat-ND-option-31-as-userland-DNSSL-support.patch
bugfix/x86/Input-i8042-also-perform-controller-reset-when-suspe.patch
features/all/wireless-rt2x00-rt2800pci-add-more-RT539x-ids.patch
features/all/rt2x00-Add-RT539b-chipset-support.patch
features/all/xen/microcode-amd-fam15plus.patch