Added powerpc-mkvmlinuz-support patch, to enable moving the mkvmlinuz support logic to kernel-package.

Added powerpc default config.

svn path=/trunk/kernel/source/linux-kernel-2.6.12/; revision=3504
This commit is contained in:
Sven Luther 2005-07-15 13:04:44 +00:00
parent ae86dcf228
commit 8563773d65
4 changed files with 60 additions and 0 deletions

View File

@ -5,3 +5,4 @@ include_common_config = 'yes'
header_dirs = 'ppc | ppc64'
headers_subarch = pmac
build_subarch = pmac
default_config = powerpc

3
debian/changelog vendored
View File

@ -31,5 +31,8 @@ linux-2.6 (2.6.12-1) UNRELEASED; urgency=low
- kernel-image-x.y.z-smp -> linux-image-x.y.z-alpha-smp
- This change was postponed after the sarge release. (closes: #260003)
* Enable CONFIG_SCSI_INITIO. (Maximilian Attems) closes: #318121
* Added powerpc-mkvmlinuz-support patch, as this is really tied to the
kernel version. kernel-package will be teached to make use of this, but it
needs some cleanup and tidying yet. (Sven Luther)
-- Frederik Schüler <fschueler@gmx.net> Thu, 30 Jun 2005 14:02:19 +0200

View File

@ -0,0 +1,54 @@
#
# Mkvmlinuz support patch, called by debian's kernel-package to generate
# the files needed by mkvmlinuz to generate the bootable images from vmlinux.
# Author: Sven Luther <luther@debian.org>
# Based on work from: Jens Schmalzing <jensen@debian.org>
# Original comment from Jens :
# This shell script is intended to be put into the debian subdirectory
# of a Linux kernel tree, where make-kpkg will find and execute it
# while building a kernel-image package. The purpose of this script
# is to add glue (object code, libraries, utilities and so on) from
# the kernel tree to the kernel-image package. Later, the mkvmlinuz
# utility, which is available as a separate Debian package, can use
# this glue to create a bootable compressed kernel from the
# uncompressed kernel in the kernel-image package and optionally a
# ramdisk. This is especially important on PowerPC subarchitectures
# that don't have a boot loader, but also comes handy for rescue
# systems and the like.
# Upstream status: well, this is a debian specific hack, it would be nice
# if it was going upstream, but probably not in this form.
#
--- linux-kernel-2.6.12-2.6.12/arch/ppc/boot/Makefile.orig 2005-07-15 12:46:28.000000000 +0000
+++ linux-kernel-2.6.12-2.6.12/arch/ppc/boot/Makefile 2005-07-15 12:55:56.000000000 +0000
@@ -32,3 +32,31 @@
$(bootdir-y): $(addprefix $(obj)/,$(subdir-y)) \
$(addprefix $(obj)/,$(hostprogs-y))
$(Q)$(MAKE) $(build)=$(obj)/$@ $(MAKECMDGOALS)
+
+mkvmlinuz_support_install:
+ # mkvmlinuz support, based on work done originally by Jens Schmalzing <jensen@debian.org>
+ mkdir -p $(INSTALL_MKVMLINUZ)/boot
+ install -m 644 -o root -g root ld.script openfirmware/note $(INSTALL_MKVMLINUZ)/boot
+
+ mkdir -p $(INSTALL_MKVMLINUZ)/lib
+ install -m 644 -o root -g root ../../../lib/lib.a $(INSTALL_MKVMLINUZ)/lib
+ install -m 644 -o root -g root lib/lib.a $(INSTALL_MKVMLINUZ)/lib/ppc.a
+ install -m 644 -o root -g root common/lib.a $(INSTALL_MKVMLINUZ)/lib/common.a
+ install -m 644 -o root -g root boot/of1275/lib.a $(INSTALL_MKVMLINUZ)/lib/of.a
+
+ mkdir -p $(INSTALL_MKVMLINUZ)/obj/openfirmware
+ install -m 644 -o root -g root openfirmware/*.o $(INSTALL_MKVMLINUZ)/obj/openfirmware
+ rm -f $(INSTALL_MKVMLINUZ)/obj/openfirmware/image*
+
+ mkdir -p $(INSTALL_MKVMLINUZ)/obj/simple
+ install -m 644 -o root -g root simple/*.o $(INSTALL_MKVMLINUZ)/obj/simple
+ rm -f $(INSTALL_MKVMLINUZ)/obj/simple/image*.o
+
+ mkdir -p $(INSTALL_MKVMLINUZ)/utils
+ install -m 755 -o root -g root utils/addnote $(INSTALL_MKVMLINUZ)/utils
+ install -m 755 -o root -g root utils/hack-coff $(INSTALL_MKVMLINUZ)/utils
+ install -m 755 -o root -g root utils/mkbugboot $(INSTALL_MKVMLINUZ)/utils
+ install -m 755 -o root -g root utils/mknote $(INSTALL_MKVMLINUZ)/utils
+ install -m 755 -o root -g root utils/mkprep $(INSTALL_MKVMLINUZ)/utils
+ install -m 755 -o root -g root utils/mktree $(INSTALL_MKVMLINUZ)/utils
+

View File

@ -23,3 +23,5 @@
+ patch-2.6.12.1
+ powerpc-ppc64-biarch-override.patch
+ patch-2.6.12.2
+ powerpc-mkvmlinuz-support.patch