Merge changes from sid up to 3.10.5-1

Exclude rt featureset addition.

svn path=/dists/trunk/linux/; revision=20458
This commit is contained in:
Ben Hutchings 2013-08-08 08:29:51 +00:00
commit 8458336937
8 changed files with 201 additions and 6 deletions

89
debian/changelog vendored
View File

@ -10,6 +10,95 @@ linux (3.11~rc4-1~exp1) UNRELEASED; urgency=low
-- Ben Hutchings <ben@decadent.org.uk> Mon, 22 Jul 2013 04:18:31 +0100
linux (3.10.5-1) unstable; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.10.4
- ipv6,mcast: always hold idev->lock before mca_lock
- ipv6: call udp_push_pending_frames when uncorking a socket with AF_INET
pending data (CVE-2013-4162)
- ipv6: ip6_append_data_mtu did not care about pmtudisc and frag_size
(CVE-2013-4163)
- sunvnet: vnet_port_remove must call unregister_netdev
- ipv6: only static routes qualify for equal cost multipathing
(CVE-2013-4125)
- atl1e: fix dma mapping warnings
- atl1e: unmap partially mapped skb on dma error and free skb
- vlan: mask vlan prio bits
- vlan: fix a race in egress prio management
- fuse: readdirplus: fix dentry leak
- fuse: readdirplus: fix instantiate
- fuse: readdirplus: sanity checks
- bcache: Fix a dumb race
- bcache: Advertise that flushes are supported
- bcache: Shutdown fix (possibly fixes #715019)
- bcache: Fix a sysfs splat on shutdown
- bcache: Journal replay fix
- ext4: fix error handling in ext4_ext_truncate()
- media: saa7134: Fix unlocked snd_pcm_stop() call
- media: dmxdev: remove dvb_ringbuffer_flush() on writer side
- lockd: protect nlm_blocked access in nlmsvc_retry_blocked
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.10.5
- mm: fix the TLB range flushed when __tlb_remove_page() runs out of slots
- iscsi-target: Fix tfc_tpg_nacl_auth_cit configfs length overflow
- iser-target: Fix session reset bug with RDMA_CM_EVENT_DISCONNECTED
- iscsi-target: Fix ISCSI_OP_SCSI_TMFUNC handling for iser
- firewire: fix libdc1394/FlyCap2 iso event regression
- SCSI: sd: fix crash when UA received on DIF enabled device
- tracing: Remove locking trace_types_lock from
tracing_reset_all_online_cpus()
- usb: host: xhci: Enable XHCI_SPURIOUS_SUCCESS for all controllers with
xhci 1.0
- xhci: fix null pointer dereference on ring_doorbell_for_active_rings
- xhci: Avoid NULL pointer deref when host dies.
- staging: comedi: fix a race between do_cmd_ioctl() and read/write
- Btrfs: fix wrong write offset when replacing a device
- Btrfs: fix lock leak when resuming snapshot deletion
- Btrfs: re-add root to dead root list if we stop dropping it
- xen-netfront: pull on receive skb may need to happen earlier
- md: Remove recent change which allows devices to skip recovery.
- md/raid1: fix bio handling problems in process_checks()
- md/raid5: fix interaction of 'replace' and 'recovery'.
- md/raid10: remove use-after-free bug.
- svcrdma: underflow issue in decode_write_list()
- nfsd: nfsd_open: when dentry_open returns an error do not propagate as
struct file
- ACPI / scan: Do not try to attach scan handlers to devices having them
- drm/radeon: fix endian issues with DP handling (v3)
- drm/radeon: fix combios tables on older cards
- drm/i915: fix up ring cleanup for the i830/i845 CS tlb w/a
- drm/i915: Fix write-read race with multiple rings
- Partially revert "drm/i915: unconditionally use mt forcewake on hsw/ivb"
- drm/i915: Fix incoherence with fence updates on Sandybridge+
- drm/i915: fix long-standing SNB regression in power consumption after resume v2
- drm/i915: Fix dereferencing invalid connectors in is_crtc_connector_off()
- drm/i915: correctly restore fences with objects attached
- drm/i915: Serialize almost all register access
- drm/radeon/atom: initialize more atom interpretor elements to 0
- mm: mempolicy: fix mbind_range() && vma_adjust() interaction
- tty_port: Fix refcounting leak in tty_port_tty_hangup()
- vfs: livelock avoidance in sget()
- iscsi-target: Fix iscsit_add_reject* usage for iser
- drm/i915: Correct obj->mm_list link to
dev_priv->dev_priv->mm.inactive_list
[ Ben Hutchings ]
* [hppa] udeb: Add core-modules package (Closes: #718270)
* nl80211: fix another nl80211_fam.attrbuf race
* Bump ABI to 2
* ext4: fix retry handling in ext4_ext_truncate()
* atl1c: Fix misuse of netdev_alloc_skb in refilling rx ring
(Closes: #718505)
* [rt] genpatch.py: Accept missing series-rt
* [rt] Update to 3.10.4-rt1 and reenable
* [rt] genpatch.py: Fix parsing of upstream patches with no header
* aufs: Update to aufs3.10-20130805
* [rt] md: Disable BCACHE, as it fails to build
* SCSI: Don't attempt to send extended INQUIRY command if skip_vpd_pages is
set (Closes: #719002)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 07 Aug 2013 22:38:45 +0200
linux (3.10.3-1) unstable; urgency=low
* New upstream stable update:

View File

@ -6,3 +6,6 @@ CONFIG_WAKEUP_LATENCY_HIST=y
## disable aufs as it's not needed on rt and conflicts with fs-dentry-use-seqlock.patch
# CONFIG_AUFS_FS is not set
## disable bcache as it uses {down,up}_read_non_owner() which don't exist on rt
# CONFIG_BCACHE is not set

View File

@ -0,0 +1 @@
#include <core-modules>

View File

@ -0,0 +1,33 @@
From: "Martin K. Petersen" <martin.petersen@oracle.com>
Date: Tue, 30 Jul 2013 22:58:34 -0400
Subject: [SCSI] Don't attempt to send extended INQUIRY command if
skip_vpd_pages is set
Origin: https://git.kernel.org/cgit/linux/kernel/git/jejb/scsi.git/commit?id=7562523e84ddc742fe1f9db8bd76b01acca89f6b
Bug-Debian: http://bugs.debian.org/719002
If a device has the skip_vpd_pages flag set we should simply fail the
scsi_get_vpd_page() call.
Signed-off-by: Martin K. Petersen <martin.petersen@oracle.com>
Acked-by: Alan Stern <stern@rowland.harvard.edu>
Tested-by: Stuart Foster <smf.linux@ntlworld.com>
Cc: stable@vger.kernel.org
Signed-off-by: James Bottomley <JBottomley@Parallels.com>
---
drivers/scsi/scsi.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/drivers/scsi/scsi.c b/drivers/scsi/scsi.c
index 3b1ea34..eaa808e 100644
--- a/drivers/scsi/scsi.c
+++ b/drivers/scsi/scsi.c
@@ -1031,6 +1031,9 @@ int scsi_get_vpd_page(struct scsi_device *sdev, u8 page, unsigned char *buf,
{
int i, result;
+ if (sdev->skip_vpd_pages)
+ goto fail;
+
/* Ask for all the pages supported by this device */
result = scsi_vpd_inquiry(sdev, buf, 0, buf_len);
if (result)

View File

@ -0,0 +1,21 @@
From: Theodore Ts'o <tytso@mit.edu>
Date: Mon, 29 Jul 2013 16:12:56 +0000
Subject: ext4: fix retry handling in ext4_ext_truncate()
Origin: https://git.kernel.org/cgit/linux/kernel/git/tytso/ext4.git/commit/?id=94eec0fc3520c759831763d866421b4d60b599b4
We tested for ENOMEM instead of -ENOMEM. Oops.
Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Cc: stable@vger.kernel.org
---
--- a/fs/ext4/extents.c
+++ b/fs/ext4/extents.c
@@ -4389,7 +4389,7 @@ void ext4_ext_truncate(handle_t *handle,
retry:
err = ext4_es_remove_extent(inode, last_block,
EXT_MAX_BLOCKS - last_block);
- if (err == ENOMEM) {
+ if (err == -ENOMEM) {
cond_resched();
congestion_wait(BLK_RW_ASYNC, HZ/50);
goto retry;

View File

@ -0,0 +1,38 @@
From: Johannes Berg <johannes.berg@intel.com>
Date: Tue, 30 Jul 2013 22:38:42 +0200
Subject: nl80211: fix another nl80211_fam.attrbuf race
Origin: https://git.kernel.org/cgit/linux/kernel/git/jberg/mac80211.git/commit/?id=c319d50bfcf678c2857038276d9fab3c6646f3bf
This is similar to the race Linus had reported, but in this case
it's an older bug: nl80211_prepare_wdev_dump() uses the wiphy
index in cb->args[0] as it is and thus parses the message over
and over again instead of just once because 0 is the first valid
wiphy index. Similar code in nl80211_testmode_dump() correctly
offsets the wiphy_index by 1, do that here as well.
Cc: stable@vger.kernel.org
Reported-by: Ben Hutchings <ben@decadent.org.uk>
Signed-off-by: Johannes Berg <johannes.berg@intel.com>
---
net/wireless/nl80211.c | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/net/wireless/nl80211.c b/net/wireless/nl80211.c
index 25d217d..3fcba69 100644
--- a/net/wireless/nl80211.c
+++ b/net/wireless/nl80211.c
@@ -441,10 +441,12 @@ static int nl80211_prepare_wdev_dump(struct sk_buff *skb,
goto out_unlock;
}
*rdev = wiphy_to_dev((*wdev)->wiphy);
- cb->args[0] = (*rdev)->wiphy_idx;
+ /* 0 is the first index - add 1 to parse only once */
+ cb->args[0] = (*rdev)->wiphy_idx + 1;
cb->args[1] = (*wdev)->identifier;
} else {
- struct wiphy *wiphy = wiphy_idx_to_wiphy(cb->args[0]);
+ /* subtract the 1 again here */
+ struct wiphy *wiphy = wiphy_idx_to_wiphy(cb->args[0] - 1);
struct wireless_dev *tmp;
if (!wiphy) {

View File

@ -9,11 +9,15 @@ def main(source_dir, version):
old_series = set()
new_series = set()
with open(os.path.join(patch_dir, series_name), 'r') as series_fh:
for line in series_fh:
name = line.strip()
if name != '' and name[0] != '#':
old_series.add(name)
try:
with open(os.path.join(patch_dir, series_name), 'r') as series_fh:
for line in series_fh:
name = line.strip()
if name != '' and name[0] != '#':
old_series.add(name)
except IOError, e:
if e.errno != errno.ENOENT:
raise
with open(os.path.join(patch_dir, series_name), 'w') as series_fh:
# Add directory prefix to all filenames.
@ -29,8 +33,10 @@ def main(source_dir, version):
with open(path, 'w') as patch:
in_header = True
for line in source_patch:
if in_header and line == '\n':
if in_header and re.match(r'^(\n|[^\w\s]|Index:)', line):
patch.write('Origin: %s\n' % origin)
if line != '\n':
patch.write('\n')
in_header = False
patch.write(line)
series_fh.write(name)

View File

@ -76,3 +76,7 @@ features/all/efi-autoload-efivars.patch
# m68k Kconfig bugfix
bugfix/m68k/ethernat-kconfig.patch
bugfix/all/nl80211-fix-another-nl80211_fam-attrbuf-race.patch
bugfix/all/ext4-fix-retry-handling-in-ext4_ext_truncate.patch
bugfix/all/SCSI-Don-t-attempt-to-send-extended-INQUIRY-command-.patch