* [ppc64el] debian/config/ppc64el/defines: switch to vmlinuz (from vmlinux).

* [ppc64el] debian/patches/debian/ppc64el-disable-zImage.patch: remove patch.
  The 'powerpc/boot: 64bit little endian wrapper' patch-set is in linux 3.16.
  (Closes: #759389).

svn path=/dists/trunk/linux/; revision=21750
This commit is contained in:
Aurelien Jarno 2014-08-27 07:41:59 +00:00
parent 24876894ca
commit 8364adfe25
4 changed files with 8 additions and 52 deletions

6
debian/changelog vendored
View File

@ -23,6 +23,12 @@ linux (3.16.1-1) UNRELEASED; urgency=medium
(Closes: #758591).
* [mips*/loongson3] Backport Loongson 3B support from 3.17.
[ Mauricio Faria de Oliveira ]
* [ppc64el] debian/config/ppc64el/defines: switch to vmlinuz (from vmlinux).
* [ppc64el] debian/patches/debian/ppc64el-disable-zImage.patch: remove patch.
The 'powerpc/boot: 64bit little endian wrapper' patch-set is in linux 3.16.
(Closes: #759389).
-- Ben Hutchings <ben@decadent.org.uk> Tue, 12 Aug 2014 02:58:45 +0100
linux (3.16-1~exp1) experimental; urgency=medium

View File

@ -4,12 +4,12 @@ flavours:
kernel-arch: powerpc
[build]
image-file: vmlinux
image-file: arch/powerpc/boot/zImage
[image]
configs:
suggests: mkvmlinuz
install-stem: vmlinux
install-stem: vmlinuz
[powerpc64le_description]
hardware: Little-endian 64-bit PowerPC

View File

@ -1,49 +0,0 @@
From: Mauricio Faria de Oliveira <mauricfo@linux.vnet.ibm.com>
Date: Wed, 4 Jun 2014 09:06:27 -0300
Subject: ppc64el: kernel: patch: temporarily disable zImage
Debian ppc64el will wait for the 'powerpc/boot: 64bit little endian wrapper'
(zImage) patches upstream rather than shipping 32-bit tools for zImage. The
patches are currently in Ben Herrenschmidt's linux-next tree [1].
The patches are not being carried over instead of this workaround because,
even without both, the build process does produces vmlinux, only failing for
zImage. So, it's ok to just work-around this for now, as we pick vmlinux.
The workaround patch just avoids this build error:
[...]
LD vmlinux
SYSMAP System.map
[...]
WRAP arch/powerpc/boot/zImage.pseries
ld: unrecognised emulation mode: elf32ppc
Supported emulations: elf64lppc elf32lppc elf32lppclinux elf32lppcsim
make[6]: *** [arch/powerpc/boot/zImage.pseries] Error 1
make[5]: *** [zImage] Error 2
[1] https://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/log/?qt=grep&q=powerpc%2Fboot
(15 commits with message prefix 'powerpc/boot:' dated of 2014-04-28)
Signed-off-by: Mauricio Faria de Oliveira <mauricfo@linux.vnet.ibm.com>
---
Index: linux-3.14.2/arch/powerpc/boot/Makefile
===================================================================
--- linux-3.14.2.orig/arch/powerpc/boot/Makefile 2014-05-02 16:52:37.000000000 -0300
+++ linux-3.14.2/arch/powerpc/boot/Makefile 2014-05-07 09:39:11.000000000 -0300
@@ -344,6 +344,15 @@
$(obj)/%.dtb: $(src)/dts/%.dts FORCE
$(call if_changed_dep,dtc)
+# Debian ppc64el will wait for the 'powerpc/boot: 64bit little endian wrapper'
+# (zImage) patches upstream rather than shipping 32-bit tools for zImage.
+# This makes the next conditional block to pick vmlinux.strip as image-y.
+ifdef CONFIG_PPC64
+ifdef CONFIG_CPU_LITTLE_ENDIAN
+image-y :=
+endif
+endif
+
# If there isn't a platform selected then just strip the vmlinux.
ifeq (,$(image-y))
image-y := vmlinux.strip

View File

@ -6,7 +6,6 @@ debian/ia64-hardcode-arch-script-output.patch
debian/mips-disable-werror.patch
debian/arch-sh4-fix-uimage-build.patch
debian/powerpcspe-omit-uimage.patch
debian/ppc64el-disable-zImage.patch
features/all/Kbuild-kconfig-Verbose-version-of-listnewconfig.patch
# Fixes/improvements to firmware loading