iwlegacy: Use consistent condition for il_pm_ops (fixes FTBFS on ia64)

svn path=/dists/trunk/linux/; revision=20246
This commit is contained in:
Ben Hutchings 2013-06-11 03:42:19 +00:00
parent 5cf8fbf550
commit 82d06bd176
3 changed files with 36 additions and 0 deletions

1
debian/changelog vendored
View File

@ -14,6 +14,7 @@ linux (3.10~rc5-1~exp1) UNRELEASED; urgency=low
nic-modules
- Move ide-modules and ide-core-modules into ia64 configuration
- [powerpc,x86] Fold nic-extra-modules into nic-modules
* iwlegacy: Use consistent condition for il_pm_ops (fixes FTBFS on ia64)
-- Ben Hutchings <ben@decadent.org.uk> Mon, 03 Jun 2013 13:21:56 +0100

View File

@ -0,0 +1,34 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: iwlegacy: Use consistent condition for il_pm_ops
Date: Tue, 11 Jun 2013 04:37:26 +0100
Commit e82add550d9b 'net: wireless: iwlegacy: add CONFIG_PM_SLEEP to
suspend/resume functions' correctly changed the condition for defining
il_pm_ops and the functions it points to. But it didn't change the
condition for use of il_pm_ops, so iwl3945 and iwl4965 fail to link if
only CONFIG_PM is enabled.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/drivers/net/wireless/iwlegacy/common.h
+++ b/drivers/net/wireless/iwlegacy/common.h
@@ -1832,16 +1832,16 @@ u32 il_usecs_to_beacons(struct il_priv *
__le32 il_add_beacon_time(struct il_priv *il, u32 base, u32 addon,
u32 beacon_interval);
-#ifdef CONFIG_PM
+#ifdef CONFIG_PM_SLEEP
extern const struct dev_pm_ops il_pm_ops;
#define IL_LEGACY_PM_OPS (&il_pm_ops)
-#else /* !CONFIG_PM */
+#else /* !CONFIG_PM_SLEEP */
#define IL_LEGACY_PM_OPS NULL
-#endif /* !CONFIG_PM */
+#endif /* !CONFIG_PM_SLEEP */
/*****************************************************
* Error Handling Debugging

View File

@ -87,3 +87,4 @@ features/arm/imx53-qsb-usb-power.patch
bugfix/all/ath9k-Disable-PowerSave-by-default.patch
bugfix/x86/viafb-autoload-on-olpc-xo1.5-only.patch
bugfix/all/iwlegacy-use-consistent-condition-for-il_pm_ops.patch