[armhf] xen/pci: Fix build on non-x86

svn path=/dists/trunk/linux/; revision=20943
This commit is contained in:
Ben Hutchings 2013-12-31 17:09:55 +00:00
parent a8c44e1b9f
commit 80641dfee8
3 changed files with 30 additions and 0 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux (3.13~rc6-1~exp2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* [armhf] xen/pci: Fix build on non-x86
-- Ben Hutchings <ben@decadent.org.uk> Mon, 30 Dec 2013 17:23:53 +0100
linux (3.13~rc6-1~exp1) experimental; urgency=low
* New upstream release candidate

View File

@ -0,0 +1,22 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 30 Dec 2013 19:44:02 +0100
Subject: xen/pci: Fix build on non-x86
We can't include <asm/pci_x86.h> if this isn't x86, and we only need
it if CONFIG_PCI_MMCONFIG is enabled.
Fixes: 8deb3eb1461e ('xen/mcfg: Call PHYSDEVOP_pci_mmcfg_reserved for MCFG areas.')
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/drivers/xen/pci.c
+++ b/drivers/xen/pci.c
@@ -26,7 +26,9 @@
#include <asm/xen/hypervisor.h>
#include <asm/xen/hypercall.h>
#include "../pci/pci.h"
+#ifdef CONFIG_PCI_MMCONFIG
#include <asm/pci_x86.h>
+#endif
static bool __read_mostly pci_seg_supported = true;

View File

@ -76,3 +76,4 @@ debian/add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by-default.patch
bugfix/all/disable-some-marvell-phys.patch
features/all/media-az6007-support-Technisat-Cablestar-Combo-HDCI-.patch
bugfix/all/staging-lustre-Make-LUSTRE_LLITE_LLOOP-tristate.patch
bugfix/arm/xen-pci-fix-build-on-non-x86.patch