Add IXP4xx network build fix.

svn path=/dists/trunk/linux-2.6/; revision=7955
This commit is contained in:
Martin Michlmayr 2006-12-09 20:38:50 +00:00
parent c272714659
commit 7fe9569b07
3 changed files with 34 additions and 0 deletions

3
debian/changelog vendored
View File

@ -14,6 +14,9 @@ linux-2.6 (2.6.19-1~experimental.1) UNRELEASED; urgency=low
[ Bastian Blank ]
* Remove legacy pty support. (closes: #338404)
[ Rod Whitby ]
* Add IXP4xx network build fix.
-- Bastian Blank <waldi@debian.org> Mon, 4 Dec 2006 07:16:41 +0100
linux-2.6 (2.6.18-6) UNRELEASED; urgency=low

View File

@ -0,0 +1,30 @@
---
arch/arm/mach-ixp4xx/common.c | 1 -
drivers/net/ixp4xx/ixp4xx_qmgr.c | 2 +-
2 files changed, 1 insertion(+), 2 deletions(-)
Index: linux-2.6.19/arch/arm/mach-ixp4xx/common.c
===================================================================
--- linux-2.6.19.orig/arch/arm/mach-ixp4xx/common.c
+++ linux-2.6.19/arch/arm/mach-ixp4xx/common.c
@@ -13,7 +13,6 @@
* warranty of any kind, whether express or implied.
*/
-#include <linux/config.h>
#include <linux/kernel.h>
#include <linux/mm.h>
#include <linux/init.h>
Index: linux-2.6.19/drivers/net/ixp4xx/ixp4xx_qmgr.c
===================================================================
--- linux-2.6.19.orig/drivers/net/ixp4xx/ixp4xx_qmgr.c
+++ linux-2.6.19/drivers/net/ixp4xx/ixp4xx_qmgr.c
@@ -165,7 +165,7 @@ int queue_set_irq_src(struct qm_queue *q
return 0;
}
-static irqreturn_t irq_qm1(int irq, void *dev_id, struct pt_regs *regs)
+static irqreturn_t irq_qm1(int irq, void *dev_id)
{
struct qm_qmgr *qmgr = dev_id;
int offs, reg;

View File

@ -28,6 +28,7 @@
+ features/arm/ixp4xx-0.2.1-driver.patch
+ features/arm/ixp4xx-net-driver-fix-qmgr.patch
+ features/arm/ixp4xx-net-driver-improve-mac-handling.patch
+ features/arm/ixp4xx-net-build-fix.patch
+ bugfix/mips/ide-scan.patch
+ bugfix/mips/64bit-tulip.patch
+ bugfix/mips/tulip_dc21143.patch