fs: cachefiles: add support for large files in filesystem caching (Closes: #698376)

svn path=/dists/sid/linux/; revision=19747
This commit is contained in:
Ben Hutchings 2013-01-19 18:11:12 +00:00
parent 22628d7a86
commit 7fa1c9ff04
3 changed files with 34 additions and 0 deletions

2
debian/changelog vendored
View File

@ -69,6 +69,8 @@ linux (3.2.36-1) UNRELEASED; urgency=low
* vt6656: Fix inconsistent structure packing which leads to crash on amd64
* [!powerpc] radeon: Reenable DRM_RADEON_KMS, as it apparently works on
most non-PowerMac systems
* fs: cachefiles: add support for large files in filesystem caching
(Closes: #698376)
[ Aurelien Jarno ]
* [armhf/vexpress] Add kernel udebs.

View File

@ -0,0 +1,31 @@
From: Justin Lecher <jlec@gentoo.org>
Date: Mon, 30 Jul 2012 14:42:53 -0700
Subject: fs: cachefiles: add support for large files in filesystem caching
commit 98c350cda2c14a343d34ea01a3d9c24fea5ec66d upstream.
Support the caching of large files.
Addresses https://bugzilla.kernel.org/show_bug.cgi?id=31182
Signed-off-by: Justin Lecher <jlec@gentoo.org>
Signed-off-by: Suresh Jayaraman <sjayaraman@suse.com>
Tested-by: Suresh Jayaraman <sjayaraman@suse.com>
Acked-by: David Howells <dhowells@redhat.com>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
[bwh: Backported to 3.2:
- Adjust context
- dentry_open() takes dentry and vfsmount pointers, not a path pointer]
---
--- a/fs/cachefiles/rdwr.c
+++ b/fs/cachefiles/rdwr.c
@@ -918,7 +918,7 @@ int cachefiles_write_page(struct fscache_storage *op, struct page *page)
* own time */
dget(object->backer);
mntget(cache->mnt);
- file = dentry_open(object->backer, cache->mnt, O_RDWR,
+ file = dentry_open(object->backer, cache->mnt, O_RDWR | O_LARGEFILE,
cache->cache_cred);
if (IS_ERR(file)) {
ret = PTR_ERR(file);

View File

@ -464,3 +464,4 @@ features/all/iguanair/0010-media-iguanair-do-not-modify-transmit-buffer.patch
features/all/iguanair/0011-media-iguanair-cannot-send-data-from-the-stack.patch
features/all/rt2800-add-chipset-revision-RT5390R-support.patch
bugfix/all/vt6656-Fix-inconsistent-structure-packing.patch
bugfix/all/fs-cachefiles-add-support-for-large-files-in-filesys.patch