Update to 4.2.6

This commit is contained in:
Ben Hutchings 2015-11-10 02:26:19 +00:00
parent ef1fd62260
commit 7f79eccf5e
3 changed files with 80 additions and 45 deletions

81
debian/changelog vendored
View File

@ -1,5 +1,84 @@
linux (4.2.5-2) UNRELEASED; urgency=medium
linux (4.2.6-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.2.6
- mmc: core: Fix init_card in 52Mhz (regression in 4.2)
- rtlwifi: rtl8821ae: Fix system lockups on boot (regression in 4.2)
- iwlwifi: mvm: init card correctly on ctkill exit check
(regression in 3.18)
- iwlwifi: mvm: flush fw_dump_wk when mvm fails to start
(regression in 3.18)
- [x86] iommu/vt-d: fix range computation when making room for large pages
- [x86] iommu/amd: Fix BUG when faulting a PROT_NONE VMA
- [x86] iommu/amd: Don't clear DTE flags when modifying it
- drm: fix mutex leak in drm_dp_get_mst_branch_device
- drm: Correct arguments to list_tail_add in create blob ioctl
- drm: crtc: integer overflow in drm_property_create_blob()
- rtl28xxu: fix control message flaws (regression in 4.0)
- ALSA: hda - Fix deadlock at error in building PCM
- [x86] ioapic: Prevent NULL pointer dereference in setup_ioapic_dest()
(regression in 4.2.4)
- mm: make sendfile(2) killable
- drm/radeon/dpm: don't add pwm attributes if DPM is disabled
(regression in 4.0)
- [x86] drm/i915: Restore lost DPLL register write on gen2-4
(regression in 3.18)
- [x86] drm/i915: Deny wrapping an userptr into a framebuffer
- drm/radeon: don't try to recreate sysfs entries on resume
(regression in 4.2.5)
- drm/radeon: fix dpms when driver backlight control is disabled
(regression in 4.2.4)
- drm/radeon: move bl encoder assignment into bl init
- rbd: require stable pages if message data CRCs are enabled
- rbd: don't leak parent_spec in rbd_dev_probe_parent()
- rbd: prevent kernel stack blow up on rbd map
- [armhf] EXYNOS: Fix double of_node_put() when parsing child power domains
(regression in 4.2)
- [armhf] dts: Fix audio card detection on Peach boards (regression in 4.1)
- [arm64] Revert "ARM64: unwind: Fix PC calculation"
- block: don't release bdi while request_queue has live references
(regression in 4.2)
- dm btree remove: fix a bug when rebalancing nodes after removal
- dm cache: the CLEAN_SHUTDOWN flag was not being set
- dm btree: fix leak of bufio-backed block in btree_split_beneath error path
- Revert "serial: 8250_dma: don't bother DMA with small transfers"
(regression in 4.0)
- [armel] i2c: mv64xxx: really allow I2C offloading (regression in 3.19)
- clkdev: fix clk_add_alias() with a NULL alias device name
(regression in 4.2)
- fbcon: initialize blink interval before calling fb_set_par
(regression in 4.2)
- PCI: Prevent out of bounds access in numa_node override
- ovl: free stack of paths in ovl_fill_super (regression in 4.0)
- ovl: free lower_mnt array in ovl_put_super (regression in 4.0)
- ovl: fix dentry reference leak
- ovl: fix open in stacked overlay (regression in 4.2)
- [x86] Input: alps - only the Dell Latitude D420/430/620/630 have separate
stick button bits (regression in 4.1)
- crypto: api - Only abort operations on fatal signal
- md/raid1: submit_bio_wait() returns 0 on success (regression in 3.10)
- md/raid10: submit_bio_wait() returns 0 on success (regression in 3.10)
- md/raid5: fix locking in handle_stripe_clean_event() (regression in 3.13)
- Revert "md: allow a partially recovered device to be hot-added to an
array." (regression in 3.14) (Closes: #777511)
- [amd64] EDAC, sb_edac: Fix TAD presence check for sbridge_mci_bind_devs()
(regression in 4.2)
- mvsas: Fix NULL pointer dereference in mvs_slot_task_free
- netfilter: ipset: Fix sleeping memory allocation in atomic context
(regression in 4.2)
- btrfs: fix possible leak in btrfs_ioctl_balance() (regression in 4.2.5)
- kvm: irqchip: fix memory leak (regression in 4.2)
- [armhf] thermal: exynos: Fix register read in TMU (regression in 4.2)
- blk-mq: fix use-after-free in blk_mq_free_tag_set() (regression in 4.2)
- IB/cm: Fix rb-tree duplicate free and use-after-free
- sched/deadline: Fix migration of SCHED_DEADLINE tasks (regression in 4.2)
- [arm64] compat: fix stxr failure case in SWP emulation
- NVMe: Fix memory leak on retried commands
- [x86] drm/vmwgfx: Fix up user_dmabuf refcounting
- thp: use is_zero_pfn() only after pte_present() check (regression in 4.1)
- xen: fix backport of previous kexec patch
[ Ben Hutchings ]
* usbvision: fix overflow of interfaces array (CVE-2015-7833)
* RDS: fix race condition when sending a message on unbound socket
(CVE-2015-7990)

View File

@ -1,43 +0,0 @@
From: David Howells <dhowells@redhat.com>
Date: Fri, 18 Sep 2015 11:45:12 +0100
Subject: ovl: conditionally use O_LARGEFILE in ovl_copy_up()
Origin: https://git.kernel.org/cgit/linux/kernel/git/mszeredi/vfs.git/commit?id=bb00c2cd01c27e037900a28dcd01b00317a42fdb
Open the lower file with O_LARGEFILE in ovl_copy_up() if the lower file
is >= 4GiB in size.
Reported-by: Ulrich Obergfell <uobergfe@redhat.com>
Signed-off-by: David Howells <dhowells@redhat.com>
Signed-off-by: Miklos Szeredi <miklos@szeredi.hu>
Cc: <stable@vger.kernel.org> # v3.18+
---
fs/overlayfs/copy_up.c | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/fs/overlayfs/copy_up.c b/fs/overlayfs/copy_up.c
index 84d693d..391c359 100644
--- a/fs/overlayfs/copy_up.c
+++ b/fs/overlayfs/copy_up.c
@@ -76,16 +76,19 @@ static int ovl_copy_up_data(struct path *old, struct path *new, loff_t len)
struct file *new_file;
loff_t old_pos = 0;
loff_t new_pos = 0;
- int error = 0;
+ int error = 0, o_flag = 0;
if (len == 0)
return 0;
- old_file = ovl_path_open(old, O_RDONLY);
+ if (i_size_read(d_inode(old->dentry)) > MAX_NON_LFS)
+ o_flag |= O_LARGEFILE;
+
+ old_file = ovl_path_open(old, o_flag | O_RDONLY);
if (IS_ERR(old_file))
return PTR_ERR(old_file);
- new_file = ovl_path_open(new, O_WRONLY);
+ new_file = ovl_path_open(new, o_flag | O_WRONLY);
if (IS_ERR(new_file)) {
error = PTR_ERR(new_file);
goto out_fput;

View File

@ -91,7 +91,6 @@ bugfix/all/dcache-reduce-the-scope-of-i_lock-in-d_splice_alias.patch
bugfix/all/rds-verify-the-underlying-transport-exists-before-cr.patch
bugfix/all/media-uvcvideo-disable-hardware-timestamps-by-defaul.patch
bugfix/mips/mips-pgtable-bits.h-correct-_page_global_shift-build.patch
bugfix/all/ovl-conditionally-use-o_largefile-in-ovl_copy_up.patch
features/all/ath10k-add-qca6164-support.patch
debian/block-fix-abi-change-in-4.2.2.patch
bugfix/all/nbd-fix-timeout-detection.patch