Attempt to fix FTBFS on various architectures

svn path=/dists/trunk/linux-2.6/; revision=16686
This commit is contained in:
Ben Hutchings 2010-12-10 02:59:04 +00:00
parent c30dcc74f3
commit 7e971a68a8
5 changed files with 130 additions and 0 deletions

6
debian/changelog vendored
View File

@ -2,6 +2,12 @@ linux-2.6 (2.6.37~rc5-1~experimental.1) UNRELEASED; urgency=low
* New upstream release candidate
[ Ben Hutchings ]
* Attempt to fix FTBFS on various architectures:
- [alpha] Do not use -Werror for arch/alpha/kernel
- [arm/ixp4xx] Rename FREQ macro to avoid collisions
- [mips] Add the necessary parameter to mips_sc_is_activated()
-- Ben Hutchings <ben@decadent.org.uk> Thu, 09 Dec 2010 01:37:33 +0000
linux-2.6 (2.6.37~rc4-1~experimental.1) experimental; urgency=low

View File

@ -0,0 +1,53 @@
From 139eb17428367ad718debc4a6c46feb46f549f9f Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 10 Dec 2010 02:45:03 +0000
Subject: [PATCH 2/3] arm/ixp4xx: Rename FREQ macro to avoid collisions
FREQ is a ridiculously short name for a platform-specific macro,
and it now conflicts with an enumeration in the gspca/ov519 driver.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/arm/mach-ixp4xx/common.c | 4 ++--
arch/arm/mach-ixp4xx/include/mach/timex.h | 5 +++--
2 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/arch/arm/mach-ixp4xx/common.c b/arch/arm/mach-ixp4xx/common.c
index 0bce097..f5c42fe 100644
--- a/arch/arm/mach-ixp4xx/common.c
+++ b/arch/arm/mach-ixp4xx/common.c
@@ -415,7 +415,7 @@ static struct clocksource clocksource_ixp4xx = {
.flags = CLOCK_SOURCE_IS_CONTINUOUS,
};
-unsigned long ixp4xx_timer_freq = FREQ;
+unsigned long ixp4xx_timer_freq = IXP4XX_TIMER_FREQ;
EXPORT_SYMBOL(ixp4xx_timer_freq);
static void __init ixp4xx_clocksource_init(void)
{
@@ -491,7 +491,7 @@ static struct clock_event_device clockevent_ixp4xx = {
static void __init ixp4xx_clockevent_init(void)
{
- clockevent_ixp4xx.mult = div_sc(FREQ, NSEC_PER_SEC,
+ clockevent_ixp4xx.mult = div_sc(IXP4XX_TIMER_FREQ, NSEC_PER_SEC,
clockevent_ixp4xx.shift);
clockevent_ixp4xx.max_delta_ns =
clockevent_delta2ns(0xfffffffe, &clockevent_ixp4xx);
diff --git a/arch/arm/mach-ixp4xx/include/mach/timex.h b/arch/arm/mach-ixp4xx/include/mach/timex.h
index 2c3f93c..c9e930f 100644
--- a/arch/arm/mach-ixp4xx/include/mach/timex.h
+++ b/arch/arm/mach-ixp4xx/include/mach/timex.h
@@ -10,6 +10,7 @@
* 66.66... MHz. We do a convulted calculation of CLOCK_TICK_RATE b/c the
* timer register ignores the bottom 2 bits of the LATCH value.
*/
-#define FREQ 66666000
-#define CLOCK_TICK_RATE (((FREQ / HZ & ~IXP4XX_OST_RELOAD_MASK) + 1) * HZ)
+#define IXP4XX_TIMER_FREQ 66666000
+#define CLOCK_TICK_RATE \
+ (((IXP4XX_TIMER_FREQ / HZ & ~IXP4XX_OST_RELOAD_MASK) + 1) * HZ)
--
1.7.2.3

View File

@ -0,0 +1,37 @@
From fe999ddb3cee7f63676938abdeacd54f28a8e325 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 10 Dec 2010 02:52:35 +0000
Subject: [PATCH 3/3] mips: Add the necessary parameter to mips_sc_is_activated()
This might compile now; no idea whether it actually works.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/mips/mm/sc-mips.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/mips/mm/sc-mips.c b/arch/mips/mm/sc-mips.c
index 505feca..1835ddb 100644
--- a/arch/mips/mm/sc-mips.c
+++ b/arch/mips/mm/sc-mips.c
@@ -66,7 +66,7 @@ static struct bcache_ops mips_sc_ops = {
* 12..15 as implementation defined so below function will eventually have
* to be replaced by a platform specific probe.
*/
-static inline int mips_sc_is_activated(struct cpuinfo_mips *c)
+static inline int mips_sc_is_activated(struct cpuinfo_mips *c, unsigned config2)
{
/* Check the bypass bit (L2B) */
switch (c->cputype) {
@@ -108,7 +108,7 @@ static inline int __init mips_sc_probe(void)
config2 = read_c0_config2();
- if (!mips_sc_is_activated(c))
+ if (!mips_sc_is_activated(c, config2))
return 0;
tmp = (config2 >> 8) & 0x0f;
--
1.7.2.3

View File

@ -0,0 +1,30 @@
From 9118be3ce2ef2415b4e451c8defb60100e4e095d Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 10 Dec 2010 02:34:49 +0000
Subject: [PATCH 1/3] alpha: Do not use -Werror for arch/alpha/kernel
The alpha headers for I/O currently have illegal combinations of
extern inline and static inline functions calling each other. Make
the warnings non-fatal for now.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/alpha/kernel/Makefile | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/arch/alpha/kernel/Makefile b/arch/alpha/kernel/Makefile
index 1ee9b5b..1c77b1c 100644
--- a/arch/alpha/kernel/Makefile
+++ b/arch/alpha/kernel/Makefile
@@ -4,7 +4,7 @@
extra-y := head.o vmlinux.lds
EXTRA_AFLAGS := $(KBUILD_CFLAGS)
-EXTRA_CFLAGS := -Werror -Wno-sign-compare
+EXTRA_CFLAGS := -Wno-sign-compare
obj-y := entry.o traps.o process.o init_task.o osf_sys.o irq.o \
irq_alpha.o signal.o setup.o ptrace.o time.o \
--
1.7.2.3

View File

@ -40,3 +40,7 @@
+ features/arm/asoc-openrd-ultimate.patch
+ bugfix/all/dm-Deal-with-merge_bvec_fn-in-component-devices-bett.patch
+ features/all/Kbuild-kconfig-Verbose-version-of-listnewconfig.patch
+ debian/alpha-Do-not-use-Werror-for-arch-alpha-kernel.patch
+ bugfix/arm/arm-ixp4xx-Rename-FREQ-macro-to-avoid-collisions.patch
+ bugfix/mips/mips-Add-the-necessary-parameter-to-mips_sc_is_activ.patch