firmware_class: Fix condition in directory search loop (Closes: #804862)

(cherry picked from commit 5269f93afe)
This commit is contained in:
Ben Hutchings 2015-11-12 14:59:37 +00:00
parent 6d16ac8835
commit 7d0a4425fd
2 changed files with 3 additions and 4 deletions

1
debian/changelog vendored
View File

@ -21,6 +21,7 @@ linux (4.2.6-2) UNRELEASED; urgency=medium
* [x86] Enable PINCTRL_BAYTRAIL (Closes: #797949)
* qxl: Enable by default (Closes: #779515)
* [s390*] Update linux-compiler metapackage to gcc-4.9
* firmware_class: Fix condition in directory search loop (Closes: #804862)
-- Salvatore Bonaccorso <carnil@debian.org> Tue, 10 Nov 2015 22:05:58 +0100

View File

@ -23,13 +23,11 @@ format to detect missing firmware.
---
--- a/drivers/base/firmware_class.c
+++ b/drivers/base/firmware_class.c
@@ -340,17 +340,20 @@ static int fw_get_filesystem_firmware(st
}
@@ -340,16 +340,19 @@ static int fw_get_filesystem_firmware(st
rc = fw_read_file_contents(file, buf);
fput(file);
- if (rc)
if (rc)
- dev_warn(device, "firmware, attempted to load %s, but failed with error %d\n",
+ if (!rc)
+ dev_dbg(device, "firmware, attempted to load %s, but failed with error %d\n",
path, rc);
else