ALSA: timer: Avoid ABI change in 4.13.13

This commit is contained in:
Ben Hutchings 2017-11-16 20:49:22 +00:00
parent 8aabb7ea89
commit 7cb3e39661
3 changed files with 27 additions and 0 deletions

1
debian/changelog vendored
View File

@ -140,6 +140,7 @@ linux (4.13.13-1) UNRELEASED; urgency=medium
* [arm64,x86] net/wireless: Enable RTL8723BS as module (Closes: #881568)
* [arm64] nvmem: Enable NVMEM_SUNXI_SID as module (Closes: #881567)
* [x86] rmi4: Disable RMI4_SMB (Closes: #880471)
* ALSA: timer: Avoid ABI change in 4.13.13
-- Salvatore Bonaccorso <carnil@debian.org> Sat, 04 Nov 2017 09:54:41 +0100

View File

@ -0,0 +1,25 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 16 Nov 2017 20:46:00 +0000
Subject: ALSA: timer: Avoid ABI change in 4.13.13
Forwarded: not-needed
Commit 9b7d869ee5a7 ("ALSA: timer: Limit max instances per timer")
added two new members to the end of struct snd_timer, and this changes
ABI for many exported symbols. However, snd_timer is always allocated
in the snd-timer module, which is the same place the new members are
used. We can safely hide the change from genksyms.
---
--- a/include/sound/timer.h
+++ b/include/sound/timer.h
@@ -90,8 +90,10 @@ struct snd_timer {
struct list_head ack_list_head;
struct list_head sack_list_head; /* slow ack list head */
struct tasklet_struct task_queue;
+#ifndef __GENKSYMS__
int max_instances; /* upper limit of timer instances */
int num_instances; /* current number of timer instances */
+#endif
};
struct snd_timer_instance {

View File

@ -148,3 +148,4 @@ debian/revert-bpf-one-perf-event-close-won-t-free-bpf-program-atta.patch
debian/mac80211-avoid-abi-change-in-4.13.5.patch
debian/keys-limit-abi-change-in-4.13.10.patch
debian/swap-avoid-abi-change-in-4.13.12.patch
debian/alsa-timer-avoid-abi-change-in-4.13.13.patch