drm: Enable DRM_BOCHS, DRM_QXL as modules

qxl: Disable by default, as it is incompatible with wheezy's
xserver-xorg-video-qxl. It can be forced to load with module
parameter modeset=1.

svn path=/dists/sid/linux/; revision=22437
This commit is contained in:
Ben Hutchings 2015-03-01 06:22:03 +00:00
parent 5b6b9def87
commit 7c6fe99dee
4 changed files with 35 additions and 0 deletions

4
debian/changelog vendored
View File

@ -187,6 +187,10 @@ linux (3.16.7-ckt7-1) UNRELEASED; urgency=medium
objects (Closes: #763155)
* KEYS: request_key() should reget expired keys rather than give EKEYEXPIRED
(Closes: #758870)
* drm: Enable DRM_BOCHS, DRM_QXL as modules
- qxl: Disable by default, as it is incompatible with wheezy's
xserver-xorg-video-qxl. It can be forced to load with module
parameter modeset=1.
[ Helge Deller ]
* [alpha] build debian-installer udeb packages

10
debian/config/config vendored
View File

@ -499,6 +499,11 @@ CONFIG_DRM_SAVAGE=m
##
# CONFIG_DRM_AST is not set
##
## file: drivers/gpu/drm/bochs/Kconfig
##
CONFIG_DRM_BOCHS=m
##
## file: drivers/gpu/drm/bridge/Kconfig
##
@ -529,6 +534,11 @@ CONFIG_NOUVEAU_DEBUG=5
CONFIG_NOUVEAU_DEBUG_DEFAULT=3
CONFIG_DRM_NOUVEAU_BACKLIGHT=y
##
## file: drivers/gpu/drm/qxl/Kconfig
##
CONFIG_DRM_QXL=m
##
## file: drivers/gpu/drm/radeon/Kconfig
##

View File

@ -0,0 +1,20 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: qxl: Disable by default
Forwarded: not-needed
This kernel driver is incompatible with older versions of
xserver-xorg-video-qxl, so do not enable it by default. It should be
enabled by a modprobe configuration file installed by
xserver-xorg-video-qxl in jessie.
--- a/drivers/gpu/drm/qxl/qxl_drv.c
+++ b/drivers/gpu/drm/qxl/qxl_drv.c
@@ -47,7 +47,7 @@ static DEFINE_PCI_DEVICE_TABLE(pciidlist
};
MODULE_DEVICE_TABLE(pci, pciidlist);
-static int qxl_modeset = -1;
+static int qxl_modeset = 0;
int qxl_num_crtc = 4;
MODULE_PARM_DESC(modeset, "Disable/Enable modesetting");

View File

@ -542,3 +542,4 @@ features/all/arcmsr/0018-arcmsr-simplify-of-updating-doneq_index-and-postq_in.pa
features/all/arcmsr/0019-arcmsr-simplify-ioctl-data-read-write.patch
bugfix/x86/drm-i915-quietly-reject-attempts-to-create-non-pagealigned-stolen-objects.patch
bugfix/all/keys-request_key-should-reget-expired-keys-rather-th.patch
debian/qxl-disable-modeset-by-default.patch