add fedora patch for recent thinkpads

svn path=/dists/trunk/linux-2.6/; revision=15740
This commit is contained in:
Maximilian Attems 2010-05-18 14:03:19 +00:00
parent 6d1124fb8d
commit 7c61a54199
3 changed files with 62 additions and 0 deletions

1
debian/changelog vendored
View File

@ -17,6 +17,7 @@ linux-2.6 (2.6.34-1~experimental.1) UNRELEASED; urgency=low
HID_NTRIG, HID_QUANTA, HID_STANTUM, HID_WACOM, USB_SERIAL_QCAUX,
USB_SERIAL_VIVOPAY_SERIAL, MMC_RICOH_MMC, LEDS_DELL_NETBOOKS, LOGFS.
* [x86] Enable EEEPC_WMI.
* Fix backlight support on some recent Thinkpads.
[ Ben Hutchings ]
* Prepare debconf templates for translation (Closes: #576758)

View File

@ -0,0 +1,60 @@
From: Matthew Garrett <mjg@redhat.com>
Date: Mon May 17 20:38:21 2010 UTC
Subject: Fix backlight support on some recent Thinkpads
diff -up linux-2.6.34.noarch/drivers/platform/x86/thinkpad_acpi.c.orig linux-2.6.34.noarch/drivers/platform/x86/thinkpad_acpi.c
--- linux-2.6.34.noarch/drivers/platform/x86/thinkpad_acpi.c.orig 2010-05-17 16:28:13.254200070 -0400
+++ linux-2.6.34.noarch/drivers/platform/x86/thinkpad_acpi.c 2010-05-17 16:29:56.471200083 -0400
@@ -3397,7 +3397,7 @@ static int __init hotkey_init(struct ibm
/* update bright_acpimode... */
tpacpi_check_std_acpi_brightness_support();
- if (tp_features.bright_acpimode && acpi_video_backlight_support()) {
+ if (acpi_video_backlight_support()) {
printk(TPACPI_INFO
"This ThinkPad has standard ACPI backlight "
"brightness control, supported by the ACPI "
@@ -6189,26 +6189,24 @@ static int __init brightness_init(struct
* going to publish a backlight interface
*/
b = tpacpi_check_std_acpi_brightness_support();
- if (b > 0) {
- if (acpi_video_backlight_support()) {
- if (brightness_enable > 1) {
- printk(TPACPI_NOTICE
- "Standard ACPI backlight interface "
- "available, not loading native one.\n");
- return 1;
- } else if (brightness_enable == 1) {
- printk(TPACPI_NOTICE
- "Backlight control force enabled, even if standard "
- "ACPI backlight interface is available\n");
- }
- } else {
- if (brightness_enable > 1) {
- printk(TPACPI_NOTICE
- "Standard ACPI backlight interface not "
- "available, thinkpad_acpi native "
- "brightness control enabled\n");
- }
+ if (acpi_video_backlight_support()) {
+ if (brightness_enable > 1) {
+ printk(TPACPI_NOTICE
+ "Standard ACPI backlight interface "
+ "available, not loading native one.\n");
+ return 1;
+ } else if (brightness_enable == 1) {
+ printk(TPACPI_NOTICE
+ "Backlight control force enabled, even if standard "
+ "ACPI backlight interface is available\n");
+ }
+ } else {
+ if (brightness_enable > 1) {
+ printk(TPACPI_NOTICE
+ "Standard ACPI backlight interface not "
+ "available, thinkpad_acpi native "
+ "brightness control enabled\n");
}
}

View File

@ -70,3 +70,4 @@
+ bugfix/all/3c503-Fix-IRQ-probing.patch
+ bugfix/x86/sis-agp-Remove-SIS-760-handled-by-amd64-agp.patch
+ bugfix/x86/amd64-agp-Probe-unknown-AGP-devices-the-right-way.patch
+ bugfix/all/thinkpad-acpi-fix-backlight.patch