* [mips] Fix SGI ip22 serial console, thanks to Julien Blache.

svn path=/dists/trunk/linux-2.6/; revision=6975
This commit is contained in:
Thiemo Seufer 2006-07-09 19:46:38 +00:00
parent 7c96bf6f26
commit 79eb679ade
3 changed files with 23 additions and 0 deletions

1
debian/changelog vendored
View File

@ -54,6 +54,7 @@ linux-2.6 (2.6.17-3) UNRELEASED; urgency=low
* [mips,mipsel] Fix sb1 interrupt handlers.
* [mips,mipsel] Fix devfs-induced build failure in sb1250 serial driver.
* [mips] SGI ip22 RTC was broken, fixed thanks to Julien Blache.
* [mips] Fix SGI ip22 serial console, thanks to Julien Blache.
-- dann frazier <dannf@debian.org> Sat, 8 Jul 2006 21:31:04 -0600

View File

@ -0,0 +1,21 @@
The patch below fixes serial console hangs as seen on IP22
machines. Typically, while booting, the machine hangs for ~1 minute
displaying "INIT: ", then the same thing happens again when init
enters in the designated runlevel and finally the getty process on
ttyS0 hangs indefinitely (though strace'ing it helps).
Signed-off-by: Julien BLACHE <jb@jblache.org>
--- source-mips-none/drivers/serial/ip22zilog.c 2006-06-18 03:49:35.000000000 +0200
+++ source/drivers/serial/ip22zilog.c 2006-07-09 14:25:11.847260358 +0200
@@ -1145,9 +1145,8 @@
up[(chip * 2) + 1].port.fifosize = 1;
up[(chip * 2) + 1].port.ops = &ip22zilog_pops;
up[(chip * 2) + 1].port.type = PORT_IP22ZILOG;
- up[(chip * 2) + 1].port.flags |= IP22ZILOG_FLAG_IS_CHANNEL_A;
up[(chip * 2) + 1].port.line = (chip * 2) + 1;
- up[(chip * 2) + 1].flags = 0;
+ up[(chip * 2) + 1].flags |= IP22ZILOG_FLAG_IS_CHANNEL_A;
}
}

View File

@ -7,3 +7,4 @@
+ mips-sb1-inthandler.patch
+ mips-bcm1480-inthandler-typo.patch
+ mips-sb1250-duart.patch
+ mips-ip22-serial-fix.patch