Update to 4.3-rc6

This commit is contained in:
Ben Hutchings 2015-10-19 02:29:50 +01:00
parent 17cc8f4497
commit 79863cf1e4
3 changed files with 6 additions and 37 deletions

6
debian/changelog vendored
View File

@ -1,3 +1,9 @@
linux (4.3~rc6-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate
-- Ben Hutchings <ben@decadent.org.uk> Mon, 19 Oct 2015 02:21:23 +0100
linux (4.3~rc5-1~exp1) experimental; urgency=medium
* New upstream release candidate

View File

@ -1,36 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 5 Oct 2015 16:40:01 +0100
Subject: crypto x86/camellia_aesni_avx: Fix CPU feature checks
Bug-Debian: https://bugs.debian.org/800934
Forwarded: http://mid.gmane.org/1444131093.2956.122.camel@decadent.org.uk
We need to explicitly check the AVX and AES CPU features, as we can't
infer them from the related XSAVE feature flags. For example, the
Core i3 2310M passes the XSAVE feature test but does not implement
AES-NI.
Reported-and-tested-by: Stéphane Glondu <glondu@debian.org>
References: https://bugs.debian.org/800934
Fixes: ce4f5f9b65ae ("x86/fpu, crypto x86/camellia_aesni_avx: Simplify...")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
Cc: stable <stable@vger.kernel.org> # 4.2
---
arch/x86/crypto/camellia_aesni_avx_glue.c | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/arch/x86/crypto/camellia_aesni_avx_glue.c b/arch/x86/crypto/camellia_aesni_avx_glue.c
index 80a0e43..bacaa13 100644
--- a/arch/x86/crypto/camellia_aesni_avx_glue.c
+++ b/arch/x86/crypto/camellia_aesni_avx_glue.c
@@ -554,6 +554,11 @@ static int __init camellia_aesni_init(void)
{
const char *feature_name;
+ if (!cpu_has_avx || !cpu_has_aes || !cpu_has_osxsave) {
+ pr_info("AVX or AES-NI instructions are not detected.\n");
+ return -ENODEV;
+ }
+
if (!cpu_has_xfeatures(XSTATE_SSE | XSTATE_YMM, &feature_name)) {
pr_info("CPU feature '%s' is not supported.\n", feature_name);
return -ENODEV;

View File

@ -81,4 +81,3 @@ features/all/grsecurity/grkernsec_perf_harden.patch
bugfix/all/media-uvcvideo-disable-hardware-timestamps-by-defaul.patch
bugfix/all/ovl-conditionally-use-o_largefile-in-ovl_copy_up.patch
bugfix/x86/crypto-x86-camellia_aesni_avx-fix-cpu-feature-checks.patch