Bump ABI to 2

This commit is contained in:
Ben Hutchings 2017-01-27 18:14:37 +00:00
parent 8c4510fb2e
commit 79253df3bb
36 changed files with 7 additions and 439151 deletions

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

6
debian/changelog vendored
View File

@ -1,3 +1,9 @@
linux (4.9.6-2) UNRELEASED; urgency=medium
* Bump ABI to 2
-- Ben Hutchings <ben@decadent.org.uk> Fri, 27 Jan 2017 18:14:31 +0000
linux (4.9.6-1) unstable; urgency=medium
* New upstream stable update:

View File

@ -1,5 +1,5 @@
[abi]
abiname: 1
abiname: 2
ignore-changes:
__cpuhp_*
module:drivers/net/wireless/**

View File

@ -1,23 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 27 Jan 2017 04:53:54 +0000
Subject: arm64: ptrace: Avoid ABI change in 4.9.6
Forwarded: not-needed
Commit aeb1f39d814b "arm64/ptrace: Avoid uninitialised struct padding
in fpr_set()" added a new member to struct user_fpsimd_state, but it
takes the place of what was padding (for 128-bit alignment). Hide
this from genksyms.
---
--- a/arch/arm64/include/uapi/asm/ptrace.h
+++ b/arch/arm64/include/uapi/asm/ptrace.h
@@ -77,7 +77,9 @@ struct user_fpsimd_state {
__uint128_t vregs[32];
__u32 fpsr;
__u32 fpcr;
+#if !defined(__KERNEL__) || !defined(__GENKSYMS__)
__u32 __reserved[2];
+#endif
};
struct user_hwdebug_state {

View File

@ -1,23 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 23 Jan 2017 15:22:56 +0000
Subject: cfg80211: avoid ABI change in 4.9.3
Forwarded: not-needed
enum nl80211_attrs got a new enumerator, which should be safe (it's
meant to be extensible). But two exported functions take it as a
parameter type. Hide the change from genksyms so it doesn't consider
this to change their ABI.
---
--- a/include/uapi/linux/nl80211.h
+++ b/include/uapi/linux/nl80211.h
@@ -2339,7 +2339,9 @@ enum nl80211_attrs {
NL80211_ATTR_NAN_FUNC,
NL80211_ATTR_NAN_MATCH,
+#if !defined(__KERNEL__) || !defined(__GENKSYMS__)
NL80211_ATTR_BSSID,
+#endif
/* add attributes here, update the policy in nl80211.c */

View File

@ -1,25 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 23 Jan 2017 04:28:47 +0000
Subject: memcg: Avoid ABI change in 4.9.5
Forwarded: not-needed
struct mem_cgroup_per_node was changed by commit b4536f0c829c
"mm, memcg: fix the active list aging for lowmem requests when
memcg is enabled", backported into 4.9.5. This structure
isn't used by modules, so hide the change.
---
--- a/include/linux/memcontrol.h
+++ b/include/linux/memcontrol.h
@@ -120,7 +120,11 @@ struct mem_cgroup_reclaim_iter {
*/
struct mem_cgroup_per_node {
struct lruvec lruvec;
+#ifdef __GENKSYMS__
+ unsigned long lru_size[NR_LRU_LISTS];
+#else
unsigned long lru_zone_size[MAX_NR_ZONES][NR_LRU_LISTS];
+#endif
struct mem_cgroup_reclaim_iter iter[DEF_PRIORITY + 1];

View File

@ -1,28 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 23 Jan 2017 14:34:01 +0000
Subject: power: Fix ABI change in 4.9.3
Forwarded: not-needed
Commit bed570307ed7 "PM / wakeirq: Fix dedicated wakeirq for drivers
not using autosuspend" changed struct wake_irq, but it is only used
by built-in code and its definition is not exposed to OOT modules
at all. Hide the change from genksyms.
---
--- a/drivers/base/power/power.h
+++ b/drivers/base/power/power.h
@@ -28,8 +28,13 @@ extern void pm_runtime_remove(struct dev
struct wake_irq {
struct device *dev;
+#ifndef __GENKSYMS__
unsigned int status;
+#endif
int irq;
+#ifdef __GENKSYMS__
+ bool dedicated_irq:1;
+#endif
};
extern void dev_pm_arm_wake_irq(struct wake_irq *wirq);

View File

@ -114,10 +114,6 @@ bugfix/powerpc/powerpc-fix-missing-crcs-add-yet-more-asm-prototypes.patch
bugfix/all/module-disable-matching-missing-version-crc.patch
# ABI maintenance
debian/memcg-avoid-abi-change-in-4.9.5.patch
debian/power-avoid-abi-change-in-4.9.3.patch
debian/cfg80211-avoid-abi-change-in-4.9.3.patch
debian/arm64-ptrace-avoid-abi-change-in-4.9.6.patch
# Tools bug fixes
bugfix/all/usbip-document-tcp-wrappers.patch