Update to 4.1-rc8

svn path=/dists/trunk/linux/; revision=22760
This commit is contained in:
Ben Hutchings 2015-06-16 22:54:51 +00:00
parent ecabdfe56d
commit 785dd82c82
6 changed files with 7 additions and 122 deletions

3
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.1~rc5-1~exp1) UNRELEASED; urgency=medium
linux (4.1~rc8-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate
@ -8,7 +8,6 @@ linux (4.1~rc5-1~exp1) UNRELEASED; urgency=medium
- linux-image: Fix timestamps in the built-in initramfs
- linux-source: Fix timestamps in the tarball
- linux-doc: Drop original timestamp (and name) when compressing
* mac80211: Fix fatal kernel-doc errors
* aufs: Apply patches to enable building aufs out-of-tree
[ maximilian attems ]

View File

@ -96,7 +96,7 @@ upstream submission.
fw_size = firmware->size / sizeof(u32);
--- a/drivers/bluetooth/ath3k.c
+++ b/drivers/bluetooth/ath3k.c
@@ -394,10 +394,8 @@ static int ath3k_load_patch(struct usb_d
@@ -398,10 +398,8 @@ static int ath3k_load_patch(struct usb_d
le32_to_cpu(fw_version.rom_version));
ret = request_firmware(&firmware, filename, &udev->dev);
@ -108,7 +108,7 @@ upstream submission.
pt_rom_version = get_unaligned_le32(firmware->data +
firmware->size - 8);
@@ -457,10 +455,8 @@ static int ath3k_load_syscfg(struct usb_
@@ -461,10 +459,8 @@ static int ath3k_load_syscfg(struct usb_
le32_to_cpu(fw_version.rom_version), clk_value, ".dfu");
ret = request_firmware(&firmware, filename, &udev->dev);
@ -154,7 +154,7 @@ upstream submission.
--- a/drivers/bluetooth/bt3c_cs.c
+++ b/drivers/bluetooth/bt3c_cs.c
@@ -571,10 +571,8 @@ static int bt3c_open(struct bt3c_info *i
@@ -568,10 +568,8 @@ static int bt3c_open(struct bt3c_info *i
/* Load firmware */
err = request_firmware(&firmware, "BT3CPCC.bin", &info->p_dev->dev);
@ -1246,9 +1246,9 @@ upstream submission.
--- a/drivers/net/ethernet/brocade/bna/cna_fwimg.c
+++ b/drivers/net/ethernet/brocade/bna/cna_fwimg.c
@@ -31,10 +31,8 @@ cna_read_firmware(struct pci_dev *pdev,
{
@@ -32,10 +32,8 @@ cna_read_firmware(struct pci_dev *pdev,
const struct firmware *fw;
u32 n;
- if (request_firmware(&fw, fw_name, &pdev->dev)) {
- pr_alert("Can't locate firmware %s\n", fw_name);
@ -2610,7 +2610,7 @@ upstream submission.
filename, emu->firmware->size);
--- a/sound/pci/hda/hda_intel.c
+++ b/sound/pci/hda/hda_intel.c
@@ -1614,10 +1614,8 @@ static void azx_firmware_cb(const struct
@@ -1619,10 +1619,8 @@ static void azx_firmware_cb(const struct
struct azx *chip = card->private_data;
struct pci_dev *pci = chip->pci;

View File

@ -1,29 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 27 May 2015 20:26:54 +0100
Subject: mac80211: Fix fatal kernel-doc errors
kernel-doc currently fails on include/net/mac80211.h because the
comments for two struct types claim they are enum types.
Fixes: a9409093d23c ("mac80211: notify the driver about authentication status")
---
--- a/include/net/mac80211.h
+++ b/include/net/mac80211.h
@@ -354,7 +354,7 @@ enum ieee80211_rssi_event_data {
};
/**
- * enum ieee80211_rssi_event - data attached to an %RSSI_EVENT
+ * struct ieee80211_rssi_event - data attached to an %RSSI_EVENT
* @data: See &enum ieee80211_rssi_event_data
*/
struct ieee80211_rssi_event {
@@ -388,7 +388,7 @@ enum ieee80211_mlme_event_status {
};
/**
- * enum ieee80211_mlme_event - data attached to an %MLME_EVENT
+ * struct ieee80211_mlme_event - data attached to an %MLME_EVENT
* @data: See &enum ieee80211_mlme_event_data
* @status: See &enum ieee80211_mlme_event_status
* @reason: the reason code if applicable

View File

@ -1,45 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 24 May 2015 04:21:46 +0100
Subject: USB: musb: Fix order of conditions for assigning end point operations
Forwarded: http://mid.gmane.org/1432438052.12412.98.camel@decadent.org.uk
Currently we always assign one of the two common implementations of
ep_offset and ep_select operations, overwriting any platform-specific
implementations.
Fixes: d026e9c76aac ("usb: musb: Change end point selection to use new IO access")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/usb/musb/musb_core.c | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
--- a/drivers/usb/musb/musb_core.c
+++ b/drivers/usb/musb/musb_core.c
@@ -2021,13 +2021,7 @@ musb_init_controller(struct device *dev,
if (musb->ops->quirks)
musb->io.quirks = musb->ops->quirks;
- /* At least tusb6010 has it's own offsets.. */
- if (musb->ops->ep_offset)
- musb->io.ep_offset = musb->ops->ep_offset;
- if (musb->ops->ep_select)
- musb->io.ep_select = musb->ops->ep_select;
-
- /* ..and some devices use indexed offset or flat offset */
+ /* Most devices use indexed offset or flat offset */
if (musb->io.quirks & MUSB_INDEXED_EP) {
musb->io.ep_offset = musb_indexed_ep_offset;
musb->io.ep_select = musb_indexed_ep_select;
@@ -2036,6 +2030,12 @@ musb_init_controller(struct device *dev,
musb->io.ep_select = musb_flat_ep_select;
}
+ /* At least tusb6010 has its own offsets */
+ if (musb->ops->ep_offset)
+ musb->io.ep_offset = musb->ops->ep_offset;
+ if (musb->ops->ep_select)
+ musb->io.ep_select = musb->ops->ep_select;
+
if (musb->ops->fifo_mode)
fifo_mode = musb->ops->fifo_mode;
else

View File

@ -1,37 +0,0 @@
From: Sasha Levin <sasha.levin@oracle.com>
Subject: vfs: read file_handle only once in handle_to_path
Date: Wed, 28 Jan 2015 15:30:43 -0500
Origin: http://article.gmane.org/gmane.linux.file-systems/92438
We used to read file_handle twice. Once to get the amount of extra bytes, and
once to fetch the entire structure.
This may be problematic since we do size verifications only after the first
read, so if the number of extra bytes changes in userspace between the first
and second calls, we'll have an incoherent view of file_handle.
Instead, read the constant size once, and copy that over to the final
structure without having to re-read it again.
Signed-off-by: Sasha Levin <sasha.levin@oracle.com>
---
Change in v2:
- Use the f_handle pointer rather than size of struct
fs/fhandle.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
--- a/fs/fhandle.c
+++ b/fs/fhandle.c
@@ -195,8 +195,9 @@ static int handle_to_path(int mountdirfd
goto out_err;
}
/* copy the full handle */
- if (copy_from_user(handle, ufh,
- sizeof(struct file_handle) +
+ *handle = f_handle;
+ if (copy_from_user(&handle->f_handle,
+ &ufh->f_handle,
f_handle.handle_bytes)) {
retval = -EFAULT;
goto out_handle;

View File

@ -68,11 +68,8 @@ debian/i2o-disable-i2o_ext_adaptec-on-64bit.patch
bugfix/all/aic94xx-remove-broken-fallback-for-missing-ctrl-a.patch
bugfix/all/rtsx_usb_ms-use-msleep_interruptible-in-polling-loop.patch
bugfix/all/net-mv643xx-disable-tso-by-default.patch
bugfix/all/vfs-read-file_handle-only-once-in-handle_to_path.patch
debian/emmc-don-t-initialize-partitions-on-rpmb-flagged-areas.patch
bugfix/all/make-highlights-deterministic-in-kernel-doc.patch
bugfix/all/musb-musb-fix-order-of-conditions-for-assigning-end-p.patch
bugfix/all/mac80211-fix-fatal-kernel-doc-errors.patch
# Miscellaneous features
features/all/efi-autoload-efi-pstore.patch