Apply m68k fixes from Thorsten Glaser

svn path=/dists/sid/linux/; revision=20493
This commit is contained in:
Ben Hutchings 2013-08-13 18:18:41 +00:00
parent fb4f2e3217
commit 77eb3f2647
30 changed files with 90 additions and 27 deletions

7
debian/changelog vendored
View File

@ -3,6 +3,13 @@ linux (3.10.5-2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* [x86] Enable ASUS_OLED as module (Closes: #680016)
[ Thorsten Glaser ]
* [m68k] debian/patches/bugfix/m68k/atari-irqs.patch: patch from mailing list
to silence IRQ problems on Atari platforms with multi-platform kernel
* [m68k] debian/patches/bugfix/m68k/type-fix-div64.patch: patch from Andreas
Schwab to handle do_div being called with a non-u32 second argument
* [m68k] begin working on d-i kernel configs (just enough to not FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Fri, 09 Aug 2013 15:54:02 +0200
linux (3.10.5-1) unstable; urgency=low

View File

@ -1,4 +1,2 @@
# arch version flavour installedname suffix build-depends
m68k - amiga - y -
m68k - atari - y -
m68k - mac - y -
m68k - m68k - - -

View File

@ -1 +0,0 @@
#include <btrfs-modules>

View File

@ -1 +0,0 @@
#include <cdrom-core-modules>

View File

@ -1 +0,0 @@
#include <crc-modules>

View File

@ -1 +0,0 @@
#include <crypto-modules>

View File

@ -1 +0,0 @@
#include <fat-modules>

View File

@ -1 +0,0 @@
#include <fuse-modules>

View File

@ -1 +0,0 @@
#include <isofs-modules>

View File

@ -1 +0,0 @@
#include <jfs-modules>

View File

@ -1 +0,0 @@
# empty

View File

@ -1 +0,0 @@
#include <md-modules>

View File

@ -1 +0,0 @@
#include <nbd-modules>

View File

@ -1,2 +0,0 @@
#include "../m68k/nic-shared-modules"
libphy

View File

@ -1 +0,0 @@
#include <ppp-modules>

View File

@ -1 +0,0 @@
#include "../m68k/scsi-modules"

View File

@ -1 +0,0 @@
#include <squashfs-modules>

View File

@ -1 +0,0 @@
#include <udf-modules>

View File

@ -1 +0,0 @@
#include <zlib-modules>

View File

@ -0,0 +1 @@
#include <core-modules>

View File

@ -0,0 +1 @@
#include <ext2-modules>

View File

@ -0,0 +1,2 @@
#include <ext3-modules>

View File

@ -0,0 +1 @@
#include <ext4-modules>

View File

@ -1 +0,0 @@
#include <jfs-modules>

View File

@ -1,11 +1,19 @@
#include <nic-shared-modules>
82596 ?
8390 ?
8390p ?
7990 ?
a2065 ?
apne ?
ariadne ?
ariadne2 ?
atarilance ?
dummy
hydra ?
mac89x0 ?
macsonic ?
zorro8390 ?
ne ?
atari_ethernec ?
smc91x ?
libphy

View File

@ -3,6 +3,7 @@
# architecture, which is derived from the files in the modules directory.
# It overwrites specifications from /usr/share/kernel-wedge/package-list.
#
Package: kernel-image
Provides: loop-modules, ext2-modules, ext3-modules
#Provides_mac: loop-modules, ext2-modules, ext3-modules, hfs-modules
#Package: ide-modules
# add kernel/drivers/* I think
# also SCSI drivers are now modular…

View File

@ -0,0 +1,18 @@
From: Thorsten Glaser <tg@debian.org>
Description: m68k: handle Atari interrupts in multi-platform kernels
Origin: http://thread.gmane.org/gmane.linux.debian.devel.kernel/91476/focus=5003
Forwarded: http://thread.gmane.org/gmane.linux.ports.m68k/5009
--- a/arch/m68k/include/asm/irqflags.h
+++ b/arch/m68k/include/asm/irqflags.h
@@ -67,6 +67,10 @@ static inline void arch_local_irq_restor
static inline bool arch_irqs_disabled_flags(unsigned long flags)
{
+ if (MACH_IS_ATARI) {
+ /* Ignore HSYNC = ipl 2 on Atari */
+ return (flags & ~(ALLOWINT | 0x200)) != 0;
+ }
return (flags & ~ALLOWINT) != 0;
}

View File

@ -1,5 +1,6 @@
# DP: cherry-picked from commit edee09224891c259071238d5a8d2be5e3ca7f09c
# DP: make SMC91X selectible for ATARI_ETHERNAT
Author: Michael Schmitz <schmitzmic@gmail.com>
Description: Make SMC91X driver selectable for ATARI_ETHERNAT boards
Origin: http://git.kernel.org/cgit/linux/kernel/git/geert/linux-m68k.git/commit/?id=edee09224891c259071238d5a8d2be5e3ca7f09c
--- a/drivers/net/ethernet/smsc/Kconfig
+++ b/drivers/net/ethernet/smsc/Kconfig

View File

@ -0,0 +1,38 @@
From: Andreas Schwab <schwab@linux-m68k.org>
Message-ID: <871u633t27.fsf@igel.home>
Date: Fri, 09 Aug 2013 15:14:08 +0200
Subject: [PATCH] m68k: truncate base in do_div
Origin: http://thread.gmane.org/gmane.linux.ports.m68k/5008
Explicitly truncate the second operand of do_div to 32 bits to guard
against bogus code calling it with a 64bit divisor.
Signed-off-by: Andreas Schwab <schwab@linux-m68k.org>
---
arch/m68k/include/asm/div64.h | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
--- a/arch/m68k/include/asm/div64.h
+++ b/arch/m68k/include/asm/div64.h
@@ -15,16 +15,17 @@
unsigned long long n64; \
} __n; \
unsigned long __rem, __upper; \
+ unsigned long __base = (base); \
\
__n.n64 = (n); \
if ((__upper = __n.n32[0])) { \
asm ("divul.l %2,%1:%0" \
- : "=d" (__n.n32[0]), "=d" (__upper) \
- : "d" (base), "0" (__n.n32[0])); \
+ : "=d" (__n.n32[0]), "=d" (__upper) \
+ : "d" (__base), "0" (__n.n32[0])); \
} \
asm ("divu.l %2,%1:%0" \
- : "=d" (__n.n32[1]), "=d" (__rem) \
- : "d" (base), "1" (__upper), "0" (__n.n32[1])); \
+ : "=d" (__n.n32[1]), "=d" (__rem) \
+ : "d" (__base), "1" (__upper), "0" (__n.n32[1])); \
(n) = __n.n64; \
__rem; \
})

View File

@ -114,3 +114,9 @@ bugfix/all/nl80211-fix-another-nl80211_fam-attrbuf-race.patch
bugfix/all/ext4-fix-retry-handling-in-ext4_ext_truncate.patch
bugfix/all/atl1c-Fix-misuse-of-netdev_alloc_skb-in-refilling-rx.patch
bugfix/all/SCSI-Don-t-attempt-to-send-extended-INQUIRY-command-.patch
# m68k IRQ bugfix
bugfix/m68k/atari-irqs.patch
# m68k workaround for div64 called with wrong type args
bugfix/m68k/type-fix-div64.patch