Added hvc-console powerbook suspend-to-disk fix (Closes: #387178)

Renamed oldworld-boot-fix to .patch.

svn path=/dists/trunk/linux-2.6/; revision=7434
This commit is contained in:
Sven Luther 2006-09-17 22:24:28 +00:00
parent fda71f06d3
commit 77d4e1bb41
4 changed files with 24 additions and 1 deletions

2
debian/changelog vendored
View File

@ -23,6 +23,8 @@ linux-2.6 (2.6.17+2.6.18-rc7-0experimental.1) UNRELEASED; urgency=low
* [powerpc] Added tentative patch to fix oldworld ramdisk size bug. * [powerpc] Added tentative patch to fix oldworld ramdisk size bug.
Thanks fo to Christian Aichinger for investigating and providing the Thanks fo to Christian Aichinger for investigating and providing the
patch. (Closes: #366620, #375035). patch. (Closes: #366620, #375035).
* [powerpc] Fixes hvc_console caused suspsend-to-disk breakage. Thanks to
Andrew Morton for providing the patch. (Closes: #387178)
[ Frederik Schüler ] [ Frederik Schüler ]
* Remove obsolete options from amd64 and i386 configs. * Remove obsolete options from amd64 and i386 configs.

View File

@ -0,0 +1,20 @@
From: Andrew Morton <akpm@osdl.org>
Signed-off-by: Andrew Morton <akpm@osdl.org>
---
drivers/char/hvc_console.c | 1 +
1 file changed, 1 insertion(+)
diff -puN drivers/char/hvc_console.c~hvc_console-suspend-fix drivers/char/hvc_console.c
--- a/drivers/char/hvc_console.c~hvc_console-suspend-fix
+++ a/drivers/char/hvc_console.c
@@ -669,6 +669,7 @@ int khvcd(void *unused)
do {
poll_mask = 0;
hvc_kicked = 0;
+ try_to_freeze();
wmb();
if (cpus_empty(cpus_in_xmon)) {
spin_lock(&hvc_structs_lock);
_

View File

@ -30,4 +30,5 @@
+ arm-iop-fix-cpuid + arm-iop-fix-cpuid
+ arm-get_unaligned-gcc41-const.patch + arm-get_unaligned-gcc41-const.patch
+ powerpc-serial.patch + powerpc-serial.patch
+ powerpc-oldworld-boot-fix.diff + powerpc-oldworld-boot-fix.patch
+ powerpc-hvc_console-suspend-fix.patch