Backport fix for nullpointer dereference on regulator core. Thanks Arnaud Patard.

svn path=/dists/sid/linux-2.6/; revision=18346
This commit is contained in:
Hector Oron 2011-12-04 00:33:57 +00:00
parent 4fa4671f8d
commit 77c86295ed
3 changed files with 30 additions and 0 deletions

3
debian/changelog vendored
View File

@ -2,6 +2,9 @@ linux-2.6 (3.1.4-2) UNRELEASED; urgency=low
* Fix generation of revisions for the patch list.
[ Hector Oron ]
* regulator: backport fix for nullpointer dereference in core.
-- Bastian Blank <waldi@debian.org> Thu, 01 Dec 2011 13:17:34 +0100
linux-2.6 (3.1.4-1) unstable; urgency=low

View File

@ -0,0 +1,26 @@
commit d1685e4e2c3854782272f32b71f2f3eff5c6e0d0
Author: Heiko Stübner <heiko@sntech.de>
Date: Fri Oct 14 18:00:29 2011 +0200
regulator: Fix possible nullpointer dereference in regulator_enable()
In the case where _regulator_enable returns an error it was not checked
if a supplying regulator exists before trying to disable it, leading
to a null pointer-dereference if no supplying regulator existed.
Signed-off-by: Heiko Stuebner <heiko@sntech.de>
Signed-off-by: Mark Brown <broonie@opensource.wolfsonmicro.com>
Index: source/drivers/regulator/core.c
===================================================================
--- source.orig/drivers/regulator/core.c 2011-11-28 22:48:14.000000000 +0000
+++ source/drivers/regulator/core.c 2011-12-03 23:01:59.000000000 +0000
@@ -1425,7 +1425,7 @@
ret = _regulator_enable(rdev);
mutex_unlock(&rdev->mutex);
- if (ret != 0)
+ if (ret != 0 && rdev->supply)
regulator_disable(rdev->supply);
return ret;

View File

@ -56,6 +56,7 @@
+ bugfix/all/PM-Freezer-Reimplement-wait_event_freezekillable-usi.patch
+ bugfix/all/hfs-fix-hfs_find_init-sb-ext_tree-NULL-ptr-oops.patch
+ features/x86/x86-Add-amilo-rfkill-driver-for-some-Fujitsu-Siemens.patch
+ bugfix/all/regulator_enable-nullpointer-dereference.patch
# Defer until we're sure about the system call number
#+ bugfix/ia64/ia64-Add-accept4-syscall.patch