Update to 3.8.3

svn path=/dists/trunk/linux/; revision=19918
This commit is contained in:
Ben Hutchings 2013-03-19 03:54:56 +00:00
parent 82f86eaeb1
commit 77bae59ff4
3 changed files with 4 additions and 44 deletions

5
debian/changelog vendored
View File

@ -1,4 +1,7 @@
linux (3.8.2-1~experimental.2) UNRELEASED; urgency=low
linux (3.8.3-1~experimental.1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.8.3
[ Ben Hutchings ]
* aufs: Update to aufs3.8-20130311

View File

@ -1,41 +0,0 @@
From: Sebastian Riemer <sebastian.riemer@profitbricks.com>
Date: Fri, 25 Jan 2013 12:46:59 +0100
Subject: md: protect against crash upon fsync on ro array
Bug-Debian: http://bugs.debian.org/696650
commit 0ecfa11f08c79be05eb00bba537e764e6672774d upstream.
If an fsync occurs on a read-only array, we need to send a
completion for the IO and may not increment the active IO count.
Otherwise, we hit a bug trace and can't stop the MD array anymore.
By advice of Christoph Hellwig we return success upon a flush
request but we return -EROFS for other writes.
We detect flush requests by checking if the bio has zero sectors.
Cc: Christoph Hellwig <hch@infradead.org>
Cc: Ben Hutchings <ben@decadent.org.uk>
Cc: NeilBrown <neilb@suse.de>
Signed-off-by: Sebastian Riemer <sebastian.riemer@profitbricks.com>
Reported-by: Ben Hutchings <ben@decadent.org.uk>
Acked-by: Paul Menzel <paulepanter@users.sourceforge.net>
Signed-off-by: NeilBrown <neilb@suse.de>
---
drivers/md/md.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/drivers/md/md.c b/drivers/md/md.c
index 3db3d1b..1e634a6 100644
--- a/drivers/md/md.c
+++ b/drivers/md/md.c
@@ -307,6 +307,10 @@ static void md_make_request(struct request_queue *q, struct bio *bio)
bio_io_error(bio);
return;
}
+ if (mddev->ro == 1 && unlikely(rw == WRITE)) {
+ bio_endio(bio, bio_sectors(bio) == 0 ? 0 : -EROFS);
+ return;
+ }
smp_rmb(); /* Ensure implications of 'active' are visible */
rcu_read_lock();
if (mddev->suspended) {

View File

@ -63,8 +63,6 @@ bugfix/all/ath6kl-do-not-use-virt_addr_valid.patch
features/all/xen/microcode-api-update.patch
bugfix/all/md-protect-against-crash-upon-fsync-on-ro-array.patch
# alx *still* isn't upstream
features/all/alx/alx-add-new-QCA-ethernet-driver-which-supercedes-atl.patch
features/all/alx/remove-atl1c-devices-from-alx.patch