r4064: waldi | 2005-08-29 12:59:50 +0200

* debian/bin/gencontrol.py: Really use abiname from config.
 * debian/changelog: Update.
 * debian/patches-debian/series/2.6.13-1: Move from debian/patches-debian/series/2.6.12+2.6.13-rc6-1.
 * debian/patches-debian/drivers-s390-net-klist.patch: Drop, it is included in 2.6.13.

svn path=/trunk/kernel/linux-2.6/; revision=4065
This commit is contained in:
Bastian Blank 2005-08-29 11:13:47 +00:00
parent c7e4885a56
commit 77a113f580
5 changed files with 51 additions and 280 deletions

View File

@ -111,7 +111,7 @@ $
match = re.match(version_re, version, re.X)
return match.groupdict()
def process_changelog(in_vars, changelog):
def process_changelog(in_vars, config, changelog):
ret = [None, None, None, None]
ret[0] = version = changelog[0]['Version']
vars = in_vars.copy()
@ -119,7 +119,7 @@ def process_changelog(in_vars, changelog):
ret[1] = vars['abiname'] = version['modifier']
ret[2] = ""
else:
ret[1] = vars['abiname'] = c['base']['abiname']
ret[1] = vars['abiname'] = config['base']['abiname']
ret[2] = "-%s" % vars['abiname']
vars['version'] = version['version']
vars['major'] = version['major']
@ -431,7 +431,7 @@ def main():
c = config()
version, abiname, kpkg_abiname, vars = process_changelog({}, changelog)
version, abiname, kpkg_abiname, vars = process_changelog({}, c, changelog)
packages = packages_list()
makefile = []

12
debian/changelog vendored
View File

@ -1,14 +1,8 @@
linux-2.6 (2.6.12+2.6.13-rc6-1) UNRELEASED; urgency=low
linux-2.6 (2.6.13-1) UNRELEASED; urgency=low
[ Simon Horman ]
* Unset CC_OPTIMIZE_FOR_SIZE in i386 config,
it breaks iproute's (and other netlink users) ability
to set routes. (closes: #322723)
* net-sockglue-cap.patch
[Security] Restrict socket policy loading to CAP_NET_ADMIN.
See CAN-2005-2555.
*
-- Simon Horman <horms@debian.org> Mon, 22 Aug 2005 14:54:28 +0900
-- Bastian Blank <waldi@debian.org> Thu, 25 Aug 2005 11:59:12 +0200
linux-2.6 (2.6.12-6) UNRELEASED; urgency=low

View File

@ -1,268 +0,0 @@
From: Cornelia Huck <cohuck@de.ibm.com>
Date: Mon, 8 Aug 2005 16:22:36 +0000 (-0700)
Subject: [PATCH] s390: use klist in qeth driver
X-Git-Url: http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=66aea23ff84ca81bfaeaf7d63e248b873f5c2616
[PATCH] s390: use klist in qeth driver
From: Martin Schwidesky <schwidefsky@de.ibm.com>
Convert qeth to the new klist interface and make it compiling again.
Signed-off-by: Frank Pavlic <pavlic@de.ibm.com>
Signed-off-by: Andrew Morton <akpm@osdl.org>
Signed-off-by: Linus Torvalds <torvalds@osdl.org>
---
--- a/drivers/s390/net/qeth_main.c
+++ b/drivers/s390/net/qeth_main.c
@@ -8120,20 +8120,22 @@ static struct notifier_block qeth_ip6_no
#endif
static int
-qeth_reboot_event(struct notifier_block *this, unsigned long event, void *ptr)
+__qeth_reboot_event_card(struct device *dev, void *data)
{
-
- struct device *entry;
struct qeth_card *card;
- down_read(&qeth_ccwgroup_driver.driver.bus->subsys.rwsem);
- list_for_each_entry(entry, &qeth_ccwgroup_driver.driver.devices,
- driver_list) {
- card = (struct qeth_card *) entry->driver_data;
- qeth_clear_ip_list(card, 0, 0);
- qeth_qdio_clear_card(card, 0);
- }
- up_read(&qeth_ccwgroup_driver.driver.bus->subsys.rwsem);
+ card = (struct qeth_card *) dev->driver_data;
+ qeth_clear_ip_list(card, 0, 0);
+ qeth_qdio_clear_card(card, 0);
+ return 0;
+}
+
+static int
+qeth_reboot_event(struct notifier_block *this, unsigned long event, void *ptr)
+{
+
+ driver_for_each_device(&qeth_ccwgroup_driver.driver, NULL, NULL,
+ __qeth_reboot_event_card);
return NOTIFY_DONE;
}
--- a/drivers/s390/net/qeth_proc.c
+++ b/drivers/s390/net/qeth_proc.c
@@ -27,23 +27,33 @@ const char *VERSION_QETH_PROC_C = "$Revi
#define QETH_PROCFILE_NAME "qeth"
static struct proc_dir_entry *qeth_procfile;
+static int
+qeth_procfile_seq_match(struct device *dev, void *data)
+{
+ return 1;
+}
+
static void *
qeth_procfile_seq_start(struct seq_file *s, loff_t *offset)
{
- struct list_head *next_card = NULL;
- int i = 0;
+ struct device *dev;
+ loff_t nr;
down_read(&qeth_ccwgroup_driver.driver.bus->subsys.rwsem);
- if (*offset == 0)
+ nr = *offset;
+ if (nr == 0)
return SEQ_START_TOKEN;
- /* get card at pos *offset */
- list_for_each(next_card, &qeth_ccwgroup_driver.driver.devices)
- if (++i == *offset)
- return next_card;
+ dev = driver_find_device(&qeth_ccwgroup_driver.driver, NULL,
+ NULL, qeth_procfile_seq_match);
- return NULL;
+ /* get card at pos *offset */
+ nr = *offset;
+ while (nr-- > 1 && dev)
+ dev = driver_find_device(&qeth_ccwgroup_driver.driver, dev,
+ NULL, qeth_procfile_seq_match);
+ return (void *) dev;
}
static void
@@ -55,23 +65,21 @@ qeth_procfile_seq_stop(struct seq_file *
static void *
qeth_procfile_seq_next(struct seq_file *s, void *it, loff_t *offset)
{
- struct list_head *next_card = NULL;
- struct list_head *current_card;
+ struct device *prev, *next;
if (it == SEQ_START_TOKEN) {
- next_card = qeth_ccwgroup_driver.driver.devices.next;
- if (next_card->next == next_card) /* list empty */
- return NULL;
- (*offset)++;
- } else {
- current_card = (struct list_head *)it;
- if (current_card->next == &qeth_ccwgroup_driver.driver.devices)
- return NULL; /* end of list reached */
- next_card = current_card->next;
- (*offset)++;
+ next = driver_find_device(&qeth_ccwgroup_driver.driver,
+ NULL, NULL, qeth_procfile_seq_match);
+ if (next)
+ (*offset)++;
+ return (void *) next;
}
-
- return next_card;
+ prev = (struct device *) it;
+ next = driver_find_device(&qeth_ccwgroup_driver.driver,
+ prev, NULL, qeth_procfile_seq_match);
+ if (next)
+ (*offset)++;
+ return (void *) next;
}
static inline const char *
@@ -126,7 +134,7 @@ qeth_procfile_seq_show(struct seq_file *
"-------------- ---- ------ ---------- ---- "
"---- ----- -----\n");
} else {
- device = list_entry(it, struct device, driver_list);
+ device = (struct device *) it;
card = device->driver_data;
seq_printf(s, "%s/%s/%s x%02X %-10s %-14s %-4i ",
CARD_RDEV_ID(card),
@@ -180,17 +188,20 @@ static struct proc_dir_entry *qeth_perf_
static void *
qeth_perf_procfile_seq_start(struct seq_file *s, loff_t *offset)
{
- struct list_head *next_card = NULL;
- int i = 0;
+ struct device *dev = NULL;
+ int nr;
down_read(&qeth_ccwgroup_driver.driver.bus->subsys.rwsem);
/* get card at pos *offset */
- list_for_each(next_card, &qeth_ccwgroup_driver.driver.devices){
- if (i == *offset)
- return next_card;
- i++;
- }
- return NULL;
+ dev = driver_find_device(&qeth_ccwgroup_driver.driver, NULL, NULL,
+ qeth_procfile_seq_match);
+
+ /* get card at pos *offset */
+ nr = *offset;
+ while (nr-- > 1 && dev)
+ dev = driver_find_device(&qeth_ccwgroup_driver.driver, dev,
+ NULL, qeth_procfile_seq_match);
+ return (void *) dev;
}
static void
@@ -202,12 +213,14 @@ qeth_perf_procfile_seq_stop(struct seq_f
static void *
qeth_perf_procfile_seq_next(struct seq_file *s, void *it, loff_t *offset)
{
- struct list_head *current_card = (struct list_head *)it;
+ struct device *prev, *next;
- if (current_card->next == &qeth_ccwgroup_driver.driver.devices)
- return NULL; /* end of list reached */
- (*offset)++;
- return current_card->next;
+ prev = (struct device *) it;
+ next = driver_find_device(&qeth_ccwgroup_driver.driver, prev,
+ NULL, qeth_procfile_seq_match);
+ if (next)
+ (*offset)++;
+ return (void *) next;
}
static int
@@ -216,7 +229,7 @@ qeth_perf_procfile_seq_show(struct seq_f
struct device *device;
struct qeth_card *card;
- device = list_entry(it, struct device, driver_list);
+ device = (struct device *) it;
card = device->driver_data;
seq_printf(s, "For card with devnos %s/%s/%s (%s):\n",
CARD_RDEV_ID(card),
@@ -318,8 +331,8 @@ static struct proc_dir_entry *qeth_ipato
static void *
qeth_ipato_procfile_seq_start(struct seq_file *s, loff_t *offset)
{
- struct list_head *next_card = NULL;
- int i = 0;
+ struct device *dev;
+ loff_t nr;
down_read(&qeth_ccwgroup_driver.driver.bus->subsys.rwsem);
/* TODO: finish this */
@@ -328,13 +341,16 @@ qeth_ipato_procfile_seq_start(struct seq
* output driver settings then;
* else output setting for respective card
*/
+
+ dev = driver_find_device(&qeth_ccwgroup_driver.driver, NULL, NULL,
+ qeth_procfile_seq_match);
+
/* get card at pos *offset */
- list_for_each(next_card, &qeth_ccwgroup_driver.driver.devices){
- if (i == *offset)
- return next_card;
- i++;
- }
- return NULL;
+ nr = *offset;
+ while (nr-- > 1 && dev)
+ dev = driver_find_device(&qeth_ccwgroup_driver.driver, dev,
+ NULL, qeth_procfile_seq_match);
+ return (void *) dev;
}
static void
@@ -346,18 +362,14 @@ qeth_ipato_procfile_seq_stop(struct seq_
static void *
qeth_ipato_procfile_seq_next(struct seq_file *s, void *it, loff_t *offset)
{
- struct list_head *current_card = (struct list_head *)it;
+ struct device *prev, *next;
- /* TODO: finish this */
- /*
- * maybe SEQ_SATRT_TOKEN can be returned for offset 0
- * output driver settings then;
- * else output setting for respective card
- */
- if (current_card->next == &qeth_ccwgroup_driver.driver.devices)
- return NULL; /* end of list reached */
- (*offset)++;
- return current_card->next;
+ prev = (struct device *) it;
+ next = driver_find_device(&qeth_ccwgroup_driver.driver, prev,
+ NULL, qeth_procfile_seq_match);
+ if (next)
+ (*offset)++;
+ return (void *) next;
}
static int
@@ -372,7 +384,7 @@ qeth_ipato_procfile_seq_show(struct seq_
* output driver settings then;
* else output setting for respective card
*/
- device = list_entry(it, struct device, driver_list);
+ device = (struct device *) it;
card = device->driver_data;
return 0;

View File

@ -1,3 +1,4 @@
>>>> YOUR VERSION debian/patches-debian/series/2.6.12+2.6.13-rc6-1 112531404483769
+ amd64-int3-fix.patch
+ drivers-ide-dma-blacklist-toshiba.patch
+ drivers-scsi-megaraid_splitup.patch
@ -20,3 +21,26 @@
+ sparc64-hme-lockup.patch
+ tty-locking-fixes9.patch
+ net-sockglue-cap.patch
==== ORIGINAL VERSION debian/patches-debian/series/2.6.12+2.6.13-rc6-1 112531404483769
+ amd64-int3-fix.patch
+ drivers-ide-dma-blacklist-toshiba.patch
+ drivers-scsi-megaraid_splitup.patch
+ drivers-s390-net-klist.patch
+ fbdev-radeon-noaccel.patch
+ fs-asfs-2.patch
+ ia64-irq-affinity-upfix.patch
+ modular-ide.patch
+ modular-ide-pnp.patch
+ powerpc-calibrate-tau.patch
+ powerpc-fix-power3-ftbfs.patch
+ powerpc-g3-750cxe.patch
+ powerpc-g4-l2-flush-errata.patch
+ powerpc-mkvmlinuz-support.patch
+ powerpc-pmac-cache-power34-fix.patch
+ powerpc-ppc64-vio-data.patch
+ powerpc-serial.patch
+ qla2xxx-removed.patch
+ remove-references-to-removed-drivers.patch
+ sparc64-hme-lockup.patch
+ tty-locking-fixes9.patch
==== THEIR VERSION debian/patches-debian/series/2.6.12+2.6.13-rc6-1 112531404483769

21
debian/patches-debian/series/2.6.13-1 vendored Normal file
View File

@ -0,0 +1,21 @@
+ amd64-int3-fix.patch
+ drivers-ide-dma-blacklist-toshiba.patch
+ drivers-scsi-megaraid_splitup.patch
+ drivers-s390-net-klist.patch
+ fbdev-radeon-noaccel.patch
+ fs-asfs-2.patch
+ ia64-irq-affinity-upfix.patch
+ modular-ide.patch
+ modular-ide-pnp.patch
+ powerpc-calibrate-tau.patch
+ powerpc-fix-power3-ftbfs.patch
+ powerpc-g3-750cxe.patch
+ powerpc-g4-l2-flush-errata.patch
+ powerpc-mkvmlinuz-support.patch
+ powerpc-pmac-cache-power34-fix.patch
+ powerpc-ppc64-vio-data.patch
+ powerpc-serial.patch
+ qla2xxx-removed.patch
+ remove-references-to-removed-drivers.patch
+ sparc64-hme-lockup.patch
+ tty-locking-fixes9.patch