add 2.6.20.6

aka eastern kick-off :)

svn path=/dists/trunk/linux-2.6/; revision=8429
This commit is contained in:
Maximilian Attems 2007-04-06 21:56:53 +00:00
parent 3fc0461bd6
commit 776acf1a67
3 changed files with 31 additions and 1 deletions

5
debian/changelog vendored
View File

@ -231,6 +231,9 @@ linux-2.6 (2.6.20-1~experimental.1) UNRELEASED; urgency=low
- DVB: isl6421: don't reference freed memory
- V4L: radio: Fix error in Kbuild file
- i2o: block IO errors on i2o disk
* Add stable release 2.6.20.6:
- CRYPTO api: Use the right value when advancing scatterwalk_copychunks
- uml: fix static linking for real
[ Gordon Farquharson ]
* Disable broken config options on ARM.
@ -246,7 +249,7 @@ linux-2.6 (2.6.20-1~experimental.1) UNRELEASED; urgency=low
* Allow '.' and '+' in the target dist field of the changelog. dpkg has
supported this since 1.13.20, see #361171.
-- maximilian attems <maks@debian.org> Fri, 6 Apr 2007 21:17:20 +0200
-- maximilian attems <maks@debian.org> Fri, 6 Apr 2007 23:55:24 +0200
linux-2.6 (2.6.18.dfsg.1-10) unstable; urgency=low

26
debian/patches/bugfix/2.6.20.6 vendored Normal file
View File

@ -0,0 +1,26 @@
diff --git a/crypto/scatterwalk.c b/crypto/scatterwalk.c
index a664231..0f76175 100644
--- a/crypto/scatterwalk.c
+++ b/crypto/scatterwalk.c
@@ -91,7 +91,7 @@ void scatterwalk_copychunks(void *buf, struct scatter_walk *walk,
memcpy_dir(buf, vaddr, len_this_page, out);
scatterwalk_unmap(vaddr, out);
- scatterwalk_advance(walk, nbytes);
+ scatterwalk_advance(walk, len_this_page);
if (nbytes == len_this_page)
break;
diff --git a/include/asm-um/common.lds.S b/include/asm-um/common.lds.S
index b16222b..f5de80c 100644
--- a/include/asm-um/common.lds.S
+++ b/include/asm-um/common.lds.S
@@ -15,7 +15,7 @@
PROVIDE (_unprotected_end = .);
. = ALIGN(4096);
- .note : { *(note.*) }
+ .note : { *(.note.*) }
__start___ex_table = .;
__ex_table : { *(__ex_table) }
__stop___ex_table = .;

View File

@ -41,3 +41,4 @@
+ bugfix/ia64/hardcode-arch-script-output.patch
+ bugfix/2.6.20.4
+ bugfix/2.6.20.5
+ bugfix/2.6.20.6