Update to 4.16

This commit is contained in:
Ben Hutchings 2018-04-07 20:28:31 +02:00
parent a4fdfa09ce
commit 765677fc1f
3 changed files with 9 additions and 6 deletions

7
debian/changelog vendored
View File

@ -1,4 +1,6 @@
linux (4.16~rc6-1~exp2) UNRELEASED; urgency=medium
linux (4.16-1~exp1) UNRELEASED; urgency=medium
* New upstream release: https://kernelnewbies.org/Linux_4.16
[ Roger Shimizu ]
* [armel] Bring back armel build by reverting two commits that disabled
@ -18,6 +20,9 @@ linux (4.16~rc6-1~exp2) UNRELEASED; urgency=medium
[ Sjoerd Simons ]
* Enable DRM_DP_AUX_CHARDEV (Closes: #890235)
[ Ben Hutchings ]
* Set ABI name to trunk
-- Roger Shimizu <rogershimizu@gmail.com> Fri, 23 Mar 2018 21:10:34 +0900
linux (4.16~rc6-1~exp1) experimental; urgency=medium

View File

@ -1,5 +1,5 @@
[abi]
abiname: 2
abiname: trunk
ignore-changes:
__cpuhp_*
__xive_vm_h_*

View File

@ -21,12 +21,10 @@ cc: Alexei Starovoitov <alexei.starovoitov@gmail.com>
kernel/bpf/syscall.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/kernel/bpf/syscall.c b/kernel/bpf/syscall.c
index 25d074920a00..fa58ad74cde6 100644
--- a/kernel/bpf/syscall.c
+++ b/kernel/bpf/syscall.c
@@ -1458,6 +1458,9 @@ SYSCALL_DEFINE3(bpf, int, cmd, union bpf_attr __user *, uattr, unsigned int, siz
if (!capable(CAP_SYS_ADMIN) && sysctl_unprivileged_bpf_disabled)
@@ -1848,6 +1848,9 @@ SYSCALL_DEFINE3(bpf, int, cmd, union bpf
if (sysctl_unprivileged_bpf_disabled && !capable(CAP_SYS_ADMIN))
return -EPERM;
+ if (kernel_is_locked_down("BPF"))