aufs: Update to aufs3.x-rcN-20130909

svn path=/dists/trunk/linux/; revision=20609
This commit is contained in:
Ben Hutchings 2013-09-12 02:45:13 +00:00
parent 43571530a4
commit 760f8946c2
7 changed files with 506 additions and 235 deletions

2
debian/changelog vendored
View File

@ -49,7 +49,7 @@ linux (3.11-1~exp1) UNRELEASED; urgency=low
* [armhf/armmp] Enable PINCTRL_WM8850, replacing GPIO_VT8500
* [powerpc/powerpc64] Enable CPU_FREQ_CBE (previously CBE_CPUFREQ) as module
* [armel] Re-enable iop32x and ixp4xx flavours
* aufs: Update to aufs3.x-rcN-20130826
* aufs: Update to aufs3.x-rcN-20130909
[ Bastian Blank ]
* Symlink doc directory in linux-headers packages.

View File

@ -1,38 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 31 Aug 2013 18:34:51 +0100
Subject: aufs: mvdown, don't let unprivileged users provoke a WARNING
Forwarded:
Move the WARN_ONCE() about mvdown after the capability check.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
fs/aufs/ioctl.c | 1 -
fs/aufs/mvdown.c | 2 ++
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/fs/aufs/ioctl.c b/fs/aufs/ioctl.c
index 628d627..1ac7688 100644
--- a/fs/aufs/ioctl.c
+++ b/fs/aufs/ioctl.c
@@ -152,7 +152,6 @@ long aufs_ioctl_nondir(struct file *file, unsigned int cmd, unsigned long arg)
switch (cmd) {
case AUFS_CTL_MVDOWN:
- WARN_ONCE(1, "move-down is still testing...\n");
err = au_mvdown(file->f_dentry, (void __user *)arg);
break;
diff --git a/fs/aufs/mvdown.c b/fs/aufs/mvdown.c
index e68002e..5f56645 100644
--- a/fs/aufs/mvdown.c
+++ b/fs/aufs/mvdown.c
@@ -489,6 +489,8 @@ int au_mvdown(struct dentry *dentry, struct aufs_mvdown __user *uarg)
if (unlikely(!capable(CAP_SYS_ADMIN)))
goto out;
+ WARN_ONCE(1, "move-down is still testing...\n");
+
err = -ENOMEM;
args = kmalloc(sizeof(*args), GFP_NOFS);
if (unlikely(!args))

File diff suppressed because it is too large Load Diff

View File

@ -1,13 +1,42 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Fri Jul 19 11:54:34 2013 +0900
Date: Sun Sep 8 00:42:31 2013 +0900
Subject: aufs3.x-rcN base patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/3c1c777b882a35eecf81c5417d281cd5c302542c/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/afb98f82a779f3be9e999202fc72a0768d015004/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch
aufs3.x-rcN base patch
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index 40e7155..6e43ab0 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -691,6 +691,24 @@ static inline int is_loop_device(struct file *file)
return i && S_ISBLK(i->i_mode) && MAJOR(i->i_rdev) == LOOP_MAJOR;
}
+/*
+ * for AUFS
+ * no get/put for file.
+ */
+struct file *loop_backing_file(struct super_block *sb)
+{
+ struct file *ret;
+ struct loop_device *l;
+
+ ret = NULL;
+ if (MAJOR(sb->s_dev) == LOOP_MAJOR) {
+ l = sb->s_bdev->bd_disk->private_data;
+ ret = l->lo_backing_file;
+ }
+ return ret;
+}
+EXPORT_SYMBOL_GPL(loop_backing_file);
+
/* loop sysfs attributes */
static ssize_t loop_attr_show(struct device *dev, char *page,
diff --git a/fs/file_table.c b/fs/file_table.c
index b44e4c5..aa91109 100644
--- a/fs/file_table.c

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Fri Jul 19 11:54:34 2013 +0900
Subject: aufs3.x-rcN kbuild patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/3c1c777b882a35eecf81c5417d281cd5c302542c/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/afb98f82a779f3be9e999202fc72a0768d015004/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Thu Aug 15 21:26:42 2013 +0900
Date: Sun Sep 8 00:42:31 2013 +0900
Subject: aufs3.x-rcN standalone patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/3c1c777b882a35eecf81c5417d281cd5c302542c/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/afb98f82a779f3be9e999202fc72a0768d015004/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch
@ -50,7 +50,7 @@ index cc35712..16e2667 100644
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index 7b1ca9b..51db6ad 100644
index a45ba4f..f32874b 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -54,6 +54,7 @@ EXPORT_SYMBOL_GPL(fs_kobj);

View File

@ -27,8 +27,6 @@ features/all/aufs3/aufs3-add.patch
debian/aufs3-mark-as-staging.patch
# hide broken config option
debian/AUFS_PROC_MAP-is-BROKEN.patch
# security fix
features/all/aufs3/aufs-mvdown-don-t-let-unprivileged-users-provoke-a-W.patch
# Change some defaults for security reasons
features/all/sysrq-mask.patch