Do not use link-vmlinux.sh when cleaning external modules (Closes: #696775)

svn path=/dists/trunk/linux/; revision=19658
This commit is contained in:
Ben Hutchings 2012-12-29 01:25:08 +00:00
parent 42681a39c4
commit 7459df34cd
3 changed files with 35 additions and 0 deletions

1
debian/changelog vendored
View File

@ -3,6 +3,7 @@ linux (3.7.1-1~experimental.2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* linux-headers-common: Include the include/uapi/asm-generic directory
(Closes: #696664)
* Do not use link-vmlinux.sh when cleaning external modules (Closes: #696775)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 29 Dec 2012 02:05:46 +0100

View File

@ -0,0 +1,33 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: Clean modules without link-vmlinux.sh
Date: Sat, 29 Dec 2012 01:51:05 +0100
Bug-Debian: http://bugs.debian.org/696775
Calling link-vmlinux.sh when cleaning external modules is stupid.
--- a/Makefile
+++ b/Makefile
@@ -1036,11 +1036,13 @@ clean: rm-dirs := $(CLEAN_DIRS)
clean: rm-files := $(CLEAN_FILES)
clean-dirs := $(addprefix _clean_, . $(vmlinux-alldirs) Documentation samples)
-PHONY += $(clean-dirs) clean archclean
+PHONY += $(clean-dirs) clean-vmlinux clean archclean
$(clean-dirs):
$(Q)$(MAKE) $(clean)=$(patsubst _clean_%,%,$@)
+clean-vmlinux:
+ $(Q)$(CONFIG_SHELL) $(srctree)/scripts/link-vmlinux.sh clean
-clean: archclean
+clean: clean-vmlinux archclean
# mrproper - Delete all generated files, including .config
#
@@ -1267,7 +1269,6 @@ scripts: ;
endif # KBUILD_EXTMOD
clean: $(clean-dirs)
- $(Q)$(CONFIG_SHELL) $(srctree)/scripts/link-vmlinux.sh clean
$(call cmd,rmdirs)
$(call cmd,rmfiles)
@find $(if $(KBUILD_EXTMOD), $(KBUILD_EXTMOD), .) $(RCS_FIND_IGNORE) \

View File

@ -68,3 +68,4 @@ bugfix/all/pch_gbe-ptp_pch-Fix-the-dependency-direction-between.patch
debian/udl-disable-autoload.patch
debian/ast-disable-autoload.patch
debian/mgag200-disable-autoload.patch
clean-modules-without-link-vmlinux.sh.patch