Update to 2.6.37-rc3

svn path=/dists/trunk/linux-2.6/; revision=16606
This commit is contained in:
Ben Hutchings 2010-11-28 04:14:29 +00:00
parent 160388d6e0
commit 741625c82c
20 changed files with 23 additions and 127625 deletions

4
debian/changelog vendored
View File

@ -1,4 +1,6 @@
linux-2.6 (2.6.36-1~experimental.2) UNRELEASED; urgency=low
linux-2.6 (2.6.37~rc3-1~experimental.1) UNRELEASED; urgency=low
* New upstream release candidate
[ maximilian attems ]
* Newer Standards-Version 3.9.1 without changes.

View File

@ -1,120 +0,0 @@
From 6b5b361fb06eccdd53d3e85e0366b1f3687c0b2f Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 10 Sep 2010 01:23:30 +0100
Subject: [PATCH] brcm80211: Fix some initialisation failure paths
Initialise wl_info::tasklet early so that it's safe to tasklet_kill()
it in wl_free().
Remove assertions from wl_free() that may not be true in case of
initialisation failure.
Call wl_release_fw() in case of failure after wl_request_fw().
Don't rely on wl_firmware::fw_cnt in wl_release_fw().
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/staging/brcm80211/TODO | 1 -
drivers/staging/brcm80211/sys/wl_mac80211.c | 25 ++++++++++++-------------
2 files changed, 12 insertions(+), 14 deletions(-)
diff --git a/drivers/staging/brcm80211/TODO b/drivers/staging/brcm80211/TODO
index aa38d49..5870bca 100644
--- a/drivers/staging/brcm80211/TODO
+++ b/drivers/staging/brcm80211/TODO
@@ -25,7 +25,6 @@ Bugs
- Various occasional asserts/hangs
- Scanning during data transfer sometimes causes major slowdowns. Sometimes
revcovers when scan is done, other times not.
-- Driver does not handle missing firmware gracefully.
- Mac80211 API not completely implemented (ie ops_bss_info_changed,
ops_get_stats, etc)
diff --git a/drivers/staging/brcm80211/sys/wl_mac80211.c b/drivers/staging/brcm80211/sys/wl_mac80211.c
index 6c93472..d467bd7 100644
--- a/drivers/staging/brcm80211/sys/wl_mac80211.c
+++ b/drivers/staging/brcm80211/sys/wl_mac80211.c
@@ -840,6 +840,9 @@ static wl_info_t *wl_attach(uint16 vendor, uint16 device, ulong regs,
wl->osh = osh;
atomic_set(&wl->callbacks, 0);
+ /* setup the bottom half handler */
+ tasklet_init(&wl->tasklet, wl_dpc, (ulong) wl);
+
#ifdef WLC_HIGH_ONLY
wl->rpc_th = bcm_rpc_tp_attach(osh, NULL);
if (wl->rpc_th == NULL) {
@@ -908,17 +911,16 @@ static wl_info_t *wl_attach(uint16 vendor, uint16 device, ulong regs,
#endif
/* common load-time initialization */
- if (!
- (wl->wlc =
- wlc_attach((void *)wl, vendor, device, unit, wl->piomode, osh,
- wl->regsva, wl->bcm_bustype, btparam, &err))) {
+ wl->wlc = wlc_attach((void *)wl, vendor, device, unit, wl->piomode, osh,
+ wl->regsva, wl->bcm_bustype, btparam, &err);
+#ifndef WLC_HIGH_ONLY
+ wl_release_fw(wl);
+#endif
+ if (!wl->wlc) {
printf("%s: %s driver failed with code %d\n", KBUILD_MODNAME,
EPI_VERSION_STR, err);
goto fail;
}
-#ifndef WLC_HIGH_ONLY
- wl_release_fw(wl);
-#endif
wl->pub = wlc_pub(wl->wlc);
wl->pub->ieee_hw = hw;
@@ -945,9 +947,6 @@ static wl_info_t *wl_attach(uint16 vendor, uint16 device, ulong regs,
wlc_iovar_setint(wl->wlc, "sd_drivestrength", sd_drivestrength);
#endif
- /* setup the bottom half handler */
- tasklet_init(&wl->tasklet, wl_dpc, (ulong) wl);
-
#ifdef WLC_LOW
/* register our interrupt handler */
if (request_irq(irq, wl_isr, IRQF_SHARED, KBUILD_MODNAME, wl)) {
@@ -1713,11 +1712,9 @@ void wl_free(wl_info_t * wl)
ASSERT(wl);
#ifndef WLC_HIGH_ONLY
- ASSERT(wl->irq); /* bmac does not use direct interrupt */
/* free ucode data */
if (wl->fw.fw_cnt)
wl_ucode_data_free();
- ASSERT(wl->wlc);
if (wl->irq)
free_irq(wl->irq, wl);
#endif
@@ -2512,6 +2509,7 @@ static int wl_request_fw(wl_info_t * wl, struct pci_dev *pdev)
status = request_firmware(&wl->fw.fw_bin[i], fw_name, device);
if (status) {
printf("fail to request firmware %s\n", fw_name);
+ wl_release_fw(wl);
return status;
}
WL_NONE(("request fw %s\n", fw_name));
@@ -2520,6 +2518,7 @@ static int wl_request_fw(wl_info_t * wl, struct pci_dev *pdev)
status = request_firmware(&wl->fw.fw_hdr[i], fw_name, device);
if (status) {
printf("fail to request firmware %s\n", fw_name);
+ wl_release_fw(wl);
return status;
}
wl->fw.hdr_num_entries[i] =
@@ -2542,7 +2541,7 @@ void wl_ucode_free_buf(void *p)
static void wl_release_fw(wl_info_t * wl)
{
int i;
- for (i = 0; i < wl->fw.fw_cnt; i++) {
+ for (i = 0; i < WL_MAX_FW; i++) {
release_firmware(wl->fw.fw_bin[i]);
release_firmware(wl->fw.fw_hdr[i]);
}
--
1.7.1

View File

@ -1,28 +0,0 @@
From cf22a40e611cd1aeda44bca29d86e5d34ff90dc5 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 10 Oct 2010 03:31:00 +0100
Subject: [PATCH] perf: Fix detection of script extension
The extension starts with the last dot in the name, not the first.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
tools/perf/builtin-trace.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/tools/perf/builtin-trace.c b/tools/perf/builtin-trace.c
index 3ea6219..deda1a9 100644
--- a/tools/perf/builtin-trace.c
+++ b/tools/perf/builtin-trace.c
@@ -282,7 +282,7 @@ static int parse_scriptname(const struct option *opt __used,
script++;
} else {
script = str;
- ext = strchr(script, '.');
+ ext = strrchr(script, '.');
if (!ext) {
fprintf(stderr, "invalid script extension");
return -1;
--
1.7.1

View File

@ -1,171 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 10 Oct 2010 02:20:51 +0100
Subject: [PATCH] perf: Use $PERF_EXEC_PATH in canned report scripts
Set $PERF_EXEC_PATH before starting the record and report scripts, and
make them use it where necessary.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
tools/perf/builtin-trace.c | 6 +++---
tools/perf/scripts/perl/bin/failed-syscalls-report | 2 +-
tools/perf/scripts/perl/bin/rw-by-file-report | 2 +-
tools/perf/scripts/perl/bin/rw-by-pid-report | 2 +-
tools/perf/scripts/perl/bin/rwtop-report | 2 +-
tools/perf/scripts/perl/bin/wakeup-latency-report | 2 +-
tools/perf/scripts/perl/bin/workqueue-stats-report | 2 +-
.../python/bin/failed-syscalls-by-pid-report | 2 +-
.../perf/scripts/python/bin/sched-migration-report | 2 +-
tools/perf/scripts/python/bin/sctop-report | 2 +-
.../python/bin/syscall-counts-by-pid-report | 2 +-
.../perf/scripts/python/bin/syscall-counts-report | 2 +-
12 files changed, 14 insertions(+), 14 deletions(-)
diff --git a/tools/perf/builtin-trace.c b/tools/perf/builtin-trace.c
index 40a6a29..3ea6219 100644
--- a/tools/perf/builtin-trace.c
+++ b/tools/perf/builtin-trace.c
@@ -46,9 +46,6 @@ static struct scripting_ops *scripting_ops;
static void setup_scripting(void)
{
- /* make sure PERF_EXEC_PATH is set for scripts */
- perf_set_argv_exec_path(perf_exec_path());
-
setup_perl_scripting();
setup_python_scripting();
@@ -593,6 +590,9 @@ int cmd_trace(int argc, const char **argv, const char *prefix __used)
suffix = REPORT_SUFFIX;
}
+ /* make sure PERF_EXEC_PATH is set for scripts */
+ perf_set_argv_exec_path(perf_exec_path());
+
if (!suffix && argc >= 2 && strncmp(argv[1], "-", strlen("-")) != 0) {
char *record_script_path, *report_script_path;
int live_pipe[2];
diff --git a/tools/perf/scripts/perl/bin/failed-syscalls-report b/tools/perf/scripts/perl/bin/failed-syscalls-report
index e3a5e55..4028d92 100644
--- a/tools/perf/scripts/perl/bin/failed-syscalls-report
+++ b/tools/perf/scripts/perl/bin/failed-syscalls-report
@@ -7,4 +7,4 @@ if [ $# -gt 0 ] ; then
shift
fi
fi
-perf trace $@ -s ~/libexec/perf-core/scripts/perl/failed-syscalls.pl $comm
+perf trace $@ -s "$PERF_EXEC_PATH"/scripts/perl/failed-syscalls.pl $comm
diff --git a/tools/perf/scripts/perl/bin/rw-by-file-report b/tools/perf/scripts/perl/bin/rw-by-file-report
index d83070b..ba25f4d 100644
--- a/tools/perf/scripts/perl/bin/rw-by-file-report
+++ b/tools/perf/scripts/perl/bin/rw-by-file-report
@@ -7,7 +7,7 @@ if [ $# -lt 1 ] ; then
fi
comm=$1
shift
-perf trace $@ -s ~/libexec/perf-core/scripts/perl/rw-by-file.pl $comm
+perf trace $@ -s "$PERF_EXEC_PATH"/scripts/perl/rw-by-file.pl $comm
diff --git a/tools/perf/scripts/perl/bin/rw-by-pid-report b/tools/perf/scripts/perl/bin/rw-by-pid-report
index 7ef4698..641a3f5 100644
--- a/tools/perf/scripts/perl/bin/rw-by-pid-report
+++ b/tools/perf/scripts/perl/bin/rw-by-pid-report
@@ -1,6 +1,6 @@
#!/bin/bash
# description: system-wide r/w activity
-perf trace $@ -s ~/libexec/perf-core/scripts/perl/rw-by-pid.pl
+perf trace $@ -s "$PERF_EXEC_PATH"/scripts/perl/rw-by-pid.pl
diff --git a/tools/perf/scripts/perl/bin/rwtop-report b/tools/perf/scripts/perl/bin/rwtop-report
index 93e698c..4918dba 100644
--- a/tools/perf/scripts/perl/bin/rwtop-report
+++ b/tools/perf/scripts/perl/bin/rwtop-report
@@ -17,7 +17,7 @@ if [ "$n_args" -gt 0 ] ; then
interval=$1
shift
fi
-perf trace $@ -s ~/libexec/perf-core/scripts/perl/rwtop.pl $interval
+perf trace $@ -s "$PERF_EXEC_PATH"/scripts/perl/rwtop.pl $interval
diff --git a/tools/perf/scripts/perl/bin/wakeup-latency-report b/tools/perf/scripts/perl/bin/wakeup-latency-report
index a0d898f..49052eb 100644
--- a/tools/perf/scripts/perl/bin/wakeup-latency-report
+++ b/tools/perf/scripts/perl/bin/wakeup-latency-report
@@ -1,6 +1,6 @@
#!/bin/bash
# description: system-wide min/max/avg wakeup latency
-perf trace $@ -s ~/libexec/perf-core/scripts/perl/wakeup-latency.pl
+perf trace $@ -s "$PERF_EXEC_PATH"/scripts/perl/wakeup-latency.pl
diff --git a/tools/perf/scripts/perl/bin/workqueue-stats-report b/tools/perf/scripts/perl/bin/workqueue-stats-report
index 3508113..df0c65f 100644
--- a/tools/perf/scripts/perl/bin/workqueue-stats-report
+++ b/tools/perf/scripts/perl/bin/workqueue-stats-report
@@ -1,6 +1,6 @@
#!/bin/bash
# description: workqueue stats (ins/exe/create/destroy)
-perf trace $@ -s ~/libexec/perf-core/scripts/perl/workqueue-stats.pl
+perf trace $@ -s "$PERF_EXEC_PATH"/scripts/perl/workqueue-stats.pl
diff --git a/tools/perf/scripts/python/bin/failed-syscalls-by-pid-report b/tools/perf/scripts/python/bin/failed-syscalls-by-pid-report
index 3029354..0358702 100644
--- a/tools/perf/scripts/python/bin/failed-syscalls-by-pid-report
+++ b/tools/perf/scripts/python/bin/failed-syscalls-by-pid-report
@@ -7,4 +7,4 @@ if [ $# -gt 0 ] ; then
shift
fi
fi
-perf trace $@ -s ~/libexec/perf-core/scripts/python/failed-syscalls-by-pid.py $comm
+perf trace $@ -s "$PERF_EXEC_PATH"/scripts/python/netdev-times.py $comm
diff --git a/tools/perf/scripts/python/bin/sched-migration-report b/tools/perf/scripts/python/bin/sched-migration-report
index 61d05f7..df1791f 100644
--- a/tools/perf/scripts/python/bin/sched-migration-report
+++ b/tools/perf/scripts/python/bin/sched-migration-report
@@ -1,3 +1,3 @@
#!/bin/bash
# description: sched migration overview
-perf trace $@ -s ~/libexec/perf-core/scripts/python/sched-migration.py
+perf trace $@ -s "$PERF_EXEC_PATH"/scripts/python/sched-migration.py
diff --git a/tools/perf/scripts/python/bin/sctop-report b/tools/perf/scripts/python/bin/sctop-report
index b01c842..36b409c 100644
--- a/tools/perf/scripts/python/bin/sctop-report
+++ b/tools/perf/scripts/python/bin/sctop-report
@@ -21,4 +21,4 @@ elif [ "$n_args" -gt 0 ] ; then
interval=$1
shift
fi
-perf trace $@ -s ~/libexec/perf-core/scripts/python/sctop.py $comm $interval
+perf trace $@ -s "$PERF_EXEC_PATH"/scripts/python/sctop.py $comm $interval
diff --git a/tools/perf/scripts/python/bin/syscall-counts-by-pid-report b/tools/perf/scripts/python/bin/syscall-counts-by-pid-report
index 9e9d8dd..4eb88c9 100644
--- a/tools/perf/scripts/python/bin/syscall-counts-by-pid-report
+++ b/tools/perf/scripts/python/bin/syscall-counts-by-pid-report
@@ -7,4 +7,4 @@ if [ $# -gt 0 ] ; then
shift
fi
fi
-perf trace $@ -s ~/libexec/perf-core/scripts/python/syscall-counts-by-pid.py $comm
+perf trace $@ -s "$PERF_EXEC_PATH"/scripts/python/syscall-counts-by-pid.py $comm
diff --git a/tools/perf/scripts/python/bin/syscall-counts-report b/tools/perf/scripts/python/bin/syscall-counts-report
index dc076b6..cb2f9c5 100644
--- a/tools/perf/scripts/python/bin/syscall-counts-report
+++ b/tools/perf/scripts/python/bin/syscall-counts-report
@@ -7,4 +7,4 @@ if [ $# -gt 0 ] ; then
shift
fi
fi
-perf trace $@ -s ~/libexec/perf-core/scripts/python/syscall-counts.py $comm
+perf trace $@ -s "$PERF_EXEC_PATH"/scripts/python/syscall-counts.py $comm
--
1.7.1

View File

@ -1,33 +0,0 @@
From: Greg Kroah-Hartman <gregkh@suse.de>
Date: Wed, 8 Sep 2010 23:14:18 -0700
Subject: [PATCH] Staging: fix Makefile so broadcom driver will actually build.
commit 6b5e0736634d7b3d5f88d801e5a5e456190c42db upstream.
It would be nice if people tested their patches before sending
them to me...
Cc: Henry Ptasinski <henryp@broadcom.com>
Cc: Brett Rudley <brudley@broadcom.com>
Cc: Nohee Ko <noheek@broadcom.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
drivers/staging/Makefile | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/staging/Makefile b/drivers/staging/Makefile
index 2e82589..88a934e 100644
--- a/drivers/staging/Makefile
+++ b/drivers/staging/Makefile
@@ -14,7 +14,7 @@ obj-$(CONFIG_W35UND) += winbond/
obj-$(CONFIG_PRISM2_USB) += wlan-ng/
obj-$(CONFIG_ECHO) += echo/
obj-$(CONFIG_OTUS) += otus/
-obj-$(CONFIG_BRCM80211)) += brcm80211/
+obj-$(CONFIG_BRCM80211) += brcm80211/
obj-$(CONFIG_RT2860) += rt2860/
obj-$(CONFIG_RT2870) += rt2870/
obj-$(CONFIG_COMEDI) += comedi/
--
1.7.1

View File

@ -1,27 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 19 Sep 2010 02:48:38 +0100
Subject: [PATCH] vivi: Don't depend on FONTS
CONFIG_FONTS has nothing to do with whether find_font() is defined.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/media/video/Kconfig | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/media/video/Kconfig b/drivers/media/video/Kconfig
index f6e4d04..7528d50 100644
--- a/drivers/media/video/Kconfig
+++ b/drivers/media/video/Kconfig
@@ -539,7 +539,7 @@ config VIDEO_VIU
config VIDEO_VIVI
tristate "Virtual Video Driver"
depends on VIDEO_DEV && VIDEO_V4L2 && !SPARC32 && !SPARC64
- depends on (FRAMEBUFFER_CONSOLE || STI_CONSOLE) && FONTS
+ depends on FRAMEBUFFER_CONSOLE || STI_CONSOLE
select FONT_8x16
select VIDEOBUF_VMALLOC
default n
--
1.7.1

View File

@ -1,90 +0,0 @@
From: Nicolas Pitre <nico@fluxnic.net>
Date: Thu, 21 Oct 2010 19:48:33 +0000 (-0400)
Subject: [ARM] Kirkwood: restrict the scope of the PCIe reset workaround
X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Fnico%2Forion.git;a=commitdiff_plain;h=3924996bab2845bdf9a9d16ff7c20445de1ab55d
[ARM] Kirkwood: restrict the scope of the PCIe reset workaround
Commit 21f0ba90a447 "orion/kirkwood: reset PCIe unit on boot" made the
reset of the PCIe unit unconditional. While this may fix problems on some
targets, this also causes problems on other targets.
Saeed Bishara <saeed@marvell.com> said about the original problem: "We
couln't pinpoint the root cause of this issue, actually we failed to
reproduce that issue."
So let's restrict the reset of the PCIe unit only to the target where
the original problem was observed.
Signed-off-by: Nicolas Pitre <nico@fluxnic.net>
---
diff --git a/arch/arm/mach-kirkwood/ts41x-setup.c b/arch/arm/mach-kirkwood/ts41x-setup.c
index 2e14afe..6995199 100644
--- a/arch/arm/mach-kirkwood/ts41x-setup.c
+++ b/arch/arm/mach-kirkwood/ts41x-setup.c
@@ -27,6 +27,10 @@
#include "mpp.h"
#include "tsx1x-common.h"
+/* for the PCIe reset workaround */
+#include <plat/pcie.h>
+
+
#define QNAP_TS41X_JUMPER_JP1 45
static struct i2c_board_info __initdata qnap_ts41x_i2c_rtc = {
@@ -140,8 +144,16 @@ static void __init qnap_ts41x_init(void)
static int __init ts41x_pci_init(void)
{
- if (machine_is_ts41x())
+ if (machine_is_ts41x()) {
+ /*
+ * Without this explicit reset, the PCIe SATA controller
+ * (Marvell 88sx7042/sata_mv) is known to stop working
+ * after a few minutes.
+ */
+ orion_pcie_reset((void __iomem *)PCIE_VIRT_BASE);
+
kirkwood_pcie_init(KW_PCIE0);
+ }
return 0;
}
diff --git a/arch/arm/plat-orion/include/plat/pcie.h b/arch/arm/plat-orion/include/plat/pcie.h
index 3ebfef7..cc99163 100644
--- a/arch/arm/plat-orion/include/plat/pcie.h
+++ b/arch/arm/plat-orion/include/plat/pcie.h
@@ -11,12 +11,15 @@
#ifndef __PLAT_PCIE_H
#define __PLAT_PCIE_H
+struct pci_bus;
+
u32 orion_pcie_dev_id(void __iomem *base);
u32 orion_pcie_rev(void __iomem *base);
int orion_pcie_link_up(void __iomem *base);
int orion_pcie_x4_mode(void __iomem *base);
int orion_pcie_get_local_bus_nr(void __iomem *base);
void orion_pcie_set_local_bus_nr(void __iomem *base, int nr);
+void orion_pcie_reset(void __iomem *base);
void orion_pcie_setup(void __iomem *base,
struct mbus_dram_target_info *dram);
int orion_pcie_rd_conf(void __iomem *base, struct pci_bus *bus,
diff --git a/arch/arm/plat-orion/pcie.c b/arch/arm/plat-orion/pcie.c
index 779553a..af2d733 100644
--- a/arch/arm/plat-orion/pcie.c
+++ b/arch/arm/plat-orion/pcie.c
@@ -182,11 +182,6 @@ void __init orion_pcie_setup(void __iomem *base,
u32 mask;
/*
- * soft reset PCIe unit
- */
- orion_pcie_reset(base);
-
- /*
* Point PCIe unit MBUS decode windows to DRAM space.
*/
orion_pcie_setup_wins(base, dram);

View File

@ -1,9 +0,0 @@
--- a/drivers/staging/otus/Kconfig
+++ b/drivers/staging/otus/Kconfig
@@ -1,5 +1,6 @@
config OTUS
tristate "Atheros OTUS 802.11n USB wireless support"
+ depends on BROKEN
depends on USB && WLAN && MAC80211
select WIRELESS_EXT
select WEXT_PRIV

View File

@ -44,8 +44,6 @@ rm drivers/net/appletalk/cops_ltdrv.h
unifdef drivers/net/r8169.c -UREMOVE_DFSG
rm drivers/staging/otus/hal/hp*fw*.c*
unifdef drivers/staging/rtl8192u/r819xU_firmware_img.c -UREMOVE_DFSG
rm drivers/staging/vt6656/firmware.c

View File

@ -2,7 +2,7 @@ diff --git a/firmware/Makefile b/firmware/Makefile
index 1c00d05..3bf888d 100644
--- a/firmware/Makefile
+++ b/firmware/Makefile
@@ -20,53 +20,8 @@ fw-external-y := $(subst ",,$(CONFIG_EXTRA_FIRMWARE))
@@ -20,55 +20,8 @@ fw-external-y := $(subst ",,$(CONFIG_EXTRA_FIRMWARE))
# accurate. In the latter case it doesn't matter -- it'll use $(fw-shipped-all).
# But be aware that the config file might not be included at all.
@ -18,12 +18,14 @@ index 1c00d05..3bf888d 100644
- adaptec/starfire_tx.bin
fw-shipped-$(CONFIG_ATARI_DSP56K) += dsp56k/bootstrap.bin
-fw-shipped-$(CONFIG_ATM_AMBASSADOR) += atmsar11.fw
-fw-shipped-$(CONFIG_BNX2X) += bnx2x-e1-5.2.13.0.fw bnx2x-e1h-5.2.13.0.fw
-fw-shipped-$(CONFIG_BNX2) += bnx2/bnx2-mips-09-5.0.0.j15.fw \
- bnx2/bnx2-rv2p-09-5.0.0.j10.fw \
- bnx2/bnx2-rv2p-09ax-5.0.0.j10.fw \
- bnx2/bnx2-mips-06-5.0.0.j6.fw \
- bnx2/bnx2-rv2p-06-5.0.0.j3.fw
-fw-shipped-$(CONFIG_BNX2X) += bnx2x/bnx2x-e1-6.0.34.0.fw \
- bnx2x/bnx2x-e1h-6.0.34.0.fw \
- bnx2x/bnx2x-e2-6.0.34.0.fw
-fw-shipped-$(CONFIG_BNX2) += bnx2/bnx2-mips-09-6.0.17.fw \
- bnx2/bnx2-rv2p-09-6.0.17.fw \
- bnx2/bnx2-rv2p-09ax-6.0.17.fw \
- bnx2/bnx2-mips-06-6.0.15.fw \
- bnx2/bnx2-rv2p-06-6.0.15.fw
-fw-shipped-$(CONFIG_CASSINI) += sun/cassini.bin
-fw-shipped-$(CONFIG_COMPUTONE) += intelliport2.bin
-fw-shipped-$(CONFIG_CHELSIO_T3) += cxgb3/t3b_psram-1.1.0.bin \

View File

@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
@@ -192,35 +192,6 @@
@@ -192,38 +192,6 @@
CROSS_COMPILE ?=
CROSS_COMPILE ?= $(CONFIG_CROSS_COMPILE:"%"=%)
@ -17,6 +17,9 @@
-endif
-
-# Additional ARCH settings for sparc
-ifeq ($(ARCH),sparc32)
- SRCARCH := sparc
-endif
-ifeq ($(ARCH),sparc64)
- SRCARCH := sparc
-endif

View File

@ -1,7 +1,5 @@
diff --git a/drivers/char/sysrq.c b/drivers/char/sysrq.c
index 44203ff..964bab1 100644
--- a/drivers/char/sysrq.c
+++ b/drivers/char/sysrq.c
--- a/drivers/tty/sysrq.c
+++ b/drivers/tty/sysrq.c
@@ -43,7 +43,7 @@
#include <asm/irq_regs.h>

File diff suppressed because it is too large Load Diff

View File

@ -1,38 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: [PATCH] speakup: Fix references to vc_data::vc_tty
--- a/drivers/staging/speakup/buffers.c
+++ b/drivers/staging/speakup/buffers.c
@@ -30,8 +30,8 @@
for (i = 0; i < MAX_NR_CONSOLES; i++) {
if (speakup_console[i] && speakup_console[i]->tty_stopped)
continue;
- if ((vc_cons[i].d != NULL) && (vc_cons[i].d->vc_tty != NULL))
- start_tty(vc_cons[i].d->vc_tty);
+ if ((vc_cons[i].d != NULL) && (vc_cons[i].d->port.tty != NULL))
+ start_tty(vc_cons[i].d->port.tty);
}
unlock_kernel();
}
@@ -53,8 +53,8 @@
return;
}
for (i = 0; i < MAX_NR_CONSOLES; i++)
- if ((vc_cons[i].d != NULL) && (vc_cons[i].d->vc_tty != NULL))
- stop_tty(vc_cons[i].d->vc_tty);
+ if ((vc_cons[i].d != NULL) && (vc_cons[i].d->port.tty != NULL))
+ stop_tty(vc_cons[i].d->port.tty);
if (!in_atomic())
unlock_kernel();
return;
--- a/drivers/staging/speakup/main.c
+++ b/drivers/staging/speakup/main.c
@@ -2010,7 +2010,7 @@
return 0;
spk_lock(flags);
- tty = vc->vc_tty;
+ tty = vc->port.tty;
if (type >= 0xf0)
type -= 0xf0;
if (type == KT_PAD &&

View File

@ -1,28 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: [PATCH] speakup: integrate into kbuild
--- a/drivers/staging/Kconfig
+++ b/drivers/staging/Kconfig
@@ -152,6 +152,8 @@
source "drivers/staging/tidspbridge/Kconfig"
source "drivers/staging/quickstart/Kconfig"
+
+source "drivers/staging/speakup/Kconfig"
endif # !STAGING_EXCLUDE_BUILD
endif # STAGING
--- a/drivers/staging/Makefile
+++ b/drivers/staging/Makefile
@@ -57,3 +57,4 @@
obj-$(CONFIG_SOLO6X10) += solo6x10/
obj-$(CONFIG_TIDSPBRIDGE) += tidspbridge/
obj-$(CONFIG_ACPI_QUICKSTART) += quickstart/
+obj-$(CONFIG_SPEAKUP) += speakup/
--- a/drivers/staging/speakup/Kbuild
+++ b/drivers/staging/speakup/Kbuild
@@ -1,4 +1,3 @@
-include $M/allmodule.mk
obj-$(CONFIG_SPEAKUP_SYNTH_ACNTSA) += speakup_acntsa.o
obj-$(CONFIG_SPEAKUP_SYNTH_ACNTPC) += speakup_acntpc.o
obj-$(CONFIG_SPEAKUP_SYNTH_APOLLO) += speakup_apollo.o

File diff suppressed because it is too large Load Diff

View File

@ -1,33 +0,0 @@
From 3080c2292effe085e2ab795b26aeccab724d6bce Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 10 Oct 2010 22:31:26 +0100
Subject: [PATCH] ata_piix: Add device ID for ICH4-L
ICH4-L is a variant of ICH4 lacking USB2 functionality and with some
different device IDs.
It is documented in Intel specification update 290745-025, currently
at <http://www.intel.com/assets/pdf/specupdate/290745.pdf>, and is
included in the device ID table for piix.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/ata/ata_piix.c | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/drivers/ata/ata_piix.c b/drivers/ata/ata_piix.c
index 2cfc1ae..6cb14ca 100644
--- a/drivers/ata/ata_piix.c
+++ b/drivers/ata/ata_piix.c
@@ -210,6 +210,8 @@ static const struct pci_device_id piix_pci_tbl[] = {
{ 0x8086, 0x248A, PCI_ANY_ID, PCI_ANY_ID, 0, 0, ich_pata_100 },
/* Intel ICH3 (E7500/1) UDMA 100 */
{ 0x8086, 0x248B, PCI_ANY_ID, PCI_ANY_ID, 0, 0, ich_pata_100 },
+ /* Intel ICH4-L */
+ { 0x8086, 0x24C1, PCI_ANY_ID, PCI_ANY_ID, 0, 0, ich_pata_100 },
/* Intel ICH4 (i845GV, i845E, i852, i855) UDMA 100 */
{ 0x8086, 0x24CA, PCI_ANY_ID, PCI_ANY_ID, 0, 0, ich_pata_100 },
{ 0x8086, 0x24CB, PCI_ANY_ID, PCI_ANY_ID, 0, 0, ich_pata_100 },
--
1.7.1

View File

@ -1,4 +0,0 @@
+ debian/af_802154-Disable-auto-loading-as-mitigation-against.patch
+ debian/rds-Disable-auto-loading-as-mitigation-against-local.patch
+ debian/decnet-Disable-auto-loading-as-mitigation-against-lo.patch
+ features/arm/asoc-openrd-ultimate.patch

View File

@ -17,12 +17,6 @@
# mark as staging/crap
#+ features/all/aufs2/mark-as-staging.patch
# content of src/ from speakup package; generated with:
# diff -ur --unidirectional-new-file nonexistent src | filterdiff --strip=1 --addoldprefix=a/drivers/staging/speakup/ --addnewprefix=b/drivers/staging/speakup/
+ features/all/speakup/speakup-add.patch
+ features/all/speakup/speakup-kbuild.patch
+ features/all/speakup/speakup-fix-vc_tty.patch
+ bugfix/ia64/hardcode-arch-script-output.patch
+ bugfix/mips/disable-advansys.patch
+ bugfix/arm/disable-scsi_acard.patch
@ -36,17 +30,12 @@
+ debian/arch-sh4-fix-uimage-build.patch
+ debian/af_802154-Disable-auto-loading-as-mitigation-against.patch
+ debian/rds-Disable-auto-loading-as-mitigation-against-local.patch
+ debian/decnet-Disable-auto-loading-as-mitigation-against-lo.patch
+ bugfix/mips/mips-ide-flush-dcache.patch
+ features/all/staging-Add-initial-release-of-brcm80211.patch
+ bugfix/all/staging-fix-Makefile-so-broadcom-driver-will-build.patch
+ bugfix/all/brcm80211-Fix-some-initialisation-failure-paths.patch
+ bugfix/all/vivi-Don-t-depend-on-FONTS.patch
+ bugfix/all/qla4xxx-Fix-build-on-some-architectures-lacking-64-bit-I-O.patch
+ bugfix/all/perf-Use-PERF_EXEC_PATH-in-canned-report-scripts.patch
+ bugfix/all/perf-Fix-detection-of-script-extension.patch
+ bugfix/x86/Skip-looking-for-ioapic-overrides-when-ioapics-are-not-present.patch
+ features/x86/ata_piix-Add-device-ID-for-ICH4-L.patch
+ bugfix/arm/kirkwood-restrict-pcie-reset.patch
+ bugfix/arm/ixp4xx-add-missing-export.patch
+ features/arm/asoc-openrd-ultimate.patch

View File

@ -1,7 +1,6 @@
+ debian/dfsg/arch-powerpc-platforms-8xx-ucode-disable.patch
+ debian/dfsg/drivers-media-dvb-dvb-usb-af9005-disable.patch
+ debian/dfsg/drivers-net-appletalk-cops.patch
+ debian/dfsg/drivers-staging-otus-disable.patch
+ debian/dfsg/rtl8192u_usb-Remove-built-in-firmware.patch
+ debian/dfsg/drivers-staging-wlags49_h2-disable.patch
+ debian/dfsg/drivers-staging-wlags49_h25-disable.patch