[s390] Add pgste to ptep_modify_prot_start()

Fixes build breakage in 3.9.5.

svn path=/dists/sid/linux/; revision=20219
This commit is contained in:
Ben Hutchings 2013-06-09 20:16:14 +00:00
parent 935de573c8
commit 73ed4e477f
3 changed files with 33 additions and 0 deletions

2
debian/changelog vendored
View File

@ -47,6 +47,8 @@ linux (3.9.5-1) UNRELEASED; urgency=low
[ Ben Hutchings ]
* [powerpcspe] Remove installer udebs (really fixes FTBFS)
* [s390] Add pgste to ptep_modify_prot_start()
-- Ben Hutchings <ben@decadent.org.uk> Sat, 08 Jun 2013 15:25:11 +0100

View File

@ -0,0 +1,30 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 09 Jun 2013 16:54:12 +0100
Subject: s390: Add pgste to ptep_modify_prot_start()
Forwarded: http://article.gmane.org/gmane.linux.kernel.stable/55564
Commit 52f36be0f4e2 's390/pgtable: Fix check for pgste/storage key
handling', which was commit b56433cb782d upstream, added a use of
pgste to ptep_modify_prot_start(), but this variable does not exist.
In mainline, pgste was added by commit d3383632d4e8 's390/mm: add pte
invalidation notifier for kvm' and initialised to the return value of
pgste_get_lock(ptep). Initialise it similarly here.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/arch/s390/include/asm/pgtable.h
+++ b/arch/s390/include/asm/pgtable.h
@@ -1063,11 +1063,12 @@ static inline pte_t ptep_modify_prot_sta
unsigned long address,
pte_t *ptep)
{
+ pgste_t pgste;
pte_t pte;
mm->context.flush_mm = 1;
if (mm_has_pgste(mm))
- pgste_get_lock(ptep);
+ pgste = pgste_get_lock(ptep);
pte = *ptep;
if (!mm_exclusive(mm))

View File

@ -104,3 +104,4 @@ features/arm/imx53-qsb-usb-power.patch
features/arm/0001-thermal-Add-driver-for-Armada-370-XP-SoC-thermal-man.patch
features/arm/0001-ARM-mvebu-Add-thermal-support-to-Armada-XP-device-tr.patch
bugfix/s390/s390-add-pgste-to-ptep_modify_prot_start.patch