fjes: Disable auto-loading, as this driver matches a very common ACPI ID (Closes: #853976)

This commit is contained in:
Ben Hutchings 2017-03-18 20:47:20 +00:00
parent 15269fa16f
commit 73b2f137b6
3 changed files with 26 additions and 0 deletions

2
debian/changelog vendored
View File

@ -149,6 +149,8 @@ linux (4.9.14-1) UNRELEASED; urgency=medium
* ucount: Remove the atomicity from ucount->count (CVE-2017-6874)
* userns: Avoid ABI change for CVE-2017-6874 fix
* [amd64] Don't WARN about expected W+X pages on Xen (see #852324)
* fjes: Disable auto-loading, as this driver matches a very common ACPI ID
(Closes: #853976)
[ Salvatore Bonaccorso ]
* ACPI / EC: Use busy polling mode when GPE is not enabled.

View File

@ -0,0 +1,23 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 18 Mar 2017 20:47:58 +0000
Subject: fjes: Disable auto-loading
Bug-Debian: https://bugs.debian.org/853976
fjes matches a generic ACPI device ID, and relies on its probe
function to distinguish whether that really corresponds to a supported
device. Very few system will need the driver and it wastes memory on
all the other systems where the same device ID appears, so disable
auto-loading.
---
--- a/drivers/net/fjes/fjes_main.c
+++ b/drivers/net/fjes/fjes_main.c
@@ -81,7 +81,7 @@ static const struct acpi_device_id fjes_
{"PNP0C02", 0},
{"", 0},
};
-MODULE_DEVICE_TABLE(acpi, fjes_acpi_ids);
+/* MODULE_DEVICE_TABLE(acpi, fjes_acpi_ids); */
static struct acpi_driver fjes_acpi_driver = {
.name = DRV_NAME,

View File

@ -42,6 +42,7 @@ features/all/security-perf-allow-further-restriction-of-perf_event_open.patch
debian/cdc_ncm-cdc_mbim-use-ncm-by-default.patch
debian/snd-pcsp-disable-autoload.patch
bugfix/x86/viafb-autoload-on-olpc-xo1.5-only.patch
debian/fjes-disable-autoload.patch
# Taint if dangerous features are used
debian/fanotify-taint-on-use-of-fanotify_access_permissions.patch