revert s390 2.6.18.1 uaccess.S fix for now

svn path=/dists/trunk/linux-2.6/; revision=7692
This commit is contained in:
maximilian attems 2006-11-04 17:36:16 +00:00
parent c9ac5adffe
commit 733c3c79ed
3 changed files with 46 additions and 1 deletions

4
debian/changelog vendored
View File

@ -112,6 +112,8 @@ linux-2.6 (2.6.18-4) UNRELEASED; urgency=low
- uml: make Uml compile on FC6 kernel headers
- Fix potential interrupts during alternative patching
* Backport atkbd - supress "too many keys" error message.
* [s390] Revert temporarly 2.6.18.1 "S390: user readable uninitialised
kernel memory (CVE-2006-5174)" fix as it causes ftfbs
[ Sven Luther ]
* [powerpc] Added exception alignement patch from Benjamin Herrenschmidt.
@ -155,7 +157,7 @@ linux-2.6 (2.6.18-4) UNRELEASED; urgency=low
- bugfix/mips/dec-serial.patch, replaces mips-dec-serial.patch, fix
serial console handling on DECstations.
-- maximilian attems <maks@sternwelten.at> Sat, 4 Nov 2006 14:46:21 +0100
-- maximilian attems <maks@sternwelten.at> Sat, 4 Nov 2006 18:31:52 +0100
linux-2.6 (2.6.18-3) unstable; urgency=low

View File

@ -0,0 +1,42 @@
--- linux-2.6-2.6.18/arch/s390/lib/uaccess.S 2006-11-04 18:27:41.000000000 +0100
+++ linux-2.6-2.6.18/arch/s390/lib/uaccess.S.orig 2006-11-04 18:27:14.000000000 +0100
@@ -40,17 +40,7 @@ __copy_from_user_asm:
# move with the reduced length which is < 256
5: mvcp 0(%r5,%r2),0(%r4),%r0
slr %r3,%r5
- alr %r2,%r5
-6: lgr %r5,%r3 # copy remaining size
- ahi %r5,-1 # subtract 1 for xc loop
- bras %r4,8f
- xc 0(1,%2),0(%2)
-7: xc 0(256,%2),0(%2)
- la %r2,256(%r2)
-8: ahji %r5,-256
- jnm 7b
- ex %r5,0(%r2)
-9: lr %r2,%r3
+6: lr %r2,%r3
br %r14
.section __ex_table,"a"
.long 0b,4b
--- linux-2.6-2.6.18/arch/s390/lib/uaccess64.S 2006-11-04 18:27:41.000000000 +0100
+++ linux-2.6-2.6.18/arch/s390/lib/uaccess64.S.orig 2006-11-04 18:27:24.000000000 +0100
@@ -40,17 +40,7 @@ __copy_from_user_asm:
# move with the reduced length which is < 256
5: mvcp 0(%r5,%r2),0(%r4),%r0
slgr %r3,%r5
- algr %r2,%r5
-6: lgr %r5,%r3 # copy remaining size
- aghi %r5,-1 # subtract 1 for xc loop
- bras %r4,8f
- xc 0(1,%r2),0(%r2)
-7: xc 0(256,%r2),0(%r2)
- la %r2,256(%r2)
-8: aghi %r5,-256
- jnm 7b
- ex %r5,0(%r2)
-9: lgr %r2,%r3
+6: lgr %r2,%r3
br %r14
.section __ex_table,"a"
.quad 0b,4b

View File

@ -46,3 +46,4 @@
+ bugfix/2.6.18.2
+ bugfix/arm/iop3xx-mtd-map-fix.patch
+ features/input-atkb-supress-too-may-keys.patch
+ bugfix/s390-ftbfs-2.6.18.1.patch