Drop "bridge: provide a mtu() method for fake_dst_ops", only needed for 3.2

svn path=/dists/sid/linux-2.6/; revision=18452
This commit is contained in:
Ben Hutchings 2012-01-04 13:27:45 +00:00
parent 5589c09f09
commit 7193956cc5
3 changed files with 1 additions and 49 deletions

4
debian/changelog vendored
View File

@ -5,9 +5,7 @@ linux-2.6 (3.1.6-2) UNRELEASED; urgency=low
* iwlwifi: allow to switch to HT40 if not associated (Closes: #653423)
* drm/radeon: flush read cache for gtt with fence on r6xx and newer GPU
(Closes: #646376)
* net: Fix regressions that may result in a crash when using br_netfilter:
- bridge: provide a mtu() method for fake_dst_ops
- net: introduce DST_NOPEER dst flag
* net: introduce DST_NOPEER dst flag (fixes crash when using br_netfilter)
* rtc: Fix alarm rollover when day or month is out-of-range (Closes: #646429)
* l2tp: ensure sk->dst is still valid (Closes: #652503)
* Update Russian debconf template translations (Yuri Kozlov)

View File

@ -1,45 +0,0 @@
From: Eric Dumazet <eric.dumazet@gmail.com>
Date: Wed, 21 Dec 2011 20:00:32 +0000
Subject: [PATCH 1/2] bridge: provide a mtu() method for fake_dst_ops
commit a13861a28b90541aa207532d237e7a940f1b1c7b upstream.
Commit 618f9bc74a039da76 (net: Move mtu handling down to the protocol
depended handlers) forgot the bridge netfilter case, adding a NULL
dereference in ip_fragment().
Reported-by: Chris Boot <bootc@bootc.net>
CC: Steffen Klassert <steffen.klassert@secunet.com>
Signed-off-by: Eric Dumazet <eric.dumazet@gmail.com>
Acked-by: Steffen Klassert <steffen.klassert@secunet.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
net/bridge/br_netfilter.c | 6 ++++++
1 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/net/bridge/br_netfilter.c b/net/bridge/br_netfilter.c
index d6ec372..08757dc 100644
--- a/net/bridge/br_netfilter.c
+++ b/net/bridge/br_netfilter.c
@@ -114,12 +114,18 @@ static struct neighbour *fake_neigh_lookup(const struct dst_entry *dst, const vo
return NULL;
}
+static unsigned int fake_mtu(const struct dst_entry *dst)
+{
+ return dst->dev->mtu;
+}
+
static struct dst_ops fake_dst_ops = {
.family = AF_INET,
.protocol = cpu_to_be16(ETH_P_IP),
.update_pmtu = fake_update_pmtu,
.cow_metrics = fake_cow_metrics,
.neigh_lookup = fake_neigh_lookup,
+ .mtu = fake_mtu,
};
/*
--
1.7.7.3

View File

@ -89,7 +89,6 @@
+ bugfix/all/snapshot-Implement-compat_ioctl.patch
+ bugfix/all/iwlwifi-allow-to-switch-to-ht40-if-not-associated.patch
+ bugfix/all/drm-radeon-flush-read-cache-for-gtt-with-fence-on-r6.patch
+ bugfix/all/bridge-provide-a-mtu-method-for-fake_dst_ops.patch
+ bugfix/all/net-introduce-DST_NOPEER-dst-flag.patch
+ bugfix/all/rtc-Fix-alarm-rollover-when-day-or-month-is-out-of-r.patch
+ bugfix/all/l2tp-ensure-sk-dst-is-still-valid.patch