aufs: Update support patchset to aufs4.x-rcN 20180910

This commit is contained in:
Ben Hutchings 2018-09-10 15:25:34 +01:00
parent ea499d401a
commit 70e8277e19
5 changed files with 111 additions and 138 deletions

1
debian/changelog vendored
View File

@ -9,6 +9,7 @@ linux (4.19~rc3-1~exp1) UNRELEASED; urgency=medium
* [x86] boot: Fix EFI stub alignment
* wireless: Update "wireless: Disable regulatory.db direct loading" for
4.19-rc3
* aufs: Update support patchset to aufs4.x-rcN 20180910
-- Ben Hutchings <ben@decadent.org.uk> Wed, 05 Sep 2018 02:37:19 +0100

View File

@ -1,19 +1,19 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Aug 14 17:10:38 2018 +0900
Subject: aufs4.18 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/799ee5199f279477d2a5e1cff2c3f9dc44fcb3af
Date: Sat Sep 8 23:32:19 2018 +0900
Subject: aufs4.x-rcN base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/ecea3973efed5223878e489d212dc39fee4dabb6
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.18 base patch
aufs4.x-rcN base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 544cac8..aaa1c7a 100644
index 9ad052a..35c459a 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2541,6 +2541,19 @@ F: include/linux/audit.h
@@ -2605,6 +2605,19 @@ F: include/linux/audit.h
F: include/uapi/linux/audit.h
F: kernel/audit*
@ -34,10 +34,10 @@ index 544cac8..aaa1c7a 100644
M: Miguel Ojeda Sandonis <miguel.ojeda.sandonis@gmail.com>
S: Maintained
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index 4cb1d1b..5678bf8 100644
index ea9debf..9e534a3 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -741,6 +741,24 @@ static int loop_change_fd(struct loop_device *lo, struct block_device *bdev,
@@ -739,6 +739,24 @@ static int loop_change_fd(struct loop_device *lo, struct block_device *bdev,
return error;
}
@ -63,10 +63,10 @@ index 4cb1d1b..5678bf8 100644
static ssize_t loop_attr_show(struct device *dev, char *page,
diff --git a/fs/dcache.c b/fs/dcache.c
index ceb7b49..88a1514 100644
index 2e7e8d8..9f57bd8 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1237,7 +1237,7 @@ enum d_walk_ret {
@@ -1238,7 +1238,7 @@ enum d_walk_ret {
*
* The @enter() callbacks are called with d_lock held.
*/
@ -76,7 +76,7 @@ index ceb7b49..88a1514 100644
{
struct dentry *this_parent;
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 12273b6..545e686 100644
index 4137d96..c91b3e3 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -32,7 +32,7 @@
@ -98,10 +98,10 @@ index 12273b6..545e686 100644
return error;
diff --git a/fs/inode.c b/fs/inode.c
index 8c86c80..af894e7 100644
index 42f6d25..fa6ae6a 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1649,7 +1649,7 @@ EXPORT_SYMBOL(generic_update_time);
@@ -1657,7 +1657,7 @@ EXPORT_SYMBOL(generic_update_time);
* This does the actual work of updating an inodes time or version. Must have
* had called mnt_want_write() before calling this.
*/
@ -111,10 +111,10 @@ index 8c86c80..af894e7 100644
int (*update_time)(struct inode *, struct timespec64 *, int);
diff --git a/fs/namespace.c b/fs/namespace.c
index bd2f4c6..eb7cd21 100644
index 9918655..72c93f3 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -855,6 +855,12 @@ static inline int check_mnt(struct mount *mnt)
@@ -770,6 +770,12 @@ static inline int check_mnt(struct mount *mnt)
return mnt->mnt_ns == current->nsproxy->mnt_ns;
}
@ -128,7 +128,7 @@ index bd2f4c6..eb7cd21 100644
* vfsmount lock must be held for write
*/
diff --git a/fs/read_write.c b/fs/read_write.c
index 153f8f6..ccc5bc8 100644
index 39b4a21..19f8e04 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -489,6 +489,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
@ -201,23 +201,11 @@ index b54e054..2860782 100644
{
if (wait)
sync_inodes_sb(sb);
diff --git a/include/linux/file.h b/include/linux/file.h
index 279720d..76e38ea 100644
--- a/include/linux/file.h
+++ b/include/linux/file.h
@@ -20,6 +20,7 @@ struct dentry;
struct path;
extern struct file *alloc_file(const struct path *, fmode_t mode,
const struct file_operations *fop);
+extern struct file *get_empty_filp(void);
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 805bf22..0d0d247f 100644
index 3332270..e1444c2 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1273,6 +1273,7 @@ extern void fasync_free(struct fasync_struct *);
@@ -1286,6 +1286,7 @@ extern void fasync_free(struct fasync_struct *);
/* can be called from interrupts */
extern void kill_fasync(struct fasync_struct **, int, int);
@ -225,7 +213,7 @@ index 805bf22..0d0d247f 100644
extern void __f_setown(struct file *filp, struct pid *, enum pid_type, int force);
extern int f_setown(struct file *filp, unsigned long arg, int force);
extern void f_delown(struct file *filp);
@@ -1733,6 +1734,7 @@ struct file_operations {
@@ -1747,6 +1748,7 @@ struct file_operations {
ssize_t (*sendpage) (struct file *, struct page *, int, size_t, loff_t *, int);
unsigned long (*get_unmapped_area)(struct file *, unsigned long, unsigned long, unsigned long, unsigned long);
int (*check_flags)(int);
@ -233,7 +221,7 @@ index 805bf22..0d0d247f 100644
int (*flock) (struct file *, int, struct file_lock *);
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *, loff_t *, size_t, unsigned int);
ssize_t (*splice_read)(struct file *, loff_t *, struct pipe_inode_info *, size_t, unsigned int);
@@ -1803,6 +1805,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
@@ -1817,6 +1819,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
struct iovec *fast_pointer,
struct iovec **ret_pointer);
@ -246,7 +234,7 @@ index 805bf22..0d0d247f 100644
extern ssize_t __vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t vfs_write(struct file *, const char __user *, size_t, loff_t *);
@@ -2218,6 +2226,7 @@ extern int current_umask(void);
@@ -2240,6 +2248,7 @@ extern int current_umask(void);
extern void ihold(struct inode * inode);
extern void iput(struct inode *);
extern int generic_update_time(struct inode *, struct timespec64 *, int);
@ -254,7 +242,7 @@ index 805bf22..0d0d247f 100644
/* /sys/fs */
extern struct kobject *fs_kobj;
@@ -2505,6 +2514,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
@@ -2527,6 +2536,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
return false;
}
#endif
@ -263,7 +251,7 @@ index 805bf22..0d0d247f 100644
extern const struct file_operations def_blk_fops;
extern const struct file_operations def_chr_fops;
diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h
index 6fc77d4..27e76f0 100644
index b0d0b51..f73ffaa 100644
--- a/include/linux/lockdep.h
+++ b/include/linux/lockdep.h
@@ -313,6 +313,8 @@ static inline int lockdep_match_key(struct lockdep_map *lock,
@ -318,10 +306,10 @@ index 74b4911..19789fb 100644
+ unsigned int flags);
#endif
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index 5fa4d31..720f070 100644
index e406c5f..b0a8d25 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -140,7 +140,7 @@ static struct lock_list list_entries[MAX_LOCKDEP_ENTRIES];
@@ -141,7 +141,7 @@ static struct lock_list list_entries[MAX_LOCKDEP_ENTRIES];
unsigned long nr_lock_classes;
static struct lock_class lock_classes[MAX_LOCKDEP_KEYS];
@ -330,7 +318,7 @@ index 5fa4d31..720f070 100644
{
if (!hlock->class_idx) {
/*
@@ -151,6 +151,7 @@ static inline struct lock_class *hlock_class(struct held_lock *hlock)
@@ -152,6 +152,7 @@ static inline struct lock_class *hlock_class(struct held_lock *hlock)
}
return lock_classes + hlock->class_idx - 1;
}

View File

@ -1,19 +1,19 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Aug 14 17:10:38 2018 +0900
Subject: aufs4.18 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/799ee5199f279477d2a5e1cff2c3f9dc44fcb3af
Date: Sat Sep 8 23:32:19 2018 +0900
Subject: aufs4.x-rcN mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/ecea3973efed5223878e489d212dc39fee4dabb6
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.18 mmap patch
aufs4.x-rcN mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index aaffc0c..ab72941 100644
index ccf86f1..a44e9d9 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -2004,7 +2004,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
@@ -2002,7 +2002,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
down_read(&mm->mmap_sem);
vma = find_exact_vma(mm, vm_start, vm_end);
if (vma && vma->vm_file) {
@ -39,10 +39,10 @@ index 3b63be6..fb9913b 100644
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index dfd73a4..ed2ce10 100644
index 5ea1d64..7865a470 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -306,7 +306,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
@@ -305,7 +305,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma)
const char *name = NULL;
if (file) {
@ -54,7 +54,7 @@ index dfd73a4..ed2ce10 100644
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1734,7 +1737,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
@@ -1727,7 +1730,7 @@ static int show_numa_map(struct seq_file *m, void *v)
struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md;
@ -64,10 +64,10 @@ index dfd73a4..ed2ce10 100644
struct mm_walk walk = {
.hugetlb_entry = gather_hugetlb_stats,
diff --git a/fs/proc/task_nommu.c b/fs/proc/task_nommu.c
index 5b62f57..dfb4a3b 100644
index 0b63d68..400d1c5 100644
--- a/fs/proc/task_nommu.c
+++ b/fs/proc/task_nommu.c
@@ -156,7 +156,10 @@ static int nommu_vma_show(struct seq_file *m, struct vm_area_struct *vma,
@@ -155,7 +155,10 @@ static int nommu_vma_show(struct seq_file *m, struct vm_area_struct *vma)
file = vma->vm_file;
if (file) {
@ -80,10 +80,10 @@ index 5b62f57..dfb4a3b 100644
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index 68a5121..d7dd986 100644
index a61ebe8..111f031 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1448,6 +1448,28 @@ static inline void unmap_shared_mapping_range(struct address_space *mapping,
@@ -1440,6 +1440,28 @@ static inline void unmap_shared_mapping_range(struct address_space *mapping,
unmap_mapping_range(mapping, holebegin, holelen, 0);
}
@ -113,10 +113,10 @@ index 68a5121..d7dd986 100644
void *buf, int len, unsigned int gup_flags);
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index 99ce070..8babe35 100644
index cd2bc93..e499e57 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -236,6 +236,7 @@ struct vm_region {
@@ -239,6 +239,7 @@ struct vm_region {
unsigned long vm_top; /* region allocated to here */
unsigned long vm_pgoff; /* the offset in vm_file corresponding to vm_start */
struct file *vm_file; /* the backing file or NULL */
@ -124,7 +124,7 @@ index 99ce070..8babe35 100644
int vm_usage; /* region usage count (access under nommu_region_sem) */
bool vm_icache_flushed : 1; /* true if the icache has been flushed for
@@ -310,6 +311,7 @@ struct vm_area_struct {
@@ -313,6 +314,7 @@ struct vm_area_struct {
unsigned long vm_pgoff; /* Offset (within vm_file) in PAGE_SIZE
units */
struct file * vm_file; /* File we map to (can be NULL). */
@ -133,10 +133,10 @@ index 99ce070..8babe35 100644
atomic_long_t swap_readahead_info;
diff --git a/kernel/fork.c b/kernel/fork.c
index 1b27bab..382f45d 100644
index d896e9c..ea800e9 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -504,7 +504,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
@@ -505,7 +505,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
struct inode *inode = file_inode(file);
struct address_space *mapping = file->f_mapping;
@ -172,7 +172,7 @@ index 52517f2..250f675 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/mmap.c b/mm/mmap.c
index 17bbf4d..a31c3e1 100644
index 5f2b2b1..d71330c 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -180,7 +180,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
@ -193,7 +193,7 @@ index 17bbf4d..a31c3e1 100644
}
if (next->anon_vma)
anon_vma_merge(vma, next);
@@ -1820,8 +1820,8 @@ unsigned long mmap_region(struct file *file, unsigned long addr,
@@ -1821,8 +1821,8 @@ unsigned long mmap_region(struct file *file, unsigned long addr,
return addr;
unmap_and_free_vma:
@ -203,7 +203,7 @@ index 17bbf4d..a31c3e1 100644
/* Undo any partial mapping done by a device driver. */
unmap_region(mm, vma, prev, vma->vm_start, vma->vm_end);
@@ -2640,7 +2640,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
@@ -2641,7 +2641,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
goto out_free_mpol;
if (new->vm_file)
@ -212,7 +212,7 @@ index 17bbf4d..a31c3e1 100644
if (new->vm_ops && new->vm_ops->open)
new->vm_ops->open(new);
@@ -2659,7 +2659,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
@@ -2660,7 +2660,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
if (new->vm_ops && new->vm_ops->close)
new->vm_ops->close(new);
if (new->vm_file)
@ -221,7 +221,7 @@ index 17bbf4d..a31c3e1 100644
unlink_anon_vmas(new);
out_free_mpol:
mpol_put(vma_policy(new));
@@ -2821,7 +2821,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
@@ -2822,7 +2822,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
struct vm_area_struct *vma;
unsigned long populate = 0;
unsigned long ret = -EINVAL;
@ -230,7 +230,7 @@ index 17bbf4d..a31c3e1 100644
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.rst.\n",
current->comm, current->pid);
@@ -2896,10 +2896,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
@@ -2897,10 +2897,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
}
}
@ -259,7 +259,7 @@ index 17bbf4d..a31c3e1 100644
out:
up_write(&mm->mmap_sem);
if (populate)
@@ -3207,7 +3224,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
@@ -3206,7 +3223,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
if (anon_vma_clone(new_vma, vma))
goto out_free_mempol;
if (new_vma->vm_file)
@ -269,10 +269,10 @@ index 17bbf4d..a31c3e1 100644
new_vma->vm_ops->open(new_vma);
vma_link(mm, new_vma, prev, rb_link, rb_parent);
diff --git a/mm/nommu.c b/mm/nommu.c
index 9fc9e43..25d4c49 100644
index e4aac33..b27b200 100644
--- a/mm/nommu.c
+++ b/mm/nommu.c
@@ -629,7 +629,7 @@ static void __put_nommu_region(struct vm_region *region)
@@ -625,7 +625,7 @@ static void __put_nommu_region(struct vm_region *region)
up_write(&nommu_region_sem);
if (region->vm_file)
@ -281,7 +281,7 @@ index 9fc9e43..25d4c49 100644
/* IO memory and memory shared directly out of the pagecache
* from ramfs/tmpfs mustn't be released here */
@@ -767,7 +767,7 @@ static void delete_vma(struct mm_struct *mm, struct vm_area_struct *vma)
@@ -763,7 +763,7 @@ static void delete_vma(struct mm_struct *mm, struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -290,7 +290,7 @@ index 9fc9e43..25d4c49 100644
put_nommu_region(vma->vm_region);
vm_area_free(vma);
}
@@ -1290,7 +1290,7 @@ unsigned long do_mmap(struct file *file,
@@ -1286,7 +1286,7 @@ unsigned long do_mmap(struct file *file,
goto error_just_free;
}
}
@ -299,7 +299,7 @@ index 9fc9e43..25d4c49 100644
kmem_cache_free(vm_region_jar, region);
region = pregion;
result = start;
@@ -1365,7 +1365,7 @@ unsigned long do_mmap(struct file *file,
@@ -1361,7 +1361,7 @@ unsigned long do_mmap(struct file *file,
up_write(&nommu_region_sem);
error:
if (region->vm_file)

View File

@ -1,19 +1,19 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Aug 14 17:10:38 2018 +0900
Subject: aufs4.18 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/799ee5199f279477d2a5e1cff2c3f9dc44fcb3af
Date: Sat Sep 8 23:32:19 2018 +0900
Subject: aufs4.x-rcN standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/ecea3973efed5223878e489d212dc39fee4dabb6
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.18 standalone patch
aufs4.x-rcN standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index 88a1514..e3f500a 100644
index 9f57bd8..328a136 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1342,6 +1342,7 @@ void d_walk(struct dentry *parent, void *data,
@@ -1343,6 +1343,7 @@ void d_walk(struct dentry *parent, void *data,
seq = 1;
goto again;
}
@ -21,7 +21,7 @@ index 88a1514..e3f500a 100644
struct check_mount {
struct vfsmount *mnt;
@@ -2890,6 +2891,7 @@ void d_exchange(struct dentry *dentry1, struct dentry *dentry2)
@@ -2837,6 +2838,7 @@ void d_exchange(struct dentry *dentry1, struct dentry *dentry2)
write_sequnlock(&rename_lock);
}
@ -30,7 +30,7 @@ index 88a1514..e3f500a 100644
/**
* d_ancestor - search for an ancestor
diff --git a/fs/exec.c b/fs/exec.c
index bdd0eac..edd3405 100644
index 1ebf6e5..a72c294 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -109,6 +109,7 @@ bool path_noexec(const struct path *path)
@ -42,7 +42,7 @@ index bdd0eac..edd3405 100644
#ifdef CONFIG_USELIB
/*
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 545e686..0237ad7 100644
index c91b3e3..7751309 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -85,6 +85,7 @@ int setfl(int fd, struct file * filp, unsigned long arg)
@ -54,18 +54,18 @@ index 545e686..0237ad7 100644
static void f_modown(struct file *filp, struct pid *pid, enum pid_type type,
int force)
diff --git a/fs/file_table.c b/fs/file_table.c
index 7ec0b3e..819ee07 100644
index e49af4c..569020f 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -147,6 +147,7 @@ struct file *get_empty_filp(void)
@@ -161,6 +161,7 @@ struct file *alloc_empty_file(int flags, const struct cred *cred)
}
return ERR_PTR(-ENFILE);
}
+EXPORT_SYMBOL_GPL(get_empty_filp);
+EXPORT_SYMBOL_GPL(alloc_empty_file);
/**
* alloc_file - allocate and initialize a 'struct file'
@@ -257,6 +258,7 @@ void flush_delayed_fput(void)
/*
* Variant of alloc_empty_file() that doesn't check and modify nr_files.
@@ -323,6 +324,7 @@ void flush_delayed_fput(void)
{
delayed_fput(NULL);
}
@ -73,27 +73,19 @@ index 7ec0b3e..819ee07 100644
static DECLARE_DELAYED_WORK(delayed_fput_work, delayed_fput);
@@ -299,6 +301,7 @@ void __fput_sync(struct file *file)
@@ -365,6 +367,7 @@ void __fput_sync(struct file *file)
}
EXPORT_SYMBOL(fput);
+EXPORT_SYMBOL_GPL(__fput_sync);
void put_filp(struct file *file)
{
@@ -307,6 +310,7 @@ void put_filp(struct file *file)
file_free(file);
}
}
+EXPORT_SYMBOL_GPL(put_filp);
void __init files_init(void)
{
diff --git a/fs/inode.c b/fs/inode.c
index af894e7..169811b 100644
index fa6ae6a..69d4a6c 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1658,6 +1658,7 @@ int update_time(struct inode *inode, struct timespec64 *time, int flags)
@@ -1666,6 +1666,7 @@ int update_time(struct inode *inode, struct timespec64 *time, int flags)
return update_time(inode, time, flags);
}
@ -102,10 +94,10 @@ index af894e7..169811b 100644
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index eb7cd21..c536458 100644
index 72c93f3..c49803c 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -517,6 +517,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
@@ -437,6 +437,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
mnt_dec_writers(real_mount(mnt));
preempt_enable();
}
@ -113,7 +105,7 @@ index eb7cd21..c536458 100644
/**
* mnt_drop_write - give up write access to a mount
@@ -860,6 +861,7 @@ int is_current_mnt_ns(struct vfsmount *mnt)
@@ -775,6 +776,7 @@ int is_current_mnt_ns(struct vfsmount *mnt)
{
return check_mnt(real_mount(mnt));
}
@ -121,7 +113,7 @@ index eb7cd21..c536458 100644
/*
* vfsmount lock must be held for write
@@ -1917,6 +1919,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@@ -1832,6 +1834,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -130,18 +122,18 @@ index eb7cd21..c536458 100644
static void cleanup_group_ids(struct mount *mnt, struct mount *end)
{
diff --git a/fs/notify/group.c b/fs/notify/group.c
index aa5468f2..b38d224 100644
index c03b836..817f22c 100644
--- a/fs/notify/group.c
+++ b/fs/notify/group.c
@@ -22,6 +22,7 @@
#include <linux/srcu.h>
@@ -23,6 +23,7 @@
#include <linux/rculist.h>
#include <linux/wait.h>
#include <linux/memcontrol.h>
+#include <linux/module.h>
#include <linux/fsnotify_backend.h>
#include "fsnotify.h"
@@ -109,6 +110,7 @@ void fsnotify_get_group(struct fsnotify_group *group)
@@ -112,6 +113,7 @@ void fsnotify_get_group(struct fsnotify_group *group)
{
refcount_inc(&group->refcnt);
}
@ -149,7 +141,7 @@ index aa5468f2..b38d224 100644
/*
* Drop a reference to a group. Free it if it's through.
@@ -118,6 +120,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
@@ -121,6 +123,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
if (refcount_dec_and_test(&group->refcnt))
fsnotify_final_destroy_group(group);
}
@ -157,7 +149,7 @@ index aa5468f2..b38d224 100644
/*
* Create a new fsnotify_group and hold a reference for the group returned.
@@ -147,6 +150,7 @@ struct fsnotify_group *fsnotify_alloc_group(const struct fsnotify_ops *ops)
@@ -150,6 +153,7 @@ struct fsnotify_group *fsnotify_alloc_group(const struct fsnotify_ops *ops)
return group;
}
@ -166,10 +158,10 @@ index aa5468f2..b38d224 100644
int fsnotify_fasync(int fd, struct file *file, int on)
{
diff --git a/fs/notify/mark.c b/fs/notify/mark.c
index 61f4c5f..855c655 100644
index 59cdb27..ce365c7 100644
--- a/fs/notify/mark.c
+++ b/fs/notify/mark.c
@@ -245,6 +245,7 @@ void fsnotify_put_mark(struct fsnotify_mark *mark)
@@ -263,6 +263,7 @@ void fsnotify_put_mark(struct fsnotify_mark *mark)
queue_delayed_work(system_unbound_wq, &reaper_work,
FSNOTIFY_REAPER_DELAY);
}
@ -177,7 +169,7 @@ index 61f4c5f..855c655 100644
/*
* Get mark reference when we found the mark via lockless traversal of object
@@ -399,6 +400,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark,
@@ -417,6 +418,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark,
mutex_unlock(&group->mark_mutex);
fsnotify_free_mark(mark);
}
@ -185,7 +177,7 @@ index 61f4c5f..855c655 100644
/*
* Sorting function for lists of fsnotify marks.
@@ -624,6 +626,7 @@ int fsnotify_add_mark(struct fsnotify_mark *mark, struct inode *inode,
@@ -632,6 +634,7 @@ int fsnotify_add_mark(struct fsnotify_mark *mark, fsnotify_connp_t *connp,
mutex_unlock(&group->mark_mutex);
return ret;
}
@ -193,7 +185,7 @@ index 61f4c5f..855c655 100644
/*
* Given a list of marks, find the mark associated with given group. If found
@@ -747,6 +750,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
@@ -754,6 +757,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
fsnotify_get_group(group);
mark->group = group;
}
@ -202,7 +194,7 @@ index 61f4c5f..855c655 100644
/*
* Destroy all marks in destroy_list, waits for SRCU period to finish before
diff --git a/fs/open.c b/fs/open.c
index d0e955b..527bc1a 100644
index 0285ce7..cb81623 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@ -213,16 +205,8 @@ index d0e955b..527bc1a 100644
long vfs_truncate(const struct path *path, loff_t length)
{
@@ -723,6 +724,7 @@ SYSCALL_DEFINE3(fchown, unsigned int, fd, uid_t, user, gid_t, group)
{
return ksys_fchown(fd, user, group);
}
+EXPORT_SYMBOL_GPL(open_check_o_direct);
int open_check_o_direct(struct file *f)
{
diff --git a/fs/read_write.c b/fs/read_write.c
index ccc5bc8..36f52f4 100644
index 19f8e04..ae78ca8 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -459,6 +459,7 @@ ssize_t vfs_read(struct file *file, char __user *buf, size_t count, loff_t *pos)
@ -290,10 +274,10 @@ index 2860782..ffd7ea4 100644
/*
* Write out and wait upon all dirty data associated with this
diff --git a/fs/xattr.c b/fs/xattr.c
index f9cb1db..000b62b 100644
index daa7325..b550ad3 100644
--- a/fs/xattr.c
+++ b/fs/xattr.c
@@ -296,6 +296,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,
@@ -295,6 +295,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,
*xattr_value = value;
return error;
}
@ -302,10 +286,10 @@ index f9cb1db..000b62b 100644
ssize_t
__vfs_getxattr(struct dentry *dentry, struct inode *inode, const char *name,
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index 720f070..4f58215 100644
index b0a8d25..5029106 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -151,6 +151,7 @@ inline struct lock_class *lockdep_hlock_class(struct held_lock *hlock)
@@ -152,6 +152,7 @@ inline struct lock_class *lockdep_hlock_class(struct held_lock *hlock)
}
return lock_classes + hlock->class_idx - 1;
}
@ -323,7 +307,7 @@ index 0fef395..83fb1ec 100644
}
+EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/commoncap.c b/security/commoncap.c
index f4c33ab..70563f1 100644
index 2e489d6..1e146da 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -1336,12 +1336,14 @@ int cap_mmap_addr(unsigned long addr)
@ -359,10 +343,10 @@ index cd97929..424fd23 100644
}
+EXPORT_SYMBOL_GPL(__devcgroup_check_permission);
diff --git a/security/security.c b/security/security.c
index 68f46d8..3bc1348 100644
index 736e78d..b314539 100644
--- a/security/security.c
+++ b/security/security.c
@@ -537,6 +537,7 @@ int security_path_rmdir(const struct path *dir, struct dentry *dentry)
@@ -542,6 +542,7 @@ int security_path_rmdir(const struct path *dir, struct dentry *dentry)
return 0;
return call_int_hook(path_rmdir, 0, dir, dentry);
}
@ -370,7 +354,7 @@ index 68f46d8..3bc1348 100644
int security_path_unlink(const struct path *dir, struct dentry *dentry)
{
@@ -553,6 +554,7 @@ int security_path_symlink(const struct path *dir, struct dentry *dentry,
@@ -558,6 +559,7 @@ int security_path_symlink(const struct path *dir, struct dentry *dentry,
return 0;
return call_int_hook(path_symlink, 0, dir, dentry, old_name);
}
@ -378,7 +362,7 @@ index 68f46d8..3bc1348 100644
int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
struct dentry *new_dentry)
@@ -561,6 +563,7 @@ int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
@@ -566,6 +568,7 @@ int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
return 0;
return call_int_hook(path_link, 0, old_dentry, new_dir, new_dentry);
}
@ -386,7 +370,7 @@ index 68f46d8..3bc1348 100644
int security_path_rename(const struct path *old_dir, struct dentry *old_dentry,
const struct path *new_dir, struct dentry *new_dentry,
@@ -588,6 +591,7 @@ int security_path_truncate(const struct path *path)
@@ -593,6 +596,7 @@ int security_path_truncate(const struct path *path)
return 0;
return call_int_hook(path_truncate, 0, path);
}
@ -394,7 +378,7 @@ index 68f46d8..3bc1348 100644
int security_path_chmod(const struct path *path, umode_t mode)
{
@@ -595,6 +599,7 @@ int security_path_chmod(const struct path *path, umode_t mode)
@@ -600,6 +604,7 @@ int security_path_chmod(const struct path *path, umode_t mode)
return 0;
return call_int_hook(path_chmod, 0, path, mode);
}
@ -402,7 +386,7 @@ index 68f46d8..3bc1348 100644
int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
{
@@ -602,6 +607,7 @@ int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
@@ -607,6 +612,7 @@ int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
return 0;
return call_int_hook(path_chown, 0, path, uid, gid);
}
@ -410,7 +394,7 @@ index 68f46d8..3bc1348 100644
int security_path_chroot(const struct path *path)
{
@@ -687,6 +693,7 @@ int security_inode_readlink(struct dentry *dentry)
@@ -692,6 +698,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return call_int_hook(inode_readlink, 0, dentry);
}
@ -418,7 +402,7 @@ index 68f46d8..3bc1348 100644
int security_inode_follow_link(struct dentry *dentry, struct inode *inode,
bool rcu)
@@ -702,6 +709,7 @@ int security_inode_permission(struct inode *inode, int mask)
@@ -707,6 +714,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return call_int_hook(inode_permission, 0, inode, mask);
}
@ -426,7 +410,7 @@ index 68f46d8..3bc1348 100644
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
@@ -873,6 +881,7 @@ int security_file_permission(struct file *file, int mask)
@@ -878,6 +886,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -434,7 +418,7 @@ index 68f46d8..3bc1348 100644
int security_file_alloc(struct file *file)
{
@@ -932,6 +941,7 @@ int security_mmap_file(struct file *file, unsigned long prot,
@@ -937,6 +946,7 @@ int security_mmap_file(struct file *file, unsigned long prot,
return ret;
return ima_file_mmap(file, prot);
}

View File

@ -32,9 +32,9 @@ debian/firmware_class-refer-to-debian-wiki-firmware-page.patch
# Patches from aufs4 repository, imported with
# debian/patches/features/all/aufs4/gen-patch. These are only the
# changes needed to allow aufs to be built out-of-tree.
#features/all/aufs4/aufs4-base.patch
#features/all/aufs4/aufs4-mmap.patch
#features/all/aufs4/aufs4-standalone.patch
features/all/aufs4/aufs4-base.patch
features/all/aufs4/aufs4-mmap.patch
features/all/aufs4/aufs4-standalone.patch
# Change some defaults for security reasons
debian/af_802154-Disable-auto-loading-as-mitigation-against.patch