Update to 4.19-rc4

Drop lockdep build fixes that were applied or obsoleted upstream.
This commit is contained in:
Ben Hutchings 2018-09-16 23:10:56 +01:00
parent cdba06ffc2
commit 70cbc7d0ea
6 changed files with 10 additions and 105 deletions

5
debian/changelog vendored
View File

@ -1,5 +1,8 @@
linux (4.19~rc3-1~exp2) UNRELEASED; urgency=medium
linux (4.19~rc4-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate
[ Ben Hutchings ]
* debian/control: Add arch-qualification to build-dependencies for linux-perf
(Closes: #908519)
* debian/control: Build-depend on libunwind-dev instead of libunwind8-dev

View File

@ -1,31 +0,0 @@
From: Bastian Blank <waldi@debian.org>
Date: Sun, 11 Feb 2018 06:24:15 +0000
Subject: liblockdep: Stub NMI watchdog reset
Forwarded: https://lore.kernel.org/lkml/20180828233721.GF18030@decadent.org.uk/T/#u
lockdep.c now includes <linux/nmi.h> and requires touch_nmi_watchdog(),
so provide those for liblockdep.
Fixes: 88f1c87de11a ("locking/lockdep: Avoid triggering hardlockup from ...")
[bwh: Write a longer description]
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
tools/include/linux/nmi.h | 12 ++++++++++++
1 file changed, 12 insertions(+)
create mode 100644 tools/include/linux/nmi.h
--- /dev/null
+++ b/tools/include/linux/nmi.h
@@ -0,0 +1,12 @@
+/* SPDX-License-Identifier: GPL-2.0 */
+/*
+ * linux/include/linux/nmi.h
+ */
+#ifndef LINUX_NMI_H
+#define LINUX_NMI_H
+
+static inline void touch_nmi_watchdog(void)
+{
+}
+
+#endif

View File

@ -1,31 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 03 Jul 2018 06:19:07 +0100
Subject: liblockdep: Stub task_struct::state
Forwarded: https://lore.kernel.org/lkml/20180828233752.GG18030@decadent.org.uk/T/#u
lockdep_print_held_locks() now checks task_struct::state. Define it
so that all tasks are assumed to be running, since we have no
reasonble way to tell in user-space.
Fixes: 8cc05c71ba5f ("locking/lockdep: Move sanity check to inside ...")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/include/linux/lockdep.h
+++ b/tools/include/linux/lockdep.h
@@ -31,12 +31,16 @@ struct task_struct {
gfp_t lockdep_reclaim_gfp;
int pid;
char comm[17];
+ long state;
};
extern struct task_struct *__curr(void);
#define current (__curr())
+/* lockdep checks task_struct::state == TASK_RUNNING */
+#define TASK_RUNNING 0
+
static inline int debug_locks_off(void)
{
return 1;

View File

@ -1,33 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 28 Aug 2018 18:47:31 +0100
Subject: locking/lockdep: Delete unnecesary #include
Forwarded: https://lore.kernel.org/lkml/20180828203315.GD18030@decadent.org.uk/T/#u
Commit c3bc8fd637a9 ("tracing: Centralize preemptirq tracepoints and u
nify their usage") added the inclusion of <trace/events/preemptirq.h>.
liblockdep doesn't have a stub version of that header so now fails to
build.
However, commit bff1b208a5d1 ("tracing: Partial revert of "tracing:
Centralize preemptirq tracepoints and unify their usage"") removed the
use of functions declared in that header. So delete the #include.
Fixes: c3bc8fd637a9 ("tracing: Centralize preemptirq tracepoints ...")
Fixes: bff1b208a5d1 ("tracing: Partial revert of "tracing: Centralize ...")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
kernel/locking/lockdep.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index e406c5fdb41e..dd13f865ad40 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -55,7 +55,6 @@
#include "lockdep_internals.h"
-#include <trace/events/preemptirq.h>
#define CREATE_TRACE_POINTS
#include <trace/events/lock.h>

View File

@ -9,7 +9,7 @@ version-dependent name. And do the same for trace.]
--- a/tools/perf/Makefile.perf
+++ b/tools/perf/Makefile.perf
@@ -750,23 +750,23 @@ endif
@@ -759,23 +759,23 @@ endif
install-tools: all install-gtk
$(call QUIET_INSTALL, binaries) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'; \
@ -37,9 +37,9 @@ version-dependent name. And do the same for trace.]
- $(call QUIET_INSTALL, libexec) \
- $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)'
ifndef NO_LIBBPF
$(call QUIET_INSTALL, lib) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perf_include_instdir_SQ)/bpf'
@@ -804,7 +804,7 @@ ifndef NO_LIBPYTHON
$(call QUIET_INSTALL, bpf-headers) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perf_include_instdir_SQ)/bpf'; \
@@ -811,7 +811,7 @@ ifndef NO_LIBPYTHON
endif
$(call QUIET_INSTALL, perf_completion-script) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d'; \
@ -48,7 +48,7 @@ version-dependent name. And do the same for trace.]
$(call QUIET_INSTALL, perf-tip) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(tip_instdir_SQ)'; \
$(INSTALL) Documentation/tips.txt -t '$(DESTDIR_SQ)$(tip_instdir_SQ)'
@@ -829,7 +829,7 @@ install-python_ext:
@@ -836,7 +836,7 @@ install-python_ext:
# 'make install-doc' should call 'make -C Documentation install'
$(INSTALL_DOC_TARGETS):
@ -84,7 +84,7 @@ version-dependent name. And do the same for trace.]
--- a/tools/perf/util/Build
+++ b/tools/perf/util/Build
@@ -192,6 +192,7 @@ CFLAGS_libstring.o += -Wno-unused-pa
@@ -193,6 +193,7 @@ CFLAGS_libstring.o += -Wno-unused-pa
CFLAGS_hweight.o += -Wno-unused-parameter -DETC_PERFCONFIG="BUILD_STR($(ETC_PERFCONFIG_SQ))"
CFLAGS_parse-events.o += -Wno-redundant-decls
CFLAGS_header.o += -include $(OUTPUT)PERF-VERSION-FILE

View File

@ -146,9 +146,6 @@ bugfix/all/perf-documentation-fix-out-of-tree-asciidoctor-man-page-generation.pa
bugfix/all/tools-build-remove-bpf-run-time-check-at-build-time.patch
bugfix/all/cpupower-bump-soname-version.patch
bugfix/all/cpupower-fix-checks-for-cpu-existence.patch
bugfix/all/lockdep-stub-nmi-watchdog-reset.patch
bugfix/all/lockdep-stub-task_struct-state.patch
bugfix/all/locking-lockdep-delete-unnecesary-include.patch
bugfix/all/tools-lib-api-fs-fs.c-fix-misuse-of-strncpy.patch
bugfix/all/usbip-fix-misuse-of-strncpy.patch
bugfix/x86/tools-x86_energy_perf_policy-fix-uninitialized-varia.patch