[armhf] Enable AHCI_IMX in armmp+lpae flavours.

Include the resulting module in the sata-modules udeb.

Add one recommended upstream fix which is in libata.git for v3.13.

svn path=/dists/trunk/linux/; revision=20847
This commit is contained in:
Ian Campbell 2013-12-04 08:28:32 +00:00
parent 584007f3e8
commit 7023045441
5 changed files with 48 additions and 0 deletions

3
debian/changelog vendored
View File

@ -31,6 +31,9 @@ linux (3.12.2-1~exp1) UNRELEASED; urgency=low
[ Bastian Blank ]
* Use compiler name instead of Linux version in compiler meta-packages.
[ Ian Campbell ]
* [armhf]: Enable AHCI_IMX in armmp+lpae flavours.
-- Ben Hutchings <ben@decadent.org.uk> Fri, 22 Nov 2013 00:41:09 +0000
linux (3.12-1~exp1) experimental; urgency=low

View File

@ -117,6 +117,7 @@ CONFIG_OMAP_PM_NOOP=y
## file: drivers/ata/Kconfig
##
CONFIG_SATA_AHCI_PLATFORM=m
CONFIG_AHCI_IMX=m
CONFIG_SATA_HIGHBANK=m
CONFIG_PATA_IMX=m
CONFIG_PATA_PLATFORM=m

View File

@ -1,4 +1,5 @@
#include <sata-modules>
ahci_platform
ahci_imx
sata_highbank

View File

@ -0,0 +1,42 @@
From 10becdb402af4fd4808a0491a726b96128c41076 Mon Sep 17 00:00:00 2001
From: Marek Vasut <marex@denx.de>
Date: Mon, 25 Nov 2013 09:47:00 +0100
Subject: [PATCH] ahci: imx: Explicitly clear IMX6Q_GPR13_SATA_MPLL_CLK_EN
We must clear this IMX6Q_GPR13_SATA_MPLL_CLK_EN bit on i.MX6Q, otherwise
Linux will fail to find the attached drive on some boards.
This entire fix was:
Reported-by: Eric Nelson <eric.nelson@boundarydevices.com>
Signed-off-by: Marek Vasut <marex@denx.de>
Reviewed-by: Shawn Guo <shawn.guo@linaro.org>
Cc: Richard Zhu <r65037@freescale.com>
Cc: Linux-IDE <linux-ide@vger.kernel.org>
Signed-off-by: Tejun Heo <tj@kernel.org>
Cc: stable@vger.kernel.org
---
drivers/ata/ahci_imx.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Index: linux/drivers/ata/ahci_imx.c
===================================================================
--- linux.orig/drivers/ata/ahci_imx.c 2013-11-29 19:28:26.000000000 +0000
+++ linux/drivers/ata/ahci_imx.c 2013-12-03 19:42:59.693982150 +0000
@@ -60,7 +60,7 @@
/*
* set PHY Paremeters, two steps to configure the GPR13,
* one write for rest of parameters, mask of first write
- * is 0x07fffffd, and the other one write for setting
+ * is 0x07ffffff, and the other one write for setting
* the mpll_clk_en.
*/
regmap_update_bits(imxpriv->gpr, 0x34, IMX6Q_GPR13_SATA_RX_EQ_VAL_MASK
@@ -71,6 +71,7 @@
| IMX6Q_GPR13_SATA_TX_ATTEN_MASK
| IMX6Q_GPR13_SATA_TX_BOOST_MASK
| IMX6Q_GPR13_SATA_TX_LVL_MASK
+ | IMX6Q_GPR13_SATA_MPLL_CLK_EN
| IMX6Q_GPR13_SATA_TX_EDGE_RATE
, IMX6Q_GPR13_SATA_RX_EQ_VAL_3_0_DB
| IMX6Q_GPR13_SATA_RX_LOS_LVL_SATA2M

View File

@ -81,3 +81,4 @@ bugfix/all/rds-prevent-bug_on-triggered-by-congestion-update-to-loopback.patch
bugfix/all/ipv6-fix-headroom-calculation-in-udp6_ufo_fragment.patch
bugfix/s390/qeth-avoid-buffer-overflow-in-snmp-ioctl.patch
bugfix/all/xfs-underflow-bug-in-xfs_attrlist_by_handle.patch
bugfix/arm/ahci-imx-Explicitly-clear-IMX6Q_GPR13_SATA_MPLL_CLK_.patch