Revert "uapi: fix linux/if.h userspace compilation errors"

This patch fixes a bug but it broke compilation of radvd (see
by reverting it for stretch.
This commit is contained in:
Ben Hutchings 2017-06-09 15:27:04 +01:00
parent cb766cd661
commit 6fdb07003d
3 changed files with 1 additions and 69 deletions

1
debian/changelog vendored
View File

@ -3,6 +3,7 @@ linux (4.9.30-1+deb9u1) UNRELEASED; urgency=medium
* ipv6: Check ip6_find_1stfragopt() return value properly.
* ipv6: xfrm: Handle errors reported by xfrm6_find_1stfragopt()
* ipv6: Fix leak in ipv6_gso_segment().
* Revert "uapi: fix linux/if.h userspace compilation errors" (see #864269)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 07 Jun 2017 23:31:14 +0100

View File

@ -1,68 +0,0 @@
From: "Dmitry V. Levin" <ldv@altlinux.org>
Date: Mon, 20 Feb 2017 14:58:41 +0300
Subject: uapi: fix linux/if.h userspace compilation errors
Origin: https://git.kernel.org/linus/2618be7dccf8739b89e1906b64bd8d551af351e6
Bug-Debian: https://bugs.debian.org/822393
Include <sys/socket.h> (guarded by ifndef __KERNEL__) to fix
the following linux/if.h userspace compilation errors:
/usr/include/linux/if.h:234:19: error: field 'ifru_addr' has incomplete type
struct sockaddr ifru_addr;
/usr/include/linux/if.h:235:19: error: field 'ifru_dstaddr' has incomplete type
struct sockaddr ifru_dstaddr;
/usr/include/linux/if.h:236:19: error: field 'ifru_broadaddr' has incomplete type
struct sockaddr ifru_broadaddr;
/usr/include/linux/if.h:237:19: error: field 'ifru_netmask' has incomplete type
struct sockaddr ifru_netmask;
/usr/include/linux/if.h:238:20: error: field 'ifru_hwaddr' has incomplete type
struct sockaddr ifru_hwaddr;
This also fixes userspace compilation of the following uapi headers:
linux/atmbr2684.h
linux/gsmmux.h
linux/if_arp.h
linux/if_bonding.h
linux/if_frad.h
linux/if_pppox.h
linux/if_tunnel.h
linux/netdevice.h
linux/route.h
linux/wireless.h
As no uapi header provides a definition of struct sockaddr, inclusion
of <sys/socket.h> seems to be the most conservative and the only safe
fix available.
All current users of <linux/if.h> are very likely to be including
<sys/socket.h> already because the latter is the sole provider
of struct sockaddr definition in libc, so adding a uapi header
with a definition of struct sockaddr would create a potential
conflict with <sys/socket.h>.
Replacing struct sockaddr in the definition of struct ifreq with
a different type would create a potential incompatibility with current
users of struct ifreq who might rely on ifru_addr et al members being
of type struct sockaddr.
Signed-off-by: Dmitry V. Levin <ldv@altlinux.org>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
include/uapi/linux/if.h | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/include/uapi/linux/if.h b/include/uapi/linux/if.h
index 1158a043342a..259617a551f2 100644
--- a/include/uapi/linux/if.h
+++ b/include/uapi/linux/if.h
@@ -24,6 +24,10 @@
#include <linux/socket.h> /* for "struct sockaddr" et al */
#include <linux/compiler.h> /* for "__user" et al */
+#ifndef __KERNEL__
+#include <sys/socket.h> /* for struct sockaddr. */
+#endif
+
#if __UAPI_DEF_IF_IFNAMSIZ
#define IFNAMSIZ 16
#endif /* __UAPI_DEF_IF_IFNAMSIZ */

View File

@ -76,7 +76,6 @@ bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/kbuild-do-not-use-hyphen-in-exported-variable-name.patch
bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
bugfix/all/uapi-fix-linux-if.h-userspace-compilation-errors.patch
# Miscellaneous features
features/all/netfilter-nft_ct-add-notrack-support.patch