Reenabled IDE interrupt on Motorola Powerstack II (Utah)

Closes: #345424: linux-source-2.6.14: Missing IDE IRQ for PReP Utah (PowerstackII Pro4000)


svn path=/dists/trunk/linux-2.6/; revision=5157
This commit is contained in:
Sven Luther 2005-12-31 15:09:58 +00:00
parent 1a6b18d7be
commit 6ef0a12cd4
3 changed files with 22 additions and 2 deletions

6
debian/changelog vendored
View File

@ -7,7 +7,11 @@ linux-2.6 (2.6.14+2.6.15-rc7-0experimental.2) UNRELEASED; urgency=low
[ Frederik Schüler ]
* Fix kconfig.ml call in rules.real.
-- Kyle McMartin <kyle@debian.org> Fri, 30 Dec 2005 22:48:40 -0500
[ Sven Luther ]
* [powerpc] Readded PReP Motorola PowerStack II Utah IDE interrupt
(Closes: #345424)
-- Sven Luther <luther@debian.org> Sat, 31 Dec 2005 15:05:18 +0000
linux-2.6 (2.6.14+2.6.15-rc7-0experimental.1) experimental; urgency=low

View File

@ -0,0 +1,16 @@
#
# Description: Reenables IDE interrupt on Motorola Powerstack II (Utah)
# Patch author: Sven Luther <luther@debian.org>
# Closes: #345424: linux-source-2.6.14: Missing IDE IRQ for PReP Utah (PowerstackII Pro4000)
#
--- linux-2.6-2.6.14+2.6.15-rc7/arch/ppc/platforms/prep_pci.c.orig 2005-12-31 14:51:16.000000000 +0000
+++ linux-2.6-2.6.14+2.6.15-rc7/arch/ppc/platforms/prep_pci.c 2005-12-31 14:58:23.000000000 +0000
@@ -46,7 +46,7 @@
static char Utah_pci_IRQ_map[23] =
{
0, /* Slot 0 - unused */
- 0, /* Slot 1 - unused */
+ 4, /* Slot 1 - IDE - SL82C105 */
5, /* Slot 2 - SCSI - NCR825A */
0, /* Slot 3 - unused */
3, /* Slot 4 - Ethernet - DEC2114x */

View File

@ -21,4 +21,4 @@
+ powerpc-arch-default-powerpc.patch
+ drivers-scsi-megaraid_splitup.patch
+ powerpc-mv643xx-spinlock-fix-support.patch
+ powerpc-prep-utah-ide-interrupt.patch