Added patch from Mark Hymers to enable serial port on Xserve, but at the expense of pcmcia serial ports.

svn path=/dists/trunk/linux-2.6/; revision=7429
This commit is contained in:
Sven Luther 2006-09-17 20:31:29 +00:00
parent 66fd31dc76
commit 6df80675e1
3 changed files with 25 additions and 19 deletions

3
debian/changelog vendored
View File

@ -16,6 +16,9 @@ linux-2.6 (2.6.17+2.6.18-rc7-0experimental.1) UNRELEASED; urgency=low
[ Sven Luther ]
* [powerpc] Enabled the -prep flavour.
* [powerpc] The sisfb framebuffer device is now builtin.
* [powerpc] Updated the powerpc serial patch. This fixes the XServe serial
port, but at the cost powermac pcmcia serial cards support.
Thanks go to Mark Hymers for providing the patch.
[ Frederik Schüler ]
* Remove obsolete options from amd64 and i386 configs.

View File

@ -4,28 +4,29 @@
## DP: Description: Disables legacy serial driver on powermacs.
## DP: Patch author: Sven Luther <luther@debian.org>
## DP: Patch author: adapted from the SuSE kernel tree.
## DP: Forward ported to 2.6.17 by Mark Hymers <mark@hymers.org.uk>
## DP: Upstream status: workaround hack waiting for a clean legacy device solution.
diff -aurN a/drivers/serial/8250.c b/drivers/serial/8250.c
--- a/drivers/serial/8250.c 2005-06-17 15:48:29.000000000 -0400
+++ b/drivers/serial/8250.c 2005-06-18 12:05:39.000000000 -0400
@@ -46,6 +46,10 @@
@@ -45,6 +45,10 @@
#include <asm/io.h>
#include <asm/irq.h>
#include "8250.h"
+#ifdef CONFIG_PPC_MULTIPLATFORM
+#include <asm/processor.h>
+#ifdef CONFIG_PPC_PMAC
+#include <asm/machdep.h>
+#endif
+
#include "8250.h"
/*
* Configuration:
* share_irqs - whether we pass SA_SHIRQ to request_irq(). This option
@@ -2188,6 +2192,12 @@
@@ -2307,6 +2312,12 @@
static int __init serial8250_console_init(void)
{
+#ifdef CONFIG_PPC_MULTIPLATFORM
+ if(_machine == _MACH_Pmac) {
+#ifdef CONFIG_PPC_PMAC
+ if(machine_is(powermac)) {
+ printk("%s: nothing to do on PowerMac\n",__FUNCTION__);
+ return -ENODEV;
+ }
@ -33,16 +34,17 @@ diff -aurN a/drivers/serial/8250.c b/drivers/serial/8250.c
serial8250_isa_init_ports();
register_console(&serial8250_console);
return 0;
@@ -2491,6 +2501,12 @@
@@ -2617,6 +2628,13 @@
{
int ret, i;
+#ifdef CONFIG_PPC_MULTIPLATFORM
+ if(_machine == _MACH_Pmac) {
+ printk("%s: nothing to do on PowerMac\n",__FUNCTION__);
+ return -ENODEV;
+ }
+#ifdef CONFIG_PPC_PMAC
+ if(machine_is(powermac)) {
+ printk("%s: nothing to do on PowerMac\n",__FUNCTION__);
+ return -ENODEV;
+ }
+#endif
printk(KERN_INFO "Serial: 8250/16550 driver $Revision: 1.90 $ "
"%d ports, IRQ sharing %sabled\n", (int) UART_NR,
share_irqs ? "en" : "dis");
+
if (nr_uarts > UART_NR)
nr_uarts = UART_NR;

View File

@ -29,3 +29,4 @@
+ powerpc-mkvmlinuz-support-powerpc.patch
+ arm-iop-fix-cpuid
+ arm-get_unaligned-gcc41-const.patch
+ powerpc-serial.patch