Update to 4.19.11

Drop ARM-dts-bcm2837-Fix-polarity-of-wifi-reset-GPIOs.patch

Cleanup debian/changelog file
This commit is contained in:
Salvatore Bonaccorso 2018-12-20 08:08:22 +01:00
parent cb0da679fb
commit 6d099e7212
3 changed files with 42 additions and 56 deletions

45
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.19.10-1) UNRELEASED; urgency=medium
linux (4.19.11-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.10
@ -98,11 +98,50 @@ linux (4.19.10-1) UNRELEASED; urgency=medium
- IB/hfi1: Fix an out-of-bounds access in get_hw_stats
- bpf: fix off-by-one error in adjust_subprog_starts
- tcp: lack of available data can also cause TSO defer
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.11
- sched/pelt: Fix warning and clean up IRQ PELT config
- scsi: raid_attrs: fix unused variable warning
- [i386] staging: olpc_dcon: add a missing dependency
- [arm64] dts: qcom-apq8064-arrow-sd-600eval fix graph_endpoint warning
- [arm64] drm/msm: fix address space warning
- [armhf] pinctrl: sunxi: a83t: Fix IRQ offset typo for PH11
- aio: fix spectre gadget in lookup_ioctx
- fs/iomap.c: get/put the page in iomap_page_create/release()
- userfaultfd: check VM_MAYWRITE was set after verifying the uffd is
registered
- [arm64] dma-mapping: Fix FORCE_CONTIGUOUS buffer clearing
- block/bio: Do not zero user pages
- ovl: fix decode of dir file handle with multi lower layers
- ovl: fix missing override creds in link of a metacopy upper
- [armhf] MMC: OMAP: fix broken MMC on OMAP15XX/OMAP5910/OMAP310
- mmc: core: use mrq->sbc when sending CMD23 for RPMB
- mmc: sdhci-omap: Fix DCRC error handling during tuning
- mmc: sdhci: fix the timeout check window for clock and reset
- fuse: continue to send FUSE_RELEASEDIR when FUSE_OPEN returns ENOSYS
- [arm] mmp/mmp2: fix cpu_is_mmp2() on mmp2-dt
- [arm] dts: bcm2837: Fix polarity of wifi reset GPIOs (Closes: #911443)
- dm thin: send event about thin-pool state change _after_ making it
- dm cache metadata: verify cache has blocks in
blocks_are_clean_separate_dirty()
- dm: call blk_queue_split() to impose device limits on bios
- tracing: Fix memory leak in create_filter()
- tracing: Fix memory leak in set_trigger_filter()
- tracing: Fix memory leak of instance function hash filters
- media: vb2: don't call __vb2_queue_cancel if vb2_start_streaming failed
- [powerpc*] msi: Fix NULL pointer access in teardown code
- [powerpc*] Look for "stdout-path" when setting up legacy consoles
- drm/nouveau/kms: Fix memory leak in nv50_mstm_del()
- drm/nouveau/kms/nv50-: also flush fb writes when rewinding push buffer
- Revert "drm/rockchip: Allow driver to be shutdown on reboot/kexec"
- [x86] drm/i915/execlists: Apply a full mb before execution for Braswell
- [amd64] drm/amdkfd: add new vega10 pci ids
- drm/amdgpu: add some additional vega10 pci ids
- drm/amdgpu: update smu firmware images for VI variants (v2)
- drm/amdgpu: update SMC firmware image for polaris10 variants
- [x86] build: Fix compiler support check for CONFIG_RETPOLINE
[ Uwe Kleine-König ]
* [arm] Fix probing of 3rd gpio device on Armada 370.
* [arm] Fix reset polarity of the wifi device on Raspberry Pi 3
(Closes: #911443).
[ Ben Hutchings ]
* linux-perf: Fix build-time check for unversioned files

View File

@ -1,52 +0,0 @@
From: Stefan Wahren <stefan.wahren@i2se.com>
Date: Mon, 3 Dec 2018 19:37:08 +0100
Subject: [PATCH] ARM: dts: bcm2837: Fix polarity of wifi reset GPIOs
Origin: v4.20-rc7, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=e25b6783c7b1bb79103d4617336879423f86b05e
The commit b1b8f45b3130 ("ARM: dts: bcm2837: Add missing GPIOs of Expander")
introduced a wifi power sequence. Unfortunately the polarity of the reset
GPIOs were wrong and broke the wifi support on Raspberry Pi 3 B and
later in 3 B+. This wasn't discovered before since the power sequence
takes only effect in case the relevant MMC driver is compiled as a module.
Fixes: b1b8f45b3130 ("ARM: dts: bcm2837: Add missing GPIOs of Expander")
Cc: stable@vger.kernel.org
Reported-by: Matthias Lueschner <lueschem@gmail.com>
Link: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=911443
Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
Reviewed-by: Eric Anholt <eric@anholt.net>
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
---
arch/arm/boot/dts/bcm2837-rpi-3-b-plus.dts | 2 +-
arch/arm/boot/dts/bcm2837-rpi-3-b.dts | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/boot/dts/bcm2837-rpi-3-b-plus.dts b/arch/arm/boot/dts/bcm2837-rpi-3-b-plus.dts
index 4adb85e66be3..93762244be7f 100644
--- a/arch/arm/boot/dts/bcm2837-rpi-3-b-plus.dts
+++ b/arch/arm/boot/dts/bcm2837-rpi-3-b-plus.dts
@@ -31,7 +31,7 @@
wifi_pwrseq: wifi-pwrseq {
compatible = "mmc-pwrseq-simple";
- reset-gpios = <&expgpio 1 GPIO_ACTIVE_HIGH>;
+ reset-gpios = <&expgpio 1 GPIO_ACTIVE_LOW>;
};
};
diff --git a/arch/arm/boot/dts/bcm2837-rpi-3-b.dts b/arch/arm/boot/dts/bcm2837-rpi-3-b.dts
index c318bcbc6ba7..89e6fd547c75 100644
--- a/arch/arm/boot/dts/bcm2837-rpi-3-b.dts
+++ b/arch/arm/boot/dts/bcm2837-rpi-3-b.dts
@@ -26,7 +26,7 @@
wifi_pwrseq: wifi-pwrseq {
compatible = "mmc-pwrseq-simple";
- reset-gpios = <&expgpio 1 GPIO_ACTIVE_HIGH>;
+ reset-gpios = <&expgpio 1 GPIO_ACTIVE_LOW>;
};
};
--
2.19.2

View File

@ -79,7 +79,6 @@ bugfix/arm64/arm64-acpi-Add-fixup-for-HPE-m400-quirks.patch
bugfix/x86/x86-32-disable-3dnow-in-generic-config.patch
bugfix/x86/x86-mm-Fix-guard-hole-handling.patch
bugfix/arm/gpio-mvebu-only-fail-on-missing-clk-if-pwm-is-actual.patch
bugfix/arm/ARM-dts-bcm2837-Fix-polarity-of-wifi-reset-GPIOs.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch