[ia64] Hardcode the output of the scripts under arch/ia64/scripts so

that we can build out-of-tree modules correctly (refresh and re-add
dropped patch) (Closes: #392592)

svn path=/dists/sid/linux-2.6/; revision=15734
This commit is contained in:
Ben Hutchings 2010-05-18 01:29:21 +00:00
parent 51b5cd23c1
commit 6cb557b2f1
3 changed files with 22 additions and 8 deletions

9
debian/changelog vendored
View File

@ -1,3 +1,12 @@
linux-2.6 (2.6.32-14) UNRELEASED; urgency=low
[ Ben Hutchings ]
* [ia64] Hardcode the output of the scripts under arch/ia64/scripts so
that we can build out-of-tree modules correctly (refresh and re-add
dropped patch) (Closes: #392592)
-- Ben Hutchings <ben@decadent.org.uk> Tue, 18 May 2010 02:13:44 +0100
linux-2.6 (2.6.32-13) unstable; urgency=low
[ Frederik Schueler ]

View File

@ -1,6 +1,8 @@
--- linux-source-2.6.18/arch/ia64/Makefile.orig 2007-01-03 17:26:31.000000000 -0700
+++ linux-source-2.6.18/arch/ia64/Makefile 2007-01-03 17:57:52.000000000 -0700
@@ -28,16 +28,7 @@
diff --git a/arch/ia64/Makefile b/arch/ia64/Makefile
index e7cbaa0..c8af869 100644
--- a/arch/ia64/Makefile
+++ b/arch/ia64/Makefile
@@ -30,16 +30,7 @@ cflags-y := -pipe $(EXTRA) -ffixed-r13 -mfixed-range=f12-f15,f32-f127 \
-falign-functions=32 -frename-registers -fno-optimize-sibling-calls
CFLAGS_KERNEL := -mconstant-gp
@ -16,9 +18,9 @@
-endif
+KBUILD_CPPFLAGS += -DHAVE_WORKING_TEXT_ALIGN -DHAVE_MODEL_SMALL_ATTRIBUTE -DHAVE_SERIALIZE_DIRECTIVE
ifeq ($(call cc-version),0304)
cflags-$(CONFIG_ITANIUM) += -mtune=merced
@@ -67,7 +58,7 @@
KBUILD_CFLAGS += $(cflags-y)
head-y := arch/ia64/kernel/head.o arch/ia64/kernel/init_task.o
@@ -69,7 +60,7 @@ boot := arch/ia64/hp/sim/boot
PHONY += boot compressed check
@ -27,7 +29,7 @@
compressed: vmlinux.gz
@@ -76,9 +67,6 @@
@@ -78,9 +69,6 @@ vmlinuz: vmlinux.gz
vmlinux.gz: vmlinux
$(Q)$(MAKE) $(build)=$(boot) $@
@ -37,9 +39,11 @@
archclean:
$(Q)$(MAKE) $(clean)=$(boot)
@@ -94,5 +82,4 @@
@@ -96,7 +84,6 @@ define archhelp
echo '* compressed - Build compressed kernel image'
echo ' install - Install compressed kernel image'
echo ' boot - Build vmlinux and bootloader for Ski simulator'
- echo '* unwcheck - Check vmlinux for invalid unwind info'
endef
archprepare: make_nr_irqs_h FORCE

1
debian/patches/series/14 vendored Normal file
View File

@ -0,0 +1 @@
+ bugfix/ia64/hardcode-arch-script-output.patch