kbuild: Do not export variable name with hyphen (Closes: #833561)

This commit is contained in:
Ben Hutchings 2016-08-26 01:42:29 +01:00
parent c464b2eb4b
commit 6ab7944873
3 changed files with 50 additions and 0 deletions

1
debian/changelog vendored
View File

@ -31,6 +31,7 @@ linux (4.7.2-1) UNRELEASED; urgency=medium
* [hppa] Fix order of EREFUSED define in errno.h
* aufs: Update support patches to aufs4.7-20160822 (Closes: #834764)
* [powerpc*] ipmi: Enable IPMI_POWERNV as module (Closes: #833861)
* kbuild: Do not use hyphen in exported variable name (Closes: #833561)
[ Martin Michlmayr ]
* [armhf] Enable MMC_SDHCI_IPROC and HW_RANDOM_BCM2835 for BCM2835.

View File

@ -0,0 +1,48 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 26 Aug 2016 01:31:28 +0100
Subject: kbuild: Do not use hyphen in exported variable name
Bug-Debian: https://bugs.debian.org/833561
This definition in Makefile.dtbinst:
export dtbinst-root ?= $(obj)
should define and export dtbinst-root when handling the root dts
directory, and do nothing in the subdirectories. However, the
variable does not reliably get exported to the environment, perhaps
because its name contains a hyphen.
Rename the variable to dtbinst_root.
References: https://bugs.debian.org/833561
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/scripts/Makefile.dtbinst
+++ b/scripts/Makefile.dtbinst
@@ -14,7 +14,7 @@ src := $(obj)
PHONY := __dtbs_install
__dtbs_install:
-export dtbinst-root ?= $(obj)
+export dtbinst_root ?= $(obj)
include include/config/auto.conf
include scripts/Kbuild.include
@@ -22,7 +22,7 @@ include $(src)/Makefile
PHONY += __dtbs_install_prep
__dtbs_install_prep:
-ifeq ("$(dtbinst-root)", "$(obj)")
+ifeq ("$(dtbinst_root)", "$(obj)")
$(Q)mkdir -p $(INSTALL_DTBS_PATH)
endif
@@ -33,7 +33,7 @@ dtbinst-dirs := $(dts-dirs)
quiet_cmd_dtb_install = INSTALL $<
cmd_dtb_install = mkdir -p $(2); cp $< $(2)
-install-dir = $(patsubst $(dtbinst-root)%,$(INSTALL_DTBS_PATH)%,$(obj))
+install-dir = $(patsubst $(dtbinst_root)%,$(INSTALL_DTBS_PATH)%,$(obj))
$(dtbinst-files) $(dtbinst-dirs): | __dtbs_install_prep

View File

@ -74,6 +74,7 @@ features/arm/arm64-tegra-correct-tegra210-xusb-mailbox-interrupt.patch
bugfix/all/kbuild-use-nostdinc-in-compile-tests.patch
bugfix/all/disable-some-marvell-phys.patch
bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/kbuild-do-not-use-hyphen-in-exported-variable-name.patch
# Miscellaneous features