* debian/changelog: Update.

* debian/patches/debian/powerpc-mkvmlinuz-support-powerpc.patch: Remove.
* debian/patches/series/1~experimental.1: Update.
* debian/rules.real: Use new wrapper install support.

svn path=/dists/trunk/linux-2.6/; revision=10618
This commit is contained in:
Bastian Blank 2008-02-20 22:40:09 +00:00
parent b40f344805
commit 6ab5734649
4 changed files with 7 additions and 44 deletions

1
debian/changelog vendored
View File

@ -50,6 +50,7 @@ linux-2.6 (2.6.25~rc2-1~experimental.1) UNRELEASED; urgency=low
- Broadcom NetXtremeII 10Gb support
* Disable now broken drivers:
- Broadcom NetXtremeII 10Gb support
* [powerpc] Use new wrapper install support.
-- Gordon Farquharson <gordonfarquharson@gmail.com> Thu, 14 Feb 2008 00:25:23 -0700

View File

@ -1,40 +0,0 @@
diff --git a/arch/powerpc/Makefile b/arch/powerpc/Makefile
index 6238b58..edfbed7 100644
--- a/arch/powerpc/Makefile
+++ b/arch/powerpc/Makefile
@@ -151,13 +151,19 @@
BOOT_TARGETS = zImage zImage.initrd uImage
+BOOT_TARGETS_SPECIAL = mkvmlinuz_support_install
+
PHONY += $(BOOT_TARGETS)
+PHONY += $(BOOT_TARGETS_SPECIAL)
boot := arch/$(ARCH)/boot
$(BOOT_TARGETS): vmlinux
$(Q)$(MAKE) ARCH=ppc64 $(build)=$(boot) $(patsubst %,$(boot)/%,$@)
+$(BOOT_TARGETS_SPECIAL):
+ $(Q)$(MAKE) $(build)=$(boot) $@
+
define archhelp
@echo '* zImage - Compressed kernel image (arch/$(ARCH)/boot/zImage.*)'
@echo ' install - Install kernel using'
diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
index 8378898..dd4c803 100644
--- a/arch/powerpc/boot/Makefile
+++ b/arch/powerpc/boot/Makefile
@@ -235,3 +235,11 @@ clean-kernel := vmlinux.strip vmlinux.bin
clean-kernel += $(addsuffix .gz,$(clean-kernel))
# If not absolute clean-files are relative to $(obj).
clean-files += $(addprefix $(objtree)/, $(clean-kernel))
+
+quiet_cmd_mkvmlinuz = INSTALL mkvmlinuz support files
+ cmd_mkvmlinuz = cp -f $(filter-out FORCE,$^) $(INSTALL_MKVMLINUZ)
+
+mkvmlinuz_support_install: $(wrapperbits)
+ @mkdir -p $(INSTALL_MKVMLINUZ)
+ $(call cmd,mkvmlinuz)
+

View File

@ -3,7 +3,6 @@
+ debian/doc-build-parallel.patch
+ debian/scripts-kconfig-reportoldconfig.patch
+ debian/powerpc-mkvmlinuz-support-ppc.patch
#+ debian/powerpc-mkvmlinuz-support-powerpc.patch
+ debian/drivers-ata-ata_piix-postpone-pata.patch

9
debian/rules.real vendored
View File

@ -399,15 +399,18 @@ install-image_i386_$(FEATURESET)_$(FLAVOUR)_plain_image:
install-image_m68k_$(FEATURESET)_$(FLAVOUR)_plain_image:
install -m644 '$(DIR)/vmlinux.gz' $(INSTALL_DIR)/vmlinuz-$(REAL_VERSION)
install-image_powerpc_$(FEATURESET)_$(FLAVOUR)_plain_image: WRAPPER_INSTALL_DIR = '$(CURDIR)'/$(PACKAGE_DIR)/usr/lib/linux-image-$(REAL_VERSION)
install-image_powerpc_$(FEATURESET)_$(FLAVOUR)_plain_image:
install -m644 '$(DIR)/vmlinux' $(INSTALL_DIR)/vmlinux-$(REAL_VERSION)
ifeq ($(KERNEL_ARCH),ppc)
# TODO: GNA
$(MAKE_CLEAN) -C '$(DIR)/arch/ppc/boot' mkvmlinuz_support_install \
INSTALL_MKVMLINUZ='$(CURDIR)'/$(PACKAGE_DIR)/usr/lib/linux-image-$(REAL_VERSION)
INSTALL_MKVMLINUZ='$(WRAPPER_INSTALL_DIR)'
else
$(MAKE_CLEAN) -C '$(DIR)' mkvmlinuz_support_install \
INSTALL_MKVMLINUZ='$(CURDIR)'/$(PACKAGE_DIR)/usr/lib/linux-image-$(REAL_VERSION)
$(MAKE_CLEAN) -C '$(DIR)' bootwrapper_install \
WRAPPER_OBJDIR='$(WRAPPER_INSTALL_DIR)' \
WRAPPER_DTSDIR='$(WRAPPER_INSTALL_DIR)'/dts \
WRAPPER_BINDIR='$(WRAPPER_INSTALL_DIR)'
endif
install-image_s390_$(FEATURESET)_$(FLAVOUR)_plain_image: