Added patch from unionfs upstream to export release_open_intent symbol.

svn path=/dists/trunk/linux-2.6/; revision=10459
This commit is contained in:
Daniel Baumann 2008-02-09 10:32:36 +00:00
parent 788fea1d16
commit 6a8bdc59f0
3 changed files with 14 additions and 1 deletions

3
debian/changelog vendored
View File

@ -1,6 +1,7 @@
linux-2.6 (2.6.24-trunk1) UNRELEASED; urgency=low
* Fake version
[ Daniel Baumann ]
* Added patch from unionfs upstream to export release_open_intent symbol.
-- maximilian attems <maks@debian.org> Tue, 29 Jan 2008 22:14:41 +0100

View File

@ -0,0 +1,11 @@
diff -Naurp linux-2.6-2.6.24.orig/fs/namei.c linux-2.6-2.6.24/fs/namei.c
--- linux-2.6-2.6.24.orig/fs/namei.c 2008-01-24 22:58:37.000000000 +0000
+++ linux-2.6-2.6.24/fs/namei.c 2008-02-09 10:13:55.000000000 +0000
@@ -389,6 +389,7 @@ void release_open_intent(struct nameidat
else
fput(nd->intent.open.file);
}
+EXPORT_SYMBOL_GPL(release_open_intent);
static inline struct dentry *
do_revalidate(struct dentry *dentry, struct nameidata *nd)

View File

@ -10,6 +10,7 @@
+ debian/dfsg/drivers-net-tg3-fix-simple.patch
+ features/all/export-gfs2-locking-symbols.patch
+ features/all/export-unionfs-symbols.patch
#+ bugfix/powerpc/mv643xx-hotplug-support.patch
+ bugfix/powerpc/oldworld-boot-fix.patch