no autoload of nouveau yet

Reported-by: Julien Cristau <jcristau@debian.org>

svn path=/dists/sid/linux-2.6/; revision=15407
This commit is contained in:
Maximilian Attems 2010-03-16 22:16:11 +00:00
parent bff850f9b2
commit 69bc0c9410
3 changed files with 36 additions and 0 deletions

1
debian/changelog vendored
View File

@ -12,6 +12,7 @@ linux-2.6 (2.6.32-10) UNRELEASED; urgency=low
* Bump ABI to 4.
* [x86] Add openvz flavour.
- adds ppp support (closes: #550975)
* Prevent nouveau from autoloading until xserver-xorg-video-nouveau lands.
[ Moritz Muehlenhoff ]
* Enable CONFIG_KEYS_DEBUG_PROC_KEYS (Closes: #400932)

View File

@ -0,0 +1,34 @@
From df56b20377639fc0ca70d0de7a94f30465af9e7f Mon Sep 17 00:00:00 2001
From: maximilian attems <max@stro.at>
Date: Tue, 16 Mar 2010 23:09:10 +0100
Subject: [PATCH] prevent nouveau from udev auto loading
we need working xserver-xorg-video-nouveau to ship it,
also maybe newer nouveau.
---
drivers/gpu/drm/nouveau/nouveau_drv.c | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/drivers/gpu/drm/nouveau/nouveau_drv.c b/drivers/gpu/drm/nouveau/nouveau_drv.c
index da3b93b..2d85e31 100644
--- a/drivers/gpu/drm/nouveau/nouveau_drv.c
+++ b/drivers/gpu/drm/nouveau/nouveau_drv.c
@@ -104,6 +104,7 @@ module_param_named(fbpercrtc, nouveau_fbpercrtc, int, 0400);
#endif
static struct pci_device_id pciidlist[] = {
+/* no autoload until xserver-xorg-video-nouveau
{
PCI_DEVICE(PCI_VENDOR_ID_NVIDIA, PCI_ANY_ID),
.class = PCI_BASE_CLASS_DISPLAY << 16,
@@ -115,6 +116,7 @@ static struct pci_device_id pciidlist[] = {
.class_mask = 0xff << 16,
},
{}
+*/
};
MODULE_DEVICE_TABLE(pci, pciidlist);
--
1.5.6.5

View File

@ -49,3 +49,4 @@
- debian/drivers-ata-pata_sis-postpone-pata.patch
- debian/drivers-ata-ata_piix-postpone-pata.patch
+ debian/piix-disable-redundant-devids.patch
+ bugfix/all/drivers-gpu-nouveau-no-udev-auto-loading.patch